1PW for Mac not working since 6.7 update? [Known Issue]

When clicking on any given Login item, 1PW for Mac navigates to the login webpage but fails to populate login screen with credentials. This behavior started with 6.7 update.

AgileBits Update: A solution has been found for this problem. Please click the Proven Solution badge to view it.

1Password Version: 6.7.1
Extension Version: 4.6.4
OS Version: 10.12.4
Sync Type: Dropbox



  • I uninstalled and reinstalled Extension 4.6.4 and this fixed the problem.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @jmb679,

    I'm happy to hear it's working correctly again after uninstalling and reinstalling the extension! Thanks for following up to let us know. I don't know why it wasn't working right away after the update, but a few others have reported similar problems, so we'll investigate this and hopefully prevent it from happening again in the future.

    If you need anything else, we're here for you. Have a great weekend! :)

  • ShaftoeShaftoe
    edited April 2017

    I also uninstalled and reinstalled Extension 4.6.4 and fixed the problem. Then it didn't work again. I saw in another comment in this forum that the browser, Safari, must be closed and then 1PW would work. I did so and it worked. But then it stopped working again. I have discovered that if I want to run 1PW all I have to do is close Safari and then 1PW will work one time. To use it again, I must close Safari again. I know, this is just a work around until 1PW comes up with a fix but at least I can manage until then.
    Get to work, guys.

    BTW, 1PW is installed on my iPhones and iPads and they work flawlessly.

  • AliboronAliboron Junior Member
    edited April 2017

    Same issue here (Yosemite 10.10.5) with the 6.7.1 update (which was supposed to fix a bug): Even after uninsatlling and reinstalling, it still won't work (I had to manually sign in on the Support forum!) The correct line is selected in the dropdown menus (see pic) but that's it, it won't populate the fields. But it will open in a new Safari tab and fill in the fields when done from the main app...

  • patnannapatnanna Junior Member

    Same issue here, also started with v6.7 from MAS, macOS 10.12.4. Uninstalling/reinstalling extension and relaunching Safari appears to resolve the issue but only for a while. Next boot? Not sure, but I'll keep watching.

    I just installed the current Beta (4.6.5.b2) extension to see if that makes a difference.

  • Is it safe to assume that everybody here uses Safari as their goto browser? While we work on understanding what went wrong we have created an announcement which can be found at 1Password Safari Extension 4.6.4 not working. We will keep that updated with what we learn and any known workarounds. I apologise that whatever this is, that it managed to sneak past us in beta testing.

  • AliboronAliboron Junior Member
    edited April 2017

    Yesss! Restarting 1Password mini using the 1Password menu option Help > Troubleshooting > Restart 1Password mini as indicated on that page did the trick, at least for now (we'll see if it stick after restarting the Mac). Thanks! It's really good to have it back! ;-)

  • Hi @Aliboron,

    Please keep us updated after you next restart your Mac. Given the widespread nature of the issue(s) relating to the Safari extension and the fact that some people have reported it returning it would be useful to learn if it is affecting everybody or a percentage.

  • I use Safari and, so far, the problem has not resurfaced.

  • AliboronAliboron Junior Member
    edited April 2017

    Hi littlebobbytables,

    I restarted my Mac and everything was fine from the start, this time. Just the usual, now! ;-)

    I'm using Safari but I mostly use 1Password mini from the menu bar, which suffered the same issue as the Safari extension. Both healed after "restarting" 1Password mini...

  • patnannapatnanna Junior Member

    I think this problem actually started with extension v4.6.4 rather than App version 6.7. Sadly, I have no way to go back to v4.6.3 because I didn't keep a copy and it no longer appears to be available. Are old versions of the extension available?

    The latest beta v4.6.5b2 appears to be better. So far, since installing the beta, the problem has no reoccurred. Fingers crossed.

  • Greetings @patnanna,

    Please see our announcement, 1Password Safari Extension 4.6.4 not working as it includes steps to revert to 4.6.3 if everything else fails.

  • Darn, problem has resurfaced.

    1Password Version: 6.7.1
    Extension Version: 4.6.4
    OS Version: 10.12.4
    Sync Type: Dropbox
    Browser: Safari

  • Hello @jmb679,

    When you say it resurfaced was this by any chance after a restart of either your Mac or Safari? If it is, is the button displayed in the Safari toolbar and does it appear to be greyed out at all or do all indications suggest it looks as it normally does?

    We have included steps on how to temporarily revert to the older 4.6.3 if people are finding 4.6.4 continues to misbehave while we investigate.

  • I noticed after a restart of of my MacBook Pro first thing this morning. Yes, the 1PW button on the Safari toolbar was greyed out. Then, I quit and relaunched Safari and, voila, the problem disappeared, only to reappear shortly thereafter. 1PW Mini works all the way up to point where it brings me to the credentials screen of any particular website but it fails to populate with username and password.

  • patnannapatnanna Junior Member

    I should have waited a bit longer, but the problem returned this morning with extension v4.6.5.b2. An extension uninstall/install fixed the problem, no Safari relaunch required.

  • patnannapatnanna Junior Member

    I should have read a bit more before posting. Sorry! Thank you, littlebobbytables, for posting the instructions for reverting back to extension v4.6.3. Installing this requires a Safari relaunch. I'll keep my eyes open for news of a permanent fix. Thank you!!

  • matthew_agmatthew_ag 1Password Alumni

    Glad LittleBobby was able to help, hopefully we can get a fix for this out soon.


  • @patnanna & @jmb679,

    I have a favour to ask. You've both posted sufficient details that we know you have seen the issue of the extension working until a restart and then it breaks. This makes you ideal testers if we haven't already frustrated you beyond belief. If you're feeling adventurous would you consider trying out a new beta we released just now. I've detailed everything (I hope) in Looking for Safari users willing to help test a new beta. You can leave feedback there.

    Neither of you are under any obligation to assist of course and if you don't want to I completely understand. I only ask because despite how widespread it is we can't reproduce on our own Macs, believe me when I say we wish we could.

  • Ok

  • patnannapatnanna Junior Member

    Always happy to help. Will keep you posted!

  • brentybrenty

    Team Member
    edited May 2017

    Thank you!!! :love:

  • This is the first time I have gotten this error message. I am not exactly sure about what I did before getting this message. I think I tried to launch a Login item from within 1PW with Safari already open. Also, I think 1PW quit on me after getting the message.

    1PW.jpg 84.5K
  • When I click on "Allow" . . . that is when I get the error message noted above and, then, 1PW quits.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @jmb679 This sounds like 1Password mini is crashing and since it is not available the extension can't connect to it. Can you try launching the main 1Password app and see if everything is working properly there?

  • When clicking on any given Login item, 1PW for Mac navigates to the login webpage but fails to populate login screen with credentials.

  • matthew_agmatthew_ag 1Password Alumni

    Hey @jmb679,

    Sorry about the filling failure you're seeing. Let's try to understand if there is an issue with the connection or if the app is just unstable at the moment.

    If you go to the website directly in your browser without relying on 1Password's Go & Fill feature and then click on the 1Password browser extension button in Safari (the button within the Safari browser itself beside the web page address bar) - do you see that 1Password Mini is displayed?

    If so, do you see the correct Login item appearing just underneath the 1Password Mini search bar?

    Looking forward to hearing back.

    Best regards,

  • This is what I see.

  • But, right now, 1PW appears to be working just fine.

  • Hi @jmb679,

    Keep us updated please. If 1Password continues working the puzzle as to the precise cause may remain unsolved. If the issue returns can you try the following for me please.

    1. Restart your Mac.
    2. Open 1Password and unlock your vault.
    3. Launch Safari.
    4. Use 1Password as you normally would until the issue presents itself.
    5. Create a diagnostic report for us please and send it in, this link will guide you through the steps.

    For 1Password on your Mac

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report, a post here with the ticket ID will help us locate it and we'll get back to you :smile:

This discussion has been closed.