1Password on Mastodon

1P and dropbox sync on 6.7.1

Community Member

i see a note that 6.7.1 fixed dropbox sync issues. I am having such issues - i just noticed this issue today when i saw that one of my laptops needed a macOS update and after the update it needed a 1P update.

anyway, sync is working fine between my laptops/desktops but on iOS on 6.7.1 i can not get my dropbox vaults to sync. the settinsg page says it is syncing and then stops. when i click on sycn and i ask it to 'sync now' i got error messages. but not every time "failed to list remote data folder in dropbox". i click 'try again' and nothing helps tried force-quitting app.

it says 'last sync' is 'in progress' but i can tell my item count that it has not synced in maybe a few days

do i need to reset my data as in https://support.1password.com/dropbox-troubleshooting/ or could it be related to the new app update / Dropbox API update?

i have used 1P for many many years andI appreciate your ongoing support.

1Password Version: 6.7.1
Extension Version: Not Provided
OS Version: ios 10.3.2
Sync Type: dropbox


  • Drew_AGDrew_AG
    1Password Alumni

    Hi @helloari,

    I'm sorry you're having trouble syncing via Dropbox! The symptoms you described sound like a bug from version 6.7, but our developers fixed that in 6.7.1, so I'm not sure why that would be happening.

    Instead of resetting your sync data in Dropbox, you could start by simply disabling and re-enabling the sync settings on your iOS device:

    • On your iOS device, open 1Password and go to Settings > Sync > Primary > Sync Service.
    • Tap Disable Sync and confirm you want to disable it.
    • In the sync settings, tap Start Syncing and choose Sync with Dropbox.
    • Tap on your Dropbox account name.
    • When asked to choose a vault, choose the sync file for that vault.
    • Enter your master password if prompted.
    • Allow Dropbox to complete the sync.
    • If you have other vaults that also sync via Dropbox and have the same problem, repeat the above steps for those vaults.

    Does that help at all? Let us know how it goes and if you have any questions. :)

  • helloarihelloari
    Community Member

    i chose a vault and it says 'please wait downloading encryption keys and item details'. those words are stilling here on my iPhone screen for 5 min - is that normal? i have 3000 items (101MB archive) but not sure if it should be taking this long for this one step?
    ok, i canceld it after 10+ minutes and tried again. still hanging.
    what's next?

    i do hve two vaults - both in dropbox FYI

  • helloarihelloari
    Community Member

    my vault is called "1Password.agilekeychain" - should i troubleshoot by switching sync format to the OPVault format? https://support.1password.com/switch-to-opvault/

  • BenBen

    Team Member

    I would definitely recommend using OPVault. I'm not sure it'll make any difference for this issue, but it is a newer and more robust format. Please give it a try and see if that helps; if not please follow the rest of the troubleshooting guide (reset) as you were originally planning.



  • helloarihelloari
    Community Member

    ok, i actually reset my iPhone since i had the sim unlocked and now it seems to be working. my 2nd vault is syncing. but when i go to resync my main vault it tells my it's only 97% similar (since i edited many items in the last week since this issue happened) and i'm not sure if it's safe to sync again - will it copy my phoen items to my dropbox vault? will it reimport the 50+ items that i trashed recently?

    shoudl i just delete the phoen vault and re-import from scratch? i see a button to delete my 2nd vault but not the primary vault.

    thanks for your guidance. i will wait to hear back from you before trying the OPVault update in case that might cause problems with a sync...

  • BenBen

    Team Member


    1Password will attempt to merge the vaults, but it never hurts to make a backup before making any further changes:

    1Password backups

    I hope that helps!


  • helloarihelloari
    Community Member

    update: so i have 3 macOS devices and 3 iOS. friday I noticed one of my iOS devices was on 1P 6.7 (and sync was working fine) but i updated it to 1P 6.7.1. then it was still working fine AND my main IOS device that caused all this trouble in the first place started working. it did a sync - the first in maybe 2 weeks. however when i kept testing it started giving more dropbox errors. i checked again now and still it's giving errors and is not syncing the primay vault - but the 2nd vault is fine.

    should i just remove all vaults form that device and try adding them again? or do OPVault? or the other dropbox troubleshooting issues? it seems connected to the iOS update so maybe those bugs are not all worked out?

  • BenBen

    Team Member

    should i just remove all vaults form that device and try adding them again? or do OPVault?

    I would suggest doing both of those things (after making backups). Note that when you switch to OPVault all devices will need to be reconnected (as the source file for sync will be different -- Keychain.opvault vs Keychain.agilekeychain).

    it seems connected to the iOS update so maybe those bugs are not all worked out?

    Possible, but I'd think if we had a bug with syncing with Dropbox we'd be getting a lot more feedback. :)

    Please let me know how it turns out.


This discussion has been closed.