App locks even tho I have it set for 90 min

Options
windy_appleseed
windy_appleseed
Community Member

Hi all,

I would like 1Password to stay open on MacBook for 90 minutes, and I've set that in preferences. However, it's often locked way before then, sometimes within ten minutes.

Thanks in advance for advice / help,


1Password Version: 6.8
Extension Version: 4.6.7
OS Version: 10.12.6
Sync Type: Not Provided

Comments

  • sjk
    sjk
    1Password Alumni
    Options

    Hi @windy_appleseed, and welcome to the forum with your fun username. :lol:

    Sounds like at least one of the other auto-lock settings is causing 1Password to lock sooner, overriding your Lock after computer is idle for 90 minutes setting. With others, if any, do you have enabled?

  • windy_appleseed
    windy_appleseed
    Community Member
    edited August 2017
    Options

    Thanks for the reply ... tried to past screenshot but it didn't work. Basically, it's the same as in your example except that 'Lock when screen saver is activated' is not selected.

    What do you think?

  • sjk
    sjk
    1Password Alumni
    Options

    Thanks for that info, @windy_appleseed.

    Your description is great, without the screenshot. I normally add one simply by dragging it into my draft comment from where it was saved (e.g. Desktop) after taking it using one of these methods:

    How to take a screenshot on your Mac - Apple Support

    I'm curious what happens if you do it like that, although let's first focus on your primary issue -- why 1Password is locking more often than you expect it to.

    When you've discovered 1Password is locked before your Mac has been idle for under 90 minutes, was your Mac ever asleep or did you use fast user switching during that time? Disabling the Lock on sleep and/or Lock when fast user switching would prevent either/both of those from causing 1Password to lock.

    From your first post:

    I would like 1Password to stay open on MacBook for 90 minutes, and I've set that in preferences.

    Do you remember if you were running 1Password 6.8 when you set that 90 minute value? There are issues with changing some preference settings in 6.8 that we expect to be fixed in the next update, so that might what's causing your 90 minute setting not to work properly.

    Wish I had a solution for you right now without those new questions and further troubleshooting. Thanks in advance for the answers; I'm sure we can get this figured out and fixed for you.

  • windy_appleseed
    windy_appleseed
    Community Member
    Options

    Thanks once again for your reply ....

    — Yes, I was running 1Password 6.8 when I set the 90 minute value ... I'm new to 1Password (several weeks), so I believe that's the version I downloaded

    — I don't switch users, so fast switching isn't an issue

    — I have hard disc sleep deselected in System Preferences, although the display will go dark after 10 minutes of inactivity

    windy_appleseed

  • rudy
    Options

    @windy_appleseed,

    what about display sleep in System Preferences -> Energy Saver?

    lock on sleep is a combined lock on display sleep and lock on system sleep checkbox.

    Rudy

  • windy_appleseed
    windy_appleseed
    Community Member
    Options

    Here's what I have ... so display sleeps after ten minutes ... hmmm ... BTW, I'm not sure I quite understand your second sentence there ...

    Thanks once again .....

  • rudy
    Options

    @windy_appleseed,

    It means that 1Password is locking after the computer is idle for only 10 minutes due to the "lock on sleep" option being turned on.

    Rudy

  • windy_appleseed
    windy_appleseed
    Community Member
    Options

    Got it ... I unchecked that option in 1Password preferences ... we shall see .... thnx!

  • sjk
    sjk
    1Password Alumni
    Options

    You're welcome, @windy_appleseed, on Rudy's behalf.

    In addition to auto-locking,, the global Lock 1Password keyboard shortcut (Control‑Option‑Command‑L default; it can be changed in General Preferences) is handy for manually locking 1Password.

This discussion has been closed.