Windows User - 1Password extension is not working in Firefox

I am a windows user and for a few weeks now my firefox extension has stopped working. I have gone through the forums (read all about native messaging and web extensions support, etc.) . I have updated everything to the latest and my configuration is as follows;

OS: Windows 10 Pro v10.0.14393
Browser: Firefox v55.0.3
1Password: Desktop Version v4.6.2.626
1Password Extension in Firefox Browser: Installed v4.6.11.91 (Automatic Updates set on Default)

At this point I have also taken other standard troubleshooting steps.
1) Restarted 1Password
2) Restarted Firefox (Ensured that no hidden instance was running through the Task Manager)
3) Restarted Windows.

The 1Password icon in firefox always stay gray (so not clickable) and when I open any saved site through the desktop client of 1password, the site opens but the automatic fill does not happen. I have also have a hotkey set in 1password to manually fill the uid and pwd on sites and that does not work either.

Please assist. Thanks


1Password Version: 4.6.2.626
Extension Version: 4.6.11.91
OS Version: 10.0.14393
Sync Type: N/A

Comments

  • Hey @adhingra! As a preliminary step, could you choose Help > Advanced and enable Use Native Messaging protocol if not enabled already? If you do need to enable this setting, restart Firefox and give the extension another try.

    Thanks! :chuffed:

  • Thanks @bundtkate. Yes it is working after making the change you suggested. :)

    One feedback though, in the latest versions should this not be an automatic selection as part of the upgrade. I'm into product development, and my experience is that average users try to shy away from product support forums.

  • brentybrenty

    Team Member

    I hear you. Native Messaging is enabled by default, but if you'd changed settings previously updating (un)fortunately won't change them behind your back. Sorry for the hiccup there, but Im glad Kate was able to help — and we won't be seeing another change like this probably for years. :)

This discussion has been closed.