1Password on Mastodon

1Password Beta for Android (trial expired) deleted my login's data when I tried to edit it

Community Member

I'm using 1Password for Android, version 6.7.BETA-2. The beta version used to include the pro features without an unlock, but that changed recently. However, this didn't really bother me much because I usually only use it to view entries created on the PC (via Dropbox sync).

Unfortunately, today I tried to edit an entry. 1Password for Android showed the "trial expired" dialog, but somehow opened the interface for editing the entry anyway. I changed the username associated with the entry (and not the password) and tried to save it. It appeared to save successfully, but afterwards the entry's username and password disappeared. Checking later on the desktop version of 1Password confirmed that editing the entry's username deleted both the username and password. This seems like a rather serious bug.

I was fortunately able to restore the login data by using Dropbox's file history (sorting the .1password files found in the data/default folder by modify time revealed the mangled one, which I restored to pre-edit).

Trying to reproduce this now, I can't get it to open the edit interface after cancelling the "upgrade" dialog, so it seems that I might have hit a race condition of some sort.

I tested deleting an entry from Android (which it lets you do without upgrading), and the behavior is completely different - the item is moved to trash, and the username and password remain intact. So having the username and password removed from the entry is definitely odd behavior here.

1Password Version: 6.7.BETA-2
Extension Version: Not Provided
OS Version: Android 8.0.0
Sync Type: Dropbox


  • periperi

    Team Member

    Hey @kbuck! Thanks for reporting this issue! You're right that this sounds serious indeed. I haven't seen the behavior on my end, and I haven't heard of this from anyone else, so I wonder if it was a fluke as you mentioned. Do you recall seeing any toast notifications/error messages at the time?

  • kbuckkbuck
    Community Member

    @peri, unfortunately I don't recall any notifications... Given the infrequency for which I edit things, though, I wonder if this was perhaps the first thing I tried to edit after my trial had expired?

    Anyway, I haven't made any progress in solving the mystery, and restoring the file from Dropbox brought the data back anyway.

  • AGAlumBAGAlumB
    1Password Alumni

    Ouch. That would be the very definition of bad timing. I'm sorry either way, but especially if your trial expired while you were in the middle of making a change. I'm glad you had a copy of your data at least. :(

This discussion has been closed.