Chrome extension doesn't work in Vivaldi on macOS 10.12.6

I know there's a similar topic in the forum but the solution eludes me.

My problem is that when enabling the extension the button appears and disappears a few indeterminate number of times until it finally stays but remains unresponsive. The first button that appears looks different [0] than the rest appearing in the sequence [1]. The action looks similar to what is described in a clip posted on the Vivaldi forum.

I have tried reinstalling the extension but that didn't help.
It does work in Chrome, Safari and Firefox.

I've had similar problems before but don't remember how it was solved.

Vivaldi 1.14.1030.3
1Password 6.8.4
1Password extension



  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @seron,

    Are you receiving any prompts from 1Password? If you are it likely has a Get Help button that will guide you to the relevant article. If you aren't then we'll likely need to review a diagnostic report to see what is happening.

    If it looks like we'll need the diagnostic report then can you create one please and send it in. This link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. Can you post that here please to help us to keep an eye out for it. With access to the report we should be able to better assist you :smile:

  • UIP-57114-224

  • jxpx777jxpx777 Code Wrangler 1Password Alumni
    edited December 2017

    @seron According to the diagnostics report, Vivaldi's code signature is invalid. Could you drag the current to the trash, empty the trash, and then install a fresh copy?

    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

    ref: UIP-57114-224

  • I have now tried your suggestion but it does not seem correct to the problem.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    That's odd, @seron. For whatever reason, the system is telling 1Password that it can't validate the code signature. When this is the case, 1Password is very cautious and does not talk to processes that it cannot be sure of. Could you double check the code signature of the Vivaldi app like this:

    1. Launch Terminal
    2. Type the following command and press return: codesign --verify --verbose /Applications/

    Copy and paste the output that you see and we should be able to advise from there.

  • $ codesign --verify --verbose /Applications/
    /Applications/ valid on disk
    /Applications/ satisfies its Designated Requirement

  • brentybrenty 1Password Alumni

    @seron: Hmm. I wonder if App Translocation is screwing us up here. Please do the following:

    1. Drag Vivaldi to the Trash
    2. Restart your Mac
    3. Download a fresh copy of Vivaldi:
    4. Open the disk image and drag it to your Applications folder — DO NOT run it from the disk image

    That worked for me when I had a similar problem. 1.13 runs like a champ. Cheers! :)

  • edited December 2017

    I'm having this exact same problem after installing a fresh install of macOS High Sierra on my computer. I've tried all of these things and nothing's changed. When opening Vivaldi the icon flashes on and off in the address bar. It will eventually stay still but is unresponsive.

  • brentybrenty 1Password Alumni

    @dustinwilson: Thanks for getting in touch! Did you try my suggestion above? Also, be sure that you have the latest version of the 1Password app and extension as well, or they will not be able to work together:

    Let me know what you find! :)

  • I have the newest version of each. I just did a fresh install of macOS, so 1password was downloaded from the app store and when it asked if I wanted the Vivaldi extension it opened the page for me. I've done all the things before. I even removed the app and all of its preferences, restarted, and reinstalled. Same result.

  • I've gotten it to work... most of the time.

    I noticed it wasn't working in Chrome either, so I closed down all the browsers, closed 1password and 1password mini, and opened them all back up. It works, but if I restart the computer sometimes it starts that again. shrug

  • I am getting a lot of stuff like this in the console when things don't work:

    684000 [EXT:(Secondary Thread 0x7f90fc758f90):<OP4NativeMessageClient: 0x7f90fc7418d0>: pid:12089 extId:(null) browser:Vivaldi] E handshakeWithManifest:reply: | Failed to verify the connection: manifest:{
        OPNativeMessageClientArguments =     (
        OPNativeMessageClientBrowserPID = 12089;
        OPNativeMessageClientBrowserURL = "file:///Applications/";
        OPNativeMessageClientURL = "file:///Applications/";
        OPNativeMessageClientVersion = "6.8.4";
    } : NMStatic:1 NMRuntime:1 BRuntime:0 JSON:1
    <NSXPCConnection: 0x7f90fc7dbe00> connection from pid 12143: Warning: Exception caught during invocation of received message, dropping incoming message and invalidating the connection.
    Exception: *** -[__NSCFString stringByAppendingString:]: nil argument
    *** -[__NSCFString stringByAppendingString:]: nil argument
       0   CoreFoundation                      0x00007fff45f4753b __exceptionPreprocess + 171
       1   libobjc.A.dylib                     0x00007fff6c956942 objc_exception_throw + 48
       2   CoreFoundation                      0x00007fff45fd77e5 +[NSException raise:format:] + 197
       3   Foundation                          0x00007fff47f99aa0 -[NSString stringByAppendingString:] + 104
       4 0x000000010ed7e2ca + 688842
       5 0x000000010ed7ce8e + 683662
       6   Foundation                          0x00007fff48252ddb __NSXPCCONNECTION_IS_CALLING_OUT_TO_EXPORTED_OBJECT_S2__ + 12
       7   Foundation                          0x00007fff482515a8 -[NSXPCConn<…>
    684000 [EXT_NMH:(Secondary Thread 0x7f8b99e0a680):<OPNMXPCConnection: 0x7f8b99e00ac0>] E connect | XPC connection was invalidated or interrupted
  • brentybrenty 1Password Alumni
    edited December 2017

    @dustinwilson: That's really weird. Something sees to be interfering with the connection between 1Password and the browser. If you're still having trouble, the best thing to do will be to restart your Mac, reproduce the same issue, and then generate a diagnostic report so we can look at the logs to determine exactly what is happening:

    Please send it to [email protected]
    Let me know once you've sent it. Once we see it we should be able to better assist you. Thanks in advance!

    ref: RHD-24538-935

  • Sent it! Thanks!

  • daltondalton

    Team Member

    Thanks, @dustinwilson! We'll review the report and continue our conversation via email. :)

  • I have the same problem, I guess it's "normal" considering I'm using the beta version of Vivaldi. I'm using the broken 1p X instead but I would love to have ONE working as it should. :P

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @Cafeine,

    Vivaldi should work with 1Password without having to fight with it. I say this because Vivaldi is my browser of choice, indeed all my testing and development occurs with Vivaldi. Now I don't run the beta version of Vivaldi, I'm pretty content with the stable version but unless they're testing so radical alterations it shouldn't be a deal breaker in general.

    To see what we might be facing can we start with versions of everything please. By that I mean macOS/Windows, 1Password, the 1Password extension and Vivaldi. Next, can you describe the issue as detailed as you can. I certainly don't mean any offence at all but on occasion people will say they have the same problem and it will turn out to be something quite different. It might share a visible symptom but as is always maddeningly the case we have to be very precise when it comes to computers. The the devil's in the detail is never more true in my experiences then when troubleshooting software :smile:

  • Heya :)
    No problem, so here are the versions (I'm usually running "latest everything" or worse - beta stuff :P ) :

    macOS 10.13.2
    Vivaldi 1.14.1047.3
    1Password ext Beta (same problem with the normal one).
    1Password 6.8.5 (AppStore) synced subscription.

    I added a gif of the problem in action.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @Cafeine,

    That behaviour tells me the extension is attempting to connect and is failing. I'm pretty confident we can get this working based on previous queries I've worked on. Quick question, is it possible you have never run Chrome on this copy of macOS? I ask because being based on the Chromium source Vivaldi (Opera too) use a Chrome support folder for native messaging but by default I don't think they'll create the folder. That's why the steps outlined in the section titled For all browsers of that particular page ask everybody to create the folder. Much easier to ask everybody to do so than force them to check and see if they need to.

    If that doesn't help I'd love to review a diagnostic report from your Mac and see what it tells us. Ideally you would restart your Mac, launch and unlock 1Password and then launch Vivaldi. After the issue manifests itself create a diagnostic report. This link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. Can you post that here as it will help us locate it and keep the conversation going.

  • brentybrenty 1Password Alumni

    @Cafeine: I had the same problem with Vivaldi on Windows. Reinstalling the 1Password extension fixed it though. I'd definitely remove it, update Vivaldi, restart the computer, and then install a fresh copy of the extension: Let me know if that helps!

  • I checked everything and tried @brenty solution but nothing is working. Only progress is that the icon stays put after a while but is non-responsive to clics. Since I'm curious, I did open a ticket. Have fun digging. ;) support ID is [#HYV-67272-253]. I'm back to 1p X while waiting. ;)

    Thanks for the help team!

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hello @Cafeine,

    Thank you for posting the ticket ID. I've located the email and you'll hear back from us soon.

    ref: HYV-67272-253

  • Thanks to the awesome support team, 1P is perfectly happy (again) with Vivaldi (even the beta). TL;DR : had to remove / reinstall vivaldi. Did it with an older build, didn't work but it did work with this one, and since you don't wipe the prefs / settings, it's very quick to do. And the latest beta support sync so it would be "fine" to remove everything anyway. ;)

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @Cafeine,

    I have to confess, one of the things I love about macOS is the approach to applications and user data. I love how you can easily delete or replace an entire application bundle so easily if you need to for any reason. We could probably do with slightly fewer ways to store user data in the Library folder but it's great that you can back up stuff for a single application easily or remove just part of something if for some reason you need to. I'm glad to hear things are working properly and we managed to get Vivaldi (beta) to play nicely with 1Password :smile:

  • @littlebobbytables
    Could you post how the issue was resolved? I have the same problem and haven't been able to find a permanent solution. The recently released public version of Vivaldi 1.14 has the same issue as well.

  • brentybrenty 1Password Alumni

    @chocolate: If your Vivaldi installation is also messed up, you can download a fresh copy here:

    Vivaldi (stable)

    Vivaldi (beta snapshots)

    Cheers! :)

  • That doesn't help at all :(.
    Vivaldi 1.13 works fine with 1password but version 1.14 (with sync) doesn't. The extension is playing hide and seek, as shown in cafine's post.
    I already tried this:

    • create a new "test" account with admin rights
    • login to account
    • start and setup 1password with new database
    • download and install Vivaldi (1.14 with sync) to /Applications
    • start Vivaldi and install the extension

    • the extension plays hide and seek

    So basically I used a "virgin" account, which means everything was clean. But it still didn't work.

    I used the download link on this page:

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hello @chocolate,

    So I haven't figured out why updating from Vivaldi 1.13 to 1.14 breaks the code signature but if I download a fresh copy of either 1.14 or 1.15 then I find it's okay. Whatever broke in the update is likely the same cause for that particular snapshot behaving in the same way. I don't have the answer yet but thank you for bringing it to our attention. Hopefully some testing will explain what we're both seeing.

This discussion has been closed.