Non-english master password

Community Member

1password app for Mac forbids user to use any keyboard layout, other than default.
This make it pretty hard to type non-latin password(you have to expose it by typing in notes/url bar and then copy-paste inside app).

1Password Version: latest
Extension Version: latest
OS Version: latest
Sync Type: native


  • Lars
    1Password Alumni
    edited March 2018

    @zloool - 1Password will follow the localization of whatever you've set your Mac to; if your chosen language includes letters or diacriticals not found in English, setting your Mac in System Preferences to use your preferred language should allow you to use them in your Master Password as well. If you've got English set as your Mac's main language, though, then yes: there will be some characters you can't use for your Master Password.

    You should definitely not be using a Master Password that you can't type out yourself on the keyboard in your chosen language for the Mac; if you have to type it anywhere in plaintext to be able to get it to work, not only is that inconvenient, it's also considerably insecure. You'll need to either change the default language of your Mac or change your Master Password to something you can type without having to resort to cut-and-paste.

    There's also some explanation in this 1Password Support article:

    Should I use special characters in my Master Password?

This discussion has been closed.