No autofill in Firefox

Hi, I'm using 1PasswordX beta in Firefox 60 on Manjaro Linux and autofill is not working at all for me. I have to copy and paste all usernames, passwords etc. I've not seen others reporting this so I'm guessing it's not a general issue. When I hit any of the autofill buttons the fields remain empty, this is across all websites. I've tried disabling all other extensions to see if this was an issue but it didn't help. I'm currently trialling 1Password, I've been waiting for a solution for Linux (I'm not a Chrome user) so I'm glad to see 1PasswordX for Firefox. In general I really like it however for me it's not very usable with the autofill issue. Let me know if I can provide any info to assist with debugging. Thanks


1Password Version: 1Password X Firefox
Extension Version: Not Provided
OS Version: Manjaro Linux
Sync Type: Not Provided

Comments

  • dtearedteare Agile Founder

    Team Member

    Welcome to the forums, @afwGF45ty35ty! It's great to meet you. 👋

    At first glance I'm not sure what the issue could be here. It's certainly not expected behaviour so we're going to need to debug why this is happening to you. Just to be 100% sure it's not a website issue, please try generating a password for Evernote and see if it fills and if you're prompted to save a new login.

    From there let's take a look at your Browser Console to see if there are any errors or interesting logs there. You can do this by selecting the Tools > Web Developer > Browser Console menu item. There shouldn't be any sensitive information logged there (at least not from 1Password), aside from your email address and account name. So you should XXXX those out before posting the log. If you feel more comfortable emailing this instead, you can send it to [email protected] If you do email us please add a link to this thread so we can connect the dots.

    Please give those both a go and we'll take it from there.

  • I don't get any errors on the console. What I have now noticed though is strange. If I choose "use suggested password" it fills the password field successfully however trying to use my existing credentials no autofill occurs. I have 1Password X installed in chromium as well and this fills in the exact same page perfectly with my existing details.

  • dtearedteare Agile Founder

    Team Member

    That is strange.

    I wonder, does filling only fail when using the inline menu? Please try filling from the popup and see if that changes the behaviour at all.

  • I get the same results if I use the icon at the top or the pop-up below the field.

  • dtearedteare Agile Founder

    Team Member

    Huh. That's very strange indeed.

    It's a shot in the dark, but can you try a fresh Firefox profile? I know you mentioned that you tried removing your other extensions already, but perhaps there's something remaining in your profile that's unexpected. You should be able to just rename your existing directory and put it back afterwards if needed.

  • Hi all,

    I'm getting the same issue as the OP.

  • Ah! I recreated my Firefox Nightly profile (needed to at some point) and that "fixed" it.

    Wonder what caused it. 🤔

  • Good news, I've isolated this issue. Enabling "privacy.resistFingerprinting" in about:config leads to this issue. Disabling it immediately fixes the problem. I'm hoping you can resolve this, one of the reasons I use Firefox is because it's superior to Chrome from a privacy perspective. This setting does not cause issues with other password managers I have used. Thanks.

  • brentybrenty

    Team Member

    @Xorkle: That's great! Thanks for letting us know that a new profile helped. Had you maybe applied the same "privacy.resistFingerprinting" preference in the other one? Otherwise it may have simply been damaged.

  • brentybrenty

    Team Member

    @afwGF45ty35ty: That's really interesting. "privacy.resistFingerprinting" is super vague, so I was trying to find more details on what it actually does, to see how it might affect 1Password X. I wasn't able to find any definitive answers, so I'll check with others on the team to see if they know more. But I didn't notice that there seems to be a lot of controversy about this in the Firefox community, I guess because it's a collection of weird hacks to try to thwart tracking which also conflict with other extensions and websites. We'll get back to you.

  • I'm not sure whether you've seen this but there is some detail here: https://wiki.mozilla.org/Security/Fingerprinting.

    It's part of the Tor Uplift program to improve privacy in Firefox. I'm not sure whether a decision has been made however my expectation is that at some point this would be turned on by default (although perhaps only for private windows similar to the tracker blocking). I've not personally noticed any ill-effects from having it enabled for websites and extensions aside from with 1Password. Thanks for looking into this.

  • brentybrenty

    Team Member
    edited April 2018

    I'm not sure whether you've seen this but there is some detail here: https://wiki.mozilla.org/Security/Fingerprinting.

    @afwGF45ty35ty: Thank you! That looks to be fairly comprehensive. We'll dig through those bug reports and see if we can narrow it down. :)

    It's part of the Tor Uplift program to improve privacy in Firefox. I'm not sure whether a decision has been made however my expectation is that at some point this would be turned on by default (although perhaps only for private windows similar to the tracker blocking). I've not personally noticed any ill-effects from having it enabled for websites and extensions aside from with 1Password. Thanks for looking into this.

    Likewise, thank you for brining it to our attention! We've got some other issues with Private Browsing we need to sort out too, so perhaps there's some connection. Cheers! :)

  • Hi Brenty,

    Yup, I had resistFingerprinting enabled!

  • brentybrenty

    Team Member
    edited June 2018

    @Xorkle: Great! Thanks for confirming. We'll see if we can figure out what's up with that. :)

    ref: b5x-439

This discussion has been closed.