1Password X blank in Firefox

edited May 2018 in 1Password X

The beta installs fine, but when you click on the icon in the Firefox menu bar, there is a brief flash, as if a window was trying to open, but then nothing. The 1P6 extension works fine.

1Password Version: Not Provided
Extension Version: 1PX Beta 1.6.3
OS Version: OS X 10.11.6
Sync Type: Not Provided



  • brentybrenty

    Team Member

    @Dr_T: Thanks for getting in touch! Did you sign into your 1Password.com account? Nothing will work until you do that, but I'm not having any trouble getting 1Password X up and running in dev60.0b13. Try updating and see if that helps. Otherwise you may need a new profile for some reason. Let me know how it goes!

  • When I click the icon in the toolbar, there's no way to "sign in" (see attached image). The toolbar icon, once clicked, opens a new browser window that has this URL <moz-extension://fac3b104-0179-cc45-9314-cb1c5073bcce/app/app.html#/page/welcome>, but the window remains blank.

  • brentybrenty

    Team Member

    @Dr_T: Hmm. Thats really weird. Are you seeing any errors in the console? I'm on 60.0b14 now and it's still working here. Were you able to update yet? Have you tried it in a fresh profile? Try installing a new copy of 1Password X there and let me know.

  • Can't seem to find the download link for 1PXbeta. Might you send it to me? Thanks.

  • brentybrenty

    Team Member

    @Dr_T: You'll be able to find the link in the email you originally received when you signed up for the beta, but I'll shoot you a private message here in a minute with more details.

  • I reinstalled the add-on (v1.6.7) and clicked the 1PX icon in the browser toolbar. The same thing happens, namely, I see a blank white "drop-down" box that is empty, momentarily (< 1 sec), and then a URL <moz-extension://8b72341a-d3da-e34f-8976-d88136047c3a/app/app.html#/page/welcome> appears in the browser and its page never opens. I've tried to find any console logs of the event but I can't seem to do so. The 1P6 browser add-on is disabled.

  • brentybrenty

    Team Member

    @Dr_T: Can you try it in a fresh Firefox profile? That's helped others with similar issues. Let me know if that also helps in your case. :)

  • I created a new profile and now the login window opens properly and 1PX works fine. I also did this without any add-ons in Firefox. I then added add-ons one at a time. I saw no effect of the add-ons. Funny how the profile messed things up. Anything I can do to help you with this issue?

  • daltondalton

    Team Member

    Thanks for trying a new profile, @Dr_T. I'm glad 1Password X is at least working for you there. :) Does your other profile use the private browsing mode, by chance? I was just doing some experimenting on my end and was able to reproduce the behavior you're seeing consistently when I enable private browsing mode in Firefox.

  • Not that I am aware. Would you like a copy of the profile (if I can recover it)?

  • daltondalton

    Team Member

    Thanks for the kind and helpful offer, @Dr_T. The profile where the issue is present likely contains private information which I wouldn't want you sharing with me (or anyone else), so it would be best not to send a copy my way. Do you remember if any of the Firefox configuration settings were changed in that profile?

  • No config. settings were changed, of which I'm aware. Thanks for your help!

  • daltondalton

    Team Member

    Interesting. I wonder if there may have been something else interfering here, though you'd think that the issue would still be present in your fresh profile if that was the case. At any rate, I'm glad you're at least able to use 1Password X for the time being. 🙂 We'd love to hear from you if you encounter the issue again. Have a wonderful weekend!

  • Hi!

    I reinstalled the add-on (v1.6.7) and clicked the 1PX icon in the browser toolbar. The same thing happens, namely, I see a blank white "drop-down" box that is empty, momentarily (< 1 sec), and then a URL <moz-extension://8b72341a-d3da-e34f-8976-d88136047c3a/app/app.html#/page/welcome> appears in the browser and its page never opens. I've tried to find any console logs of the event but I can't seem to do so. The 1P6 browser add-on is disabled.

    Just chiming in to say I am seeing the exact same issue both with the latest Firefox Beta and Firefox Nightly versions.
    I have tried starting Firefox with a brand new profile, but the issue didn't get resolved for me.

    I am on Ubuntu 18.04, but the issue started manifesting itself before I upgraded my OS from 17.10 to 18.08

    Let me know if you need more information / screenshots / etc.
    I have moved back to Chromium for the time being, but it'd be nice to be able to use Firefox again.

  • beyerbeyer

    Team Member

    Hey Melyanna,

    Thanks for reaching out to let us know you see this issue too. Can you try the following in Firefox?

    1. Copy and paste about:debugging into your address bar of Firefox and hit enter.
    2. Check the Enable add-on debugging checkbox.
    3. Click the debug link for 1Password X under Extensions.
    4. Click the Console tab in the newly opened window.
    5. Click the 1Password logo in your menu bar (which should open that blank welcome page again(
    6. If you see any errors in red, screenshot the entire console window and upload them here or send it in an email to [email protected] with a link to this thread.

    Thanks so much! We are working to track down and resolve this issue fast as it's affecting multiple people.


  • I'm having the same issue in FF 60.0 (64 bit) from the official Ubuntu 18.04 release. Here's a screen shot of the debug window.

  • Hi,

    here is a screenshot of the console, which I am emailing to support as requested.

    Thank you

  • josegfvjosegfv Junior Member

    Hello, I am having the same issue, also using FireFox 60 in Ubuntu 18.04. Attached here also the console screenshot from the debugging. There are 3 sections in the screenshot first I had the app unlocked by going to the webpage, then with the addon working I clicked the gear icon and lock, last part is clicking the addon icon again.

  • beyerbeyer

    Team Member
    edited May 2018

    Hello everyone!

    I greatly apologize for the delay. We've discovered there is a bug in Ubuntu 18.04 which is causing all Firefox extensions with password fields not to work correctly. I've just created a post which explains the issue in detail with possible ways to work around it.

    Please let me know if you have any questions and have a great week!


  • edited May 2018

    Firefox 60.0.1 is now the stable release, and I'm experiencing this consistently. It only happens in a private browsing window for me, though.
    edit: 1Password X v1.7.3 on Windows

  • beyerbeyer

    Team Member

    @marshall_stacks: Unfortunately, Firefox doesn't support the runtime.getBackgroundPage() API in a private window. Since this isn't an issue in Google Chrome or most other Chrome-based browsers we didn't discover it until after we started alpha testing on Firefox. Since Firefox doesn't look to be adding this support for this anytime soon, we have an open issue to investigate our options to get this resolved in Firefox. I can't guarantee when we will get this knocked off our to-do list, but I'm optimistic that we can do so using a less efficient method.

    Thanks for letting us know you're a heavy user of private browsing on Firefox. I've added a link to your post as being affected by this to our tracked issue.


  • Hi,
    I'm using 1password X 1.7.3 on Linux Mint 18, Cinnamon 3.0.7 and Firefox 60.0.1 and thankfully not experiencing any of the problems above.
    Everything syncs nicely between the W10 app, Mac app and 1Password X.
    Very happy with it all.

  • brentybrenty

    Team Member

    @Colins2: Thanks for taking the time to let us know that you're enjoying 1Password X! I'm glad to hear it. Don't hesitate to reach out if you have any questions, comments, or feedback. Cheers! :chuffed:

  • I'm having the same exact problem described by @Dr_T

    I reinstalled the add-on (v1.6.7) and clicked the 1PX icon in the browser toolbar. The same thing happens, namely, I see a blank white "drop-down" box that is empty, momentarily (< 1 sec), and then a URL <moz-extension://8b72341a-d3da-e34f-8976-d88136047c3a/app/app.html#/page/welcome> appears in the browser and its page never opens. I've tried to find any console logs of the event but I can't seem to do so. The 1P6 browser add-on is disabled.

    After further investigation, I found that if 1PX is enabled I can no longer sign in on the 1password webapp (my.1password.com)
    And I get the following message:

    Cannot sign in.

    You are using an outdated version of the 1Password web app.
    Please refresh the page to update.

    But when I disable 1PX and refresh the login page, everything works perfectly.

    Application Basics
    Name: Firefox
    Version: 60.0.1
    Build ID: 20180518073241
    User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
    OS: Linux 4.16.13-2-ARCH
    Multiprocess Windows: 1/1 (Enabled by default)
    Web Content Processes: 4/4
    Stylo: content = true (enabled by default), chrome = true (enabled by default)
    Enterprise Policies: Inactive
    Google Key: Found
    Mozilla Location Service Key: Found
    Safe Mode: false
    Name: 1Password X – Password Manager
    Version: 1.7.3
    Enabled: true
    ID: {d634138d-c276-4fc8-924b-40a0ea21d284}

  • PBAdamsPBAdams
    edited June 2018

    I cannot get the production 1Password X extension (1.7.3) working in my Firefox 60.0.2 installation on macOS 10.13.5

    Clicking the 1Password X icon in my tool bar takes me to this URL: moz-extension://cd83df11-5c1b-5a4a-b35c-cb98198ef652/app/app.html#/page/welcome but displays a blank page.

    I have uninstalled and re-installed the extension several times.

    Any clues?

    Debug output:

  • teknologistteknologist Junior Member

    Exactly same issue as @PBAdams here with exactly same setup

  • Having the same issues today with the 1password extension that are described by others in this thread. Updated to Firefox 60.0.2 64 bit because I was having problems with my 1password app. The app disappeared from my PC (the install .exe was still there, but of course it didn't work to reinstall). I was able to install latest version of 1Password. And after many tries was able to get the Firefox extension to show in Firefox private browsing (which I use exclusively) BUT it shows a blank window when I click on the extension. I cannot find a setting in Firefox private the browsing options which would have caused the extension to stop working/show a blank window today. I did not have any issues using Firefox private browsing and the 1password extension in the past. Maybe it has to do with the new version of 1password that I had to install today?

    On the other hand, the extension works just fine in regular (non private browsing) Firefox.

    I really don't want to use non private browsing and am not a fan of Chrome. :(:(:(

  • brentybrenty

    Team Member

    Sorry for the trouble, folks! Unfortunately, as Beyer mentioned earlier, Firefox for some reason doesn't support the standard Web Extensions extension.getBackgroundPage() API, while Chrome does. We're looking into what we can do to work around this limitation.

    ref: b5x-352

  • Apart from 1PX issues I was having other addons issues and unexpected crashes which started getting worse with time until finally, firefox crashed 2 seconds after I launched it (even in Safe Mode) so I created a new profile.
    With the new profile, everything works perfectly 😄
    I hope this helps

  • Same problem here...

This discussion has been closed.