Firefox private browsing mode issue [Firefox doesn't support background page 1Password X depends on]

edited October 2018 in 1Password X (beta)

Hello. I noticed that my 1PasswordX extension no longer works after I click it in private mode. The pop-up would show an empty window and then disappear, thus I was unable to unlock it at all.

The debug console shows this after the pop-up disappeared: "Unable to save popup state popup.js:1:8760". Remove and re-install the extension would not restore the functionality and I had to recreate a new profile.

P.S. I saw a similar bug posting about it showing an empty window in private mode, I thought they might be related but decided to still post it since it's still happening with the latest version of the extension.

Thanks! It was great to see 1PX works on Firefox. :+1:

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided



  • brentybrenty

    Team Member
    edited April 2018

    @itszero: Hey, thanks so much for the kind words, and for participating in the beta! :)

    I'm sorry that you're having trouble there though. Just to confirm, it's working on okay with you in a "normal" window? We'll see if we can figure out how to get it to stop breaking in private mode.

    ref: b5x-352

  • It's like:

    1. It was working fine in normal window after install.
    2. Activate it in Private mode, pop-up blank and disappear.
    3. Go back to normal window, now the pop-up also appears blank and disappear.

    so in short, no it stopped working for me in normal mode too.

  • MarcusCMarcusC
    edited April 2018

    I can confirm this situation too on 18.04 Ubuntu and freshly installed beta of Firefox. Clicking on the 1PX Button it seems to open very shortly and then disapear. Even clicking like a maniac on the icon does nothing except sometimes show the login to 1PX very short.

    Is there anything I can or should provide?

    Edit: it's like nomad55 described here:

  • Can also reproduce this issue after installing it using firefox on Ubuntu 18.04 on a normal session.

  • Reinstalling the Add-on doesn't solve the problem. Currently I'm using the following add-ons too: Duckduckgo, Pinboard, uBlock origin and canvas blocker.
    Deactivating those other plugins doesn't solve the problem too. Is there any log file I can/should provide?

  • daltondalton

    Team Member

    Thanks for letting us know you're running into this behavior, everyone! We're still aware that 1Password X doesn't display correctly in private mode, however, that shouldn't affect how 1Password X displaying in a normal window.

    @itszero: Thanks for outlining the steps you followed. If you restart Firefox after trying to use 1Password X in private mode, does 1Password X still not display correctly in a normal window? Also, what OS are you using?

    @MarcusC: Thanks for sharing your experience here. Are you seeing this behavior in a normal or private window? If you go about:debugging, check "Enable add-on debugging", and click Debug for 1Password X, do you see any errors logged when opening/closing 1Password X in the toolbar?

    @samgabbay: Thanks for letting us know you're also running into this issue on Ubuntu. If you follow the debugging steps I listed for MarcusC above, do you see any errors logged when using 1Password X?

    Thanks again for being vocal about the behavior you're seeing. Have a great weekend! 🙂

  • Hi @DaltonD,
    i'm not using private-mode so it diesn't work on "normal" browser usage.

    I attached a screenshot from the console log. Sorry for some German in there, if I have to translate, please let me know.

  • Thats what i got

    Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    Source map error: TypeError: NetworkError when attempting to fetch resource.
    Resource URL: moz-extension://c6d83753-46c3-4f6f-81ef-81190ec89fc0/app/app.css
    Source Map URL:[Learn More]  (unknown)
    Unable to save popup state.  popup.js:1:154461
    Unable to save popup state.  popup.js:1:154461


  • daltondalton

    Team Member

    Thanks for those details and screenshot, @MarcusC. From the logs you kindly shared, it looks like the popup is being blocked from showing for some reason. Do you have any custom Firefox configurations set? Also, would you be willing to try using 1Password X in a fresh profile and see if you get the same behavior?

  • MarcusCMarcusC
    edited May 2018

    Hi @DaltonD, after resetting my browser (I deleted /home/username/.mozilla/firefox folder) and reinstalling firefox behaves the same.

    After installing the extention again and restarting the browser the extention won't unlock. For a second I see the message.
    If I log into the website -> it works like a charm.

    As a hint: I used the following method to install:

    The Version I get from Firefox is 60.0.b16. On my Mac with 61 (Developer Edition) the extension works like a charm.
    So I'll look if I can sort the issue on my linux out.

    EDIT: tested with current Firefox Developer Edition 61.0b2 installed as mentioned here:
    Result is the same.

  • @DaltonD sorry that I missed that message. That is correct, after restarting it still does not work. It would show the pop-up with locked vault, and the vault won't unlock. If I unlock it by going to then the extension would show an empty pop-up. I'm using Antergos Linux(Arch derivative).

  • beyerbeyer

    Team Member

    Hey @MarcusC & @itszero:

    Can you please try removing the copy of 1Password X you have and add the version now on the Firefox add-ons page?

    Are you seeing the same issue and/or error in the debugging console?



  • @beyer that works for me!

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. On behalf of beyer, you are most welcome! I'm glad to hear that did the trick. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

  • Hi there,

    I guess I am reopening this thread. I just tried the private window/session option of Firefox and for me the 1Password X windows opens but isn't filled with buttons and labels; an empty window of seemingly the right size.

    While using the debug tip that @DaltonD gave, I got this output in the console of the Developer Tools.

    e is null                                          popup.js:1
    he/</<                                             moz-extension://77d4fecf-6c97-4e70-8b66-382caa7da8c7/popup/popup.js:1:228651
    apply                                              self-hosted:4355:5
    applySafeWithoutClone            resource://gre/modules/ExtensionCommon.jsm:304:16
    applySafeWithoutClone            self-hosted:980:17
    wrapPromise/<                            resource://gre/modules/ExtensionCommon.jsm:505:13
    Unable to save popup state    popup.js:1:230753

    Funnily enough, I could login into this forum to post this while still in the private window.
    A forum popup asking for the name and password showed when clicking: "Comment as", in which I could use 1Password X.

    I have 1PasswordX version 1.7.3, on Firefox, on Linux Mint 18.3.

  • beyerbeyer

    Team Member

    @wimvmourik: Unfortunately, Firefox doesn't support the extension.getBackgroundPage() API we use in Private Browsing mode. It looks unlikely that Mozilla will change this restriction (which isn't an issue in Chrome), so we will have to work around it on our end. It's on our list currently tracked as issue #352, and hopefully, we can dedicate some time to getting this fixed sooner than later.


    ref: b5x-352

  • Has this moved up your list? I am still not able to use 1PW X in Firefox in Private mode on my Mac. I click the browser icon and the popup up appears to enter my master password, but it just a blank rectangle. A small but annoying bug. I hope this is fixed soon.

  • dtearedteare Agile Founder

    Team Member

    Hi @anna212,

    It's a good question and I wish I had a better answer, but no, we have not made any progress on this. To do so requires some fundamental changes to how things work. It's a big change and it's critical we make sure that the new approach is as secure as the current approach is, so it's not something we're taking lightly. It's unclear when we'll be able to make this a priority.

    I'm sorry I don't have a better answer for you.


  • Ok. I appreciate the update, and the honest answer.

  • brentybrenty

    Team Member

    Likewise, thanks for letting us know this is something you'd like us to work on. Perhaps we'll be able to find a solution in the future.

  • Thanks for the update to anna212. That answers my question about 1passwordX on the Mac. What is the best way to get notified when a change has been made to allow it to work in private mode?

  • brentybrenty

    Team Member

    @jpmtam: You can get notifications for this discussion by bookmarking it (click the "star" at the top). If and when we have a solution, we'll be glad to have people test it. :)

  • Got it @brenty thank you

  • brentybrenty

    Team Member

    You're very welcome! :):+1:

  • dtearedteare Agile Founder

    Team Member

    The other way is to read the release notes. The nice thing is you get automatic notifications after each update and it’s a lot more fun. 🙂

  • ejg930ejg930
    edited December 2018

    Just wanted to add another voice to those requesting better private browsing support for Firefox in 1PWX. Seems like if I unlock my vault in a normal window, then I can access my logins in a private window, but that's a clunky workaround. I've switched permanently away from Chrome and this is the big thing that's missing for me :)

  • brentybrenty

    Team Member

    Thanks for chiming in! Hopefully we'll be able to find a way to work around it in the future. Happy holidays! :)

  • Hi community, nice to meet you!

    I am not sure if this issue is related but when using Firefox Developer Edition (Windows, 66b4, 64bit) a new tab is opened with the URL of the extension when I click on the 1Password icon:

    The same can be reproduced with the regular Firefox when you start it with the command line option -private.

  • Hi @Shoe,

    Another user was reporting this and it seemed to be related the their Firefox profile. You can read the full conversation at 1Password extension does not work at all with Firefox 65 on Fedora. The solution was to reset the Firefox profile using the details provided in Mozilla's support page Refresh Firefox - reset add-ons and settings. The only problem is at the moment we're working to get 1Password X back and present in Mozilla's extension store where we're currently missing. We'll be back soon but for now it is impossible to install the Firefox version of 1Password X. Once we're back though I suspect you will find that helps.

  • Thanks @littlebobbytables, I will try this as soon as the exension is back for Firefox.

This discussion has been closed.