1Password X 1.7.0 - Citibank PH Login Page - Password Not Populated at First Try

edited April 2018 in 1Password X (beta)

1Password X version: 1.7.0
Firefox 60.0b16
Chrome 66.0.3359.139

URL: https://www.citibank.com.ph/PHGCB/JSO/signon/DisplayUsernameSignon.do

Steps to Replicate:

  1. Visit URL above
  2. On Username field, click 1Password icon and choose the Login entry
  3. Only Username is populated.


  1. On Username field, click 1Password icon and choose the Login entry again
  2. It will populate both username and password fields.

Tested both Firefox and Chrome and both exhibits the same behavior. Any inputs?

1Password Version: 1.7.0
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Not Provided


  • daltondalton

    Team Member

    Thanks for letting us know that you're seeing this behavior, @dorkcereals. I just did some testing on my end and 1Password X filled both the username and password fields when I followed the steps you kindly provided. Would you be willing to update to the latest version of 1Password X (1.8) and let me know if you're still seeing the same issue? If you are, I'll gladly investigate further and try to reproduce the behavior on my end. 🙂

  • Hi @DaltonD, thanks for this. How do I force update my 1Password X? It's already set to auto-update, but it has not updated to 1.8.1. I already updated my Firefox Beta to 61.0b3.

  • brentybrenty

    Team Member

    @dorkcereals: If you disable automatic updates for it in Firefox and then manually check that should do it. Firefox is a bit flaky with the automatic updates sometimes. :)

  • Thanks @brenty. I tried that and also tried clicking the gear icon and clicking Check for Updates, but it says No Updates Found. Is there a download link that I could use to download the latest version?

  • daltondalton

    Team Member

    I'm sorry for causing extra confusion here, @dorkcereals. It looks like you're currently using the stable version of 1Password X which is now on version 1.7.1 while the 1Password X beta is on version 1.8.1 (not currently available for Firefox). You shouldn't need the beta version to fill on Citi's website, though.

    If you'd like to update to version 1.7.1 (and future versions), you'll need to download 1Password X from AMO (https://addons.mozilla.org):

    1Password X - Password Manager - Add-ons for Firefox

    Unfortunately, we weren't able to automatically update non-AMO installations of 1Password X to the AMO version so I apologize for the extra hassle here. Once you've installed 1Password X version 1.7.1 from AMO, can you try signing in to Citi's website again and see if 1Password X is still unable to fill correctly?

  • Hi @DaltonD,

    I switched back to the stable Firefox 60 and 1Password X addon which is on 1.7.1, but I am still getting the same behavior.

  • brentybrenty

    Team Member

    @dorkcereals: Thanks for confirming. I don't have an account in the Philippines, but I was able to reproduce the same behaviour at Citi's similar site here:


    The problem seems to be that 1Password fills the username field, but while it is trying to fill the password field it is interrupted since the page modifies the username field to mask it with this ****. I'm not certain we can prevent that, so I'm glad that filling again helps (since Citi doesn't then try to re-mask the username field), but we'll look into it further to see if there's anything we can do. Thanks for bringing this to our attention! :)

    P.S: You may find that clicking the box to save your username helps a bit in the mean time.

    ref: b5x-417

  • I can report that the login at https://www.citi.com/credit-cards/citi.action is still broken. A few releases ago, I was experiencing strange behavior similar to @dorkcereals. The username would usually populate, but the password field didn't most of the time.

    Now, there is also a new problem. 1Password seems to detect the login fields as identity-related fields, and clicking the icon brings up that menu.

    However, I can still go to the Chrome toolbar, or use the keyboard shortcut to autofill the login. This works most of the time, however, occasionally it still fails to populate the password field. It might happen when I autofill too quickly after the page loads. I'm not sure.

  • brentybrenty

    Team Member

    @justin_howard: Huh. You're right. That's...different. Sorry about that! While you can click ••• to select Logins instead, we'll see what we can do to get that sorted. Thank you for reporting this!

    ref: b5x-510

This discussion has been closed.