"Suggest Password" Inline menu does not honor settings in Password Generator

I just installed Beta 1.8.4 of the Chrome extension and I've set the Password Generator to 30 characters. However the "Suggest Password" inline menu item does not seem to honor this setting, i.e. it generates a shorter password.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @Manaburner: Thanks for reaching out. I’m sorry for the confusion there! That's intentional. The inline "suggested password" feature is designed to offer a sane default that has both plenty of entropy and is compatible with most sites. The password generator is an advanced option for if you want or need to do more customization for a particular site. I hope this helps. Be sure to let me know if you have any other questions! :)

  • Hi @brenty ok thank you for clarifying this.

  • brentybrenty

    Team Member

    You're very welcome. Cheers! :chuffed:

  • Can you please make it configurable? I would rather have suggested password completely disabled as I cannot configure it and then it is just a distraction.

  • I'd love to see the advanced options of the desktop app's password generator in the 1Password X inline generator. Some sites have strict requirements, so the default settings are not an option, and I have to go back to the desktop app to generate the password.

  • brentybrenty

    Team Member

    @koskokos: I don't think we've had anyone else express a desire to disable the Suggested Password feature completely, but it's something we can consider along with everyone else's feedback. :)

  • brentybrenty

    Team Member

    @noqued: You don't have to go to the desktop app at all. After all, 1Password X is designed for primarily for when those cannot be used! 1Password X has its own Password Generator with options anyway:

    The inline Suggested Password feature will work in the vast majority of situations, but we've got this for when the defaults won't do. Cheers! :)

  • Thanks a lot. I love you!! :) I did not see this option. Thank you

  • brentybrenty

    Team Member

    I love you too! You're totally welcome. Glad that helped, and we're here if you need anything else. :chuffed:

This discussion has been closed.