Global Shortcut doesn't respond when a Basic Auth dialog is focussed

Options
pento
pento
Community Member
edited June 2018 in Mac

First off, this isn't a request for full Basic Auth support, I understand there are a bunch of reasons why it can't be done. 🙂

In 1Password 6, when a Basic Auth dialog opened, it was possible to press Cmd+Alt+\, search for, and copy the appropriate password, then paste it in the dialog. Obviously not ideal, but this was a reasonable flow.

In 1Password 7, pressing Cmd+Alt+\ while a Basic Auth dialog is open no longer opens the 1Password Mini window: I need to click on another app (or the 1Password tray icon), then find/copy the password, then switch back to the browser.

Is it possible to restore the 1Password 6 behaviour?

This is in Chrome 67.0.3396.79, I haven't tested other browsers.


1Password Version: 7.0.4
Extension Version: 4.7.1.4
OS Version: MacOS 10.13.5
Sync Type: 1Password.com

Comments

  • Henry
    Henry
    1Password Alumni
    Options

    Hi there @pento! I've got my keyboard shortcut to show 1Password Mini customized to CMD + / (forward slash) and it's working fine for me on the basic auth prompt of my router's login site, orbilogin.net. Also, the usual CMD + \ (backslash) works just fine in bringing up 1Password Mini (that's probably the one for you!).

    Once you do bring up Mini, you can easily drag-and-drop your username and password now—no need for copy and paste with 1Password 7! Just be sure to start dragging from the right side of the username/password boxes of your Login item in Mini.

    Let me know how that goes. :)

  • pento
    pento
    Community Member
    Options

    Thanks for the reply, @HenryCS. You're right, the shortcut was Cmd+\, I was mis-remembering it when I typed my original post. Unfortunately, that wasn't the problem.

    I've recorded this little screencast, showing the behaviour. When it pauses briefly at around 0:05-0:09, I'm pressing the keyboard shortcut. It's also worth noting that clicking on the tray icon doesn't open the 1Password Mini window while the basic auth dialog is open, either: it won't open until I close the basic auth dialog.

    https://cloudup.com/cCwTtUUXGuz

  • Henry
    Henry
    1Password Alumni
    Options

    Thanks for the video @pento, I see what you mean! While I'm unable to reproduce this on my own Mac, I see an issue in our issue tracker where a few other customers have reported it too. One of our developers will take a look soon and see if we can identify what's happening and try to solve it!

    One more thing: did you download 1Password 7 from our website or from the Mac App Store?

    ref: apple-1338

  • chrisminett
    chrisminett
    Community Member
    Options

    +1

    I find that even clicking the 1P Menubar icon won't respond while the browser auth dialog is active. Switching to another app or another Chrome window allows shortcut and menubar to respond again. It's only blocked while the browser window with the auth dialog has focus.

    I'm using v7.0.3 from v7.0.0 website install (previously 1P6 from app store)

  • pento
    pento
    Community Member
    Options

    @HenryCS: Thanks for the update! I installed 1Password 7 from your site, I've never installed the App Store version.

  • Henry
    Henry
    1Password Alumni
    Options

    Thanks for confirming @pento and @chrisminett, so it's not where you installed 1Password from that's making the difference.

    Next theory: could your particular Basic Auth prompts be breaking this on your devices? If both of you could try bringing up Mini while on orbilogin.net (which doesn't cause an issue for me) and report back, that would be wonderful!

  • chrisminett
    chrisminett
    Community Member
    Options

    Hi @HenryCS, that page doesn't show an auth dialog for me, just a page that says Looks like you’re not connected to your Orbi’s WiFi network.

    FWIW, I'm was using Chrome 66.0.3359.181 on macOS 10.13.5 for my earlier example.

  • Henry
    Henry
    1Password Alumni
    Options

    Sorry about that @chrisminett! Try two—go to this httpbin page, press "Try it out" then "Execute", and see if Mini responds while that basic auth prompt is showing.

  • chrisminett
    chrisminett
    Community Member
    Options

    Hi @HenryCS I still get the same behaviour - no 1P Mini window when clicking the 1P icon in the menu bar (its background flashes blue showing the click registered) or using the global shortcut Cmd+Alt+\.

    Both of these work fine when the Chrome HTTP auth dialog is not focussed.

    I've updated Chrome, now 67.0.3396.79 and I've updated 1P, now 7.0.4. I've restarted Chrome since updating 1P. Still on macOS 10.13.5.

  • pento
    pento
    Community Member
    Options

    Yah, I get the same behaviour on that httpbin example, too.

  • geodbz
    geodbz
    Community Member
    Options

    I can confirm the same behavior @chrisminett is reporting -- when there's an auth dialog 1P mini will not show up (whether clicking the taskbar or using the shortcuts). However, if I cmd+tab switch to another window (like my terminal) then 1P mini will show up.

  • Henry
    Henry
    1Password Alumni
    Options

    Thanks for confirming @chrisminett, @pento, and @geodbz! Our development team is taking a look now to see what can be done. :)

    ref: apple-1338

This discussion has been closed.