1Password can’t create a required support file.

Options
paranoidprivacy
paranoidprivacy
Community Member
edited October 2018 in Mac
To save and fill passwords in your browser, 1Password needs to be able to write to: /Users/[removed]/Library/Application Support/Mozilla/NativeMessagingHosts

I keep getting this error whenever I startup 1Password.

I followed the instructions here: https://support.1password.com/cs/native-messaging-chown/ (many times) but it doesn't work at all.

I have the latest version of 1Password, 1Password Extension, and Firefox.

Any idea of how to fix this?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • paranoidprivacy
    paranoidprivacy
    Community Member
    Options

    This fixed it for me:

    sudo chown -R "$USER":staff ~/Library/Application\ Support/Mozilla && mkdir -p ~/Library/Application\ Support/Mozilla/NativeMessagingHosts
    

    Just letting 1Password know, that the suggestion in here is NOT enough to fix the problem.

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    Thanks for the update. The support article gives the solution for pretty much everyone else affected by this kind of permissions issue, so I don't imagine we'll be changing the documentation just for your particular case. It really depends on how things are mucked up on a given system, so we tried to cover the most common scenario. But I thank you for sharing this here in the event that someone else finds it helpful. Cheers! :)

This discussion has been closed.