1password 7 mac not hiding

When I launch 1password 7 and then go to the menu 1password 7 then select hide (command + H) it does not hid the application. The only way I can see to have it launched and not visible is to minimize. Am I missing something?

1Password Version: 7.0.4
Extension Version:
OS Version: 10.13.5
Sync Type: N/A



  • HenryHenry

    Team Member

    @daemon It's hiding just fine for me. You can also just 'x' it out and 1Password Mini will stay running (and everything will stay unlocked depending on your security settings in 1Password 7 > Preferences)!

  • Thanks for the reply. I tried to quit the app and the app screen went away but it was still listed in activity monitor. I force quit that and on relaunch works fine. Odd, but I am good.

  • LarsLars Junior Member

    Team Member

    @daemon - How did you try to quit 1Password? New in version 7, you Quit 1Password 7 Completely by typing ^⌥⌘Q (or just holding down the Control and Option keys as you choose Quit from the 1Password menu). Because of the mini, the usual ⌘Q does not quit 1Password 7 entirely; instead, it closes the main window and removes the icon from the dock. But the mini will still be running in your Mac's menubar, and that's why it still shows as running in Activity Monitor. You shouldn't need to force quit. Hope this explanation helps!

  • Hi I encountered similar issue today.

    I am running the latest 1Password for Mac 7.0.4(70004001) AgileBits Store version.

    repro steps are simply open 1Password, try to hide it with ⌘H for several times (if it works, just un-hide it and then try again), and eventually it will fail to hide. And when it failed to hide, all UI on the main app is not clickable. I can still lock it from menubar, and unlock it, but just clicking on any button has no effect. To get out of this strange state, the only thing I found is to ⌘Q and re-open the app.

  • That does sound as though in some way it's linked to this rather strange state of affairs I reported.


  • LarsLars Junior Member

    Team Member

    @ghprince - Hmmm. I just tried to reproduce that, and I clicked ⌘H over thirty times without getting the kind of fail you describe. I assume you didn't try more than that, but let me know if that's not the case. I'm wondering whether you can perhaps capture this on video for us? I know that might be a lot to ask. If you can't or don't want to, please try closing other applications that could potentially interfere, and attempting to reproduce this behavior with only the bare-bones running. Let us know what you discover!

  • I, too, am unable to hide 1Password via CMD+H. It is very annoying. Is a fix in the works for this?

  • LarsLars Junior Member

    Team Member

    @tkambler - no, because it's not something any of us have been able to reproduce, and there isn't any reason it should be happening. Please restart your Mac, re-open 1Password for Mac, and then try to capture a video recording of it, if you're able to. If you can't upload it here, Dropbox is a good bet, or even a YouTube link. Also, if the problem persists, we'll need:

    1. The specific version of macOS you have installed
    2. The specific version of 1Password you're running
    3. The browser you use most and its version number
    4. The specific version of 1Password extension.

    Good luck, and thanks in advance! :)

  • okthenokthen
    edited February 2019

    This happens to me as well. Not always, but seemingly most of the time? I'm not sure. I can't remember when it started or what, i just know it happens all the time.

    It's happened again just now, and i tried restarting it a few times, and of course it continued to do it, regardless of which vault or which 'screen' was selected. It also happens whether i open 1Password directly (from Alfred or Finder) or via 1Password mini.

    In any case, it doesn't respond to the 'Hide 1Password' menu item, the 'Hide' menu item on the Dock icon, or the ⌘H keyboard shortcut. There's no beep or error or anything, it just doesn't respond.

    I checked the Console as i was trying this and it didn't say anything relevant.

    Can't remember it ever happening with any other applications.

    Here's a video: https://i.imgur.com/hfzaWQ2.mp4

    1Password 7
    Version 7.2.4 (70204000)
    AgileBits Store
    macOS 10.14 (18A391)
    Firefox 65 / 1Password extension
    (but i'm not accessing it through the extension, so i'm not sure that's relevant)

  • LarsLars Junior Member

    Team Member
    edited February 2019

    @okthen - thanks for the video! We've not been able to find reproducible steps to cause this to appear...as you mentioned in your reply, it seems to happen only to certain people, and even then, only some of the time. We'll keep investigating it, but if you can find steps that consistently reproduce the issue, let us know. If we can replicate your steps here, it'll greatly increase our chance of being able to nail down whatever's going wrong. Sorry for the inconvenience, and thanks for your patience as we work on this.

    ref: apple-3077

  • It's happening here, too, with the 1Password 7 application on Mac OS 10.14.2. No response when pressing the Hide key-combo or choosing the menu item.

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @rhodri! I'm sorry for the trouble. We're still looking into this, as we've been unable to reproduce it so far, with one exception. Are you using BetterSnapTool, or something like it, for window management on your Mac?

  • I use BetterSnapTool, & yes, it’s happening to me also.

  • ag_anaag_ana

    Team Member

    Hi @WebSanity! Thank you for the information.

    Just to make sure this is not a red herring, can you please try a quick test for me? If you temporarily quit BetterSnapTool, are you able to hide 1Password once again?

  • @ag_ana I have the same problem. I also use BetterSnapTool so naturally I suspected it. I quit it but unfortunately, 1Password still won't hide. For me it is very consistent: as soon as I have unlocked for the first time, it will refuse to hide. Doesn't matter if I lock it afterwards, it refuses to hide, both through the menu item and Cmd + H. This problem never occurs with any other app. It also didn't occur on my previous Mac where I had pretty much the same software installed. Steps to reproduce for me are very simple:

    • Open the main window
    • Unlock
    • It doesn't hide

    Note that it does hide before the first unlock! So there is a clue.

    I am not using any weird tools or customizations. I have the 1Password menu item visible in the menu bar and I use Bartender, so I tried disabling the 1Password menu item. That did not help either.

    I used some applications in full screen mode, thought that perhaps that had something to do with it. I toggled them all to windowed mode; the problem persists.

    I quit all other open windowed applications except Safari. Makes no difference.

    I am using Dark Mode, but tried switching to Light Mode. Still no difference.

    I tried to do "Hide Others" from another application. Other applications hide, but not 1Password. At least it's consistent!

    There is nothing abnormal in my system logs, as far as I can tell, and I could not find a log for 1Password.

    This is on Mojave (10.14.2) on a 2015 MBP 13 inch.

    I understand that it's difficult to reproduce it, but it can't be that uncommon. Let me know if there is any other info I can give you.

  • BenBen AWS Team

    Team Member

    Thanks for the detailed report @sbesselsen. It does seem interesting that BetterSnapTool being installed may be a common denominator. I'll have to find some time to install that and see if it allows me to reproduce the issue. Thanks again.


  • I have this problem too. I do not use BetterSnapTool.

    It’s happened for at least a year that I can remember, possibly longer. As a workaround I cam completely quit 1Password (ctrl-option-cmd-q) and restart it, then hiding works again.

    I looked up BetterSnapTool and it seems to be a window organizer. I do use Divvy which is similar.

  • BenBen AWS Team

    Team Member


    If you uninstall Divvy (temporarily) for troubleshooting purposes and restart the Mac does the shortcut work as expected?


  • 1Password 7.3.1
    MacOS 10.14.6

    i'm in a similar situation to natevancouver's. when i launch 1Password, i can hide it once. after that, it just ignores every method of telling it to hide. once i quit (just regular command-Q) and restart, i can again hide it once.

    i don't have BetterSnapTool or Divvy installed.

  • ag_anaag_ana

    Team Member

    Thank you for the information @jonmcauliffe! I am afraid I still cannot reproduce the issue on my machine, so we will keep an eye out and see if we can spot the root cause of this.

    And welcome to the forum!

  • I also have had problems hiding 1Password for a while. Here are my specs:

    1Password 7.3.2
    macOS 10.14.6 (18G95)
    Google Chrome 77.0.3865.90

    @Ben I don't use BetterSnapTool but I do use Divvy. I am very happy to confirm that uninstalling Divvy and restarting resolved the problem on my machine! Thank you!

  • LarsLars Junior Member

    Team Member

    @upsideout - glad to hear that isolated the issue. Let us know if there's anything else you need assistance with. :)

  • Same thing here, as of January 2020, Mac Catalina 10.15.2

  • BenBen AWS Team

    Team Member

    Hi @taberm

    Do you have either BetterSnapTool or Divvy installed?


  • Ben,

    Neither one of those, but I read the thread, and I can hide it after quitting completely, and then before unlocking, and after unlocking...for a while. A machine restart didn't fix it earlier. Very strange. However, now that it's hiding, I'll report back if it suddenly stops hiding again.

  • LarsLars Junior Member

    Team Member

    @taberm - sounds good. :):+1:

  • Hiding not working for me… I am using Catalina version 10.15.3

  • BenBen AWS Team

    Team Member


    Do you have BetterSnapTool, Divvy, or any other window organizer/manager installed?


  • Hi Ben… No I do not have any of those items installed on my computer… I just quit 1Password completely through the mini browser and now hiding seems to be working again... However similar to others from my past experience hiding will stop working in the near future and I will have to again completely quit 1Password… So I think there is definitely some sort of issue

  • BenBen AWS Team

    Team Member

    Thanks @BUNNYPARIS. The next time this happens, please note the time, and then generate and send us a diagnostic report:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/comment/549991/#Comment_549991
    • Your forum username
    • The time at which you noted the issue

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once I see the diagnostics I'll be able to better assist you. Thanks very much!


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file