prompt to allow accessibility under Mojave.

Options

Comments

  • JAWiv
    JAWiv
    Community Member
    Options

    One other bug I've noticed in the Mojave beta is that macOS keeps asking me to allow 1Password Extension Helper to control the computer (via System Preferences -> Security & Privacy -> Privacy -> Accessibility) but it is already enabled....

  • rudy
    Options

    I've split your comment off since it doesn't have anything do with Touch ID unlock under mojave.

    This is a known issue under Mojave and will be resolved when we remove the "automatically sign in after filling usernames and passwords" functionality from the Browser's tab. In the interim you should be able to uncheck that checkbox to cease being prompted.

  • JAWiv
    JAWiv
    Community Member
    Options

    Thanks, @rudy. Should I also uncheck 1Password Extension Helper at the System Preferences location I listed?

  • lm2807
    lm2807
    Community Member
    Options

    @rudy When you say "when we remove" does that mean you're discontinuing support of that feature altogether? Or just disabling it until it's fully functional?

  • Hi @im2807 ,

    It appears that Mojave/Safari will not allow return keystrokes to be sent from another app, so we will likely be discontinuing support for that feature.

    Regards,
    Kevin

  • lm2807
    lm2807
    Community Member
    edited July 2018
    Options

    @ag_kevin @rudy @JAWiv I was able to hack together the equivalent functionality using BetterTouchTool and AppleScript. BTT sends the keyboard shortcut that activates 1P, then immediately runs a shell script that just does this:

    sleep 0.5
    osascript -e 'tell application "System Events" to keystroke return'

    And that seems to work like a charm in Safari 12.0 (14606.1.24.40.1) under macOS 10.14 Beta (18A336e).

  • JadC
    JadC
    1Password Alumni
    Options

    Thanks for sharing @lm2807! :+1: :smile:

  • scgf
    scgf
    Community Member
    edited July 2018
    Options

    I have un-checked "automatically sign in after filling usernames and passwords" but still often get the system message asking me to allow 1Password Extension Helper to control the computer. Is there anything else I need to do? Currently I just click 'deny' and everything still works.

    I am using the latest beta - 7.1-beta 1.

  • scgf
    scgf
    Community Member
    Options

    Posted this in the main Mac forum, but I am using the beta so will post here as well.

    I unchecked the "allow 1Password Extension Helper to control the computer' setting in 1PW but still get the system message "allow 1Password Extension Helper to control the computer". I click 'deny' but will get the message again for certain logins. Is the auto-submit feature cached somewhere?

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    The bad news is that there doesn't seem to be a way around that currently. The good news is that it should be resolved in future betas (or stable). Thanks for hanging in there.

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    Posted this in the main Mac forum, but I am using the beta so will post here as well.

    @scgf: Please don't. That slows down the support process for everyone — including you. :(

  • Gilles9
    Gilles9
    Community Member
    edited July 2018
    Options

    @scgf I delete the script itself, it resolved the problem I was having.... which was the same as yours

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    Glad to hear it! Just to clarify, the script will be going away in the future anyway, so you're not missing much. Cheers! :)

This discussion has been closed.