Autofill E-mail Address as Username in New 1Password Item

Options
Eagle1156
Eagle1156
Community Member

Hello...I know this has been asked multiple times in the past (and even by myself on the iOS forum) but I wanted to ask again as there still doesn't seem to be a viable solution.

Is there any option to NOT have to type out my email address in the "username" field every time I create a new 1Password login-item while using your Mac desktop app? Almost every new account out there seems to now automatically make your email address your username and I find myself typing out the same exact thing in the "username" field of every new 1Password login-item way too many times and was just hoping by now that there was a more efficient way to do this.

I've seen in this forum some people recommend using the Identity category to help solve this problem but I don't think that helps when creating a new password/login-item WITHIN the 1Password Mac desktop app. I use a text expander in every other instance where I need to type out my email address but all text expanders and keyboard replacement shortcuts are disabled when a new item is being created in 1Password. A text replacement solves this exact issue when creating a new login item on 1Password on the iPhone, but that same function is not possible on the desktop Mac app.

Has anything been updated or introduced to hopefully address this issue? Your help and input is appreciated as always!


1Password Version: 7.0.7
Extension Version: Not Provided
OS Version: OS X 10.13.6
Sync Type: Not Provided

Comments

  • Ben
    Options

    Hi @Eagle1156

    One possible solution would be to create the login within a web browser instead of within 1Password for Mac. There you can fill identities and use text expansion (except in password fields).

    How to save a Login manually in your browser | 1Password

    I'm not aware of any plans to build a feature into 1Password to fill fields within 1Password, but that may be an idea we can consider further.

    Ben

This discussion has been closed.