Why does the CLI tell me I'm not signed in even though initial signin was successful

edited August 2018 in CLI

So I followed: https://support.1password.com/command-line-getting-started/

Upon executing op signin my-subdomain.1password.com <email> <secretkey>, I was prompted for my master password and upon entering it I received:

export OP_SESSION_my_subdomain="some token string"
# This command is meant to be used with your shell's eval function.
# Run 'eval $(op signin my_subdomain)' to sign into your 1Password account.
# If you wish to use the session token itself, pass the --output=raw flag value.

Notice how the output uses underscore; my_subdomain instead of my-subdomain.

I also received an email suggesting that I had logged in to my account using the CLI.

So it seems like login was successful.

However, I wasn't able to execute any op commands after this. Doing op list items for example, produces:

(ERROR) You are not currently signed in.

What am I doing wrong?

Update 1: I came across this thread: https://discussions.agilebits.com/discussion/94643/error-you-are-not-currently-signed-in. If I echo the token and pipe it to any op command (including signout), it works. Else, nothing works.

1Password Version: CLI 0.5.2
Extension Version: Not Provided
OS Version: OS X 10.13.5
Sync Type: Not Provided


  • rickfillionrickfillion Junior Member

    Team Member

    Hi @ashvinnarayanan,

    Have you tried eval $(op signin ....) as the output recommended in its comment?


  • cohixcohix

    Team Member

    @ashvinnarayanan This ended up being a bug, as reported in the thread you linked to. We've fixed it up, and version 0.5.3 of the command-line tool is now available to fix it. I'm sorry for the trouble, please let us know if the update fixes the issue for you!

This discussion has been closed.