Autofill using accessibilty does nothing, and other autofill problems

Community Member

I recently started a 1Password Family account and was trying to set up my kids with their vaults. I myself am a longtime KeePass user, so I am not at all familiar with 1Password, but am trying 1Password as something I thought would be easy enough for the entire family to use.

I just spent over 2.5 hours (more than half of that after the kids were supposed to be in bed) trying to set up their vaults and have them save ONE login each, and use it on the PC and an Android device to show them how it works (some of that was the fault of crappy password reset procedures on a site they're using, not the fault of 1Password). My biggest issue by far was on Android.

We tried using 1Password to log into this app:

The phone is a Samsung Galaxy S5 running the LineageOS version of Oreo. I enabled autofill, accessibility, and 1Password keyboard.

With these settings, 1Password does not seem to detect the login fields at all. I had expected a 1Password popup right away, where I could search for a login or something. Is this a bad assumption?

At this point I used the 1Password keyboard to enter the password. It took a long time to figure out I had to long-press the spacebar due to the S5 using physical buttons instead of a software nav bar; I was going to complain about this but apparently it is my fault; now I notice there is a note saying exactly that in the keyboard instructions: I'm not sure how I managed to skim past that note. Anyway, after using the keyboard to log in once, now at least 1Password knows which entry to use and I don't need to manually select an item. However, the autofill popup still did not appear.

I found this thread that suggested turning OFF autofill and letting accessibility handle it alone: I assume this has something to do with autofill being (to some extent) opt-in by the developers, which is more than a little frustrating and doesn't really bode well for adoption.

This seems to make it better. I still get no popup if I tap on the username field. If I tap on the password field, a 1Password popup appears with the correct entry! But now I am stuck, because after tapping the login entry presented in the popup (that's what I'm supposed to do, right?) the popup closes but nothing else happens. Neither login field gets filled with any content at all and the login page is still displayed. If I tap the password field again, the 1Password popup appears again, but tapping it still accomplishes nothing. If I'm reading it right, it seems similar to this thread:

So far this is the only app I've tried to autofill on Android, so I'm not sure if it's a problem with this specific app, with 1Password, or if perhaps Lineage is incompatible in some way/broke something. I'm doubtful I want to install the Beta version on my daughter's phone as suggested in one of those other threads, unless it's fairly certain to help.

Feel free to follow up either here or in email, whichever is better in this case. I'd be happy to provide more information if it would help. :-)

1Password Version: 1Password for Android, Version 6.8
Extension Version: Not Provided
OS Version: Android 8.1.0 (LineageOS)
Sync Type: Not Provided


  • periperi

    Team Member

    Hi @fritzophrenic. Thanks for reaching out! I'm sorry to hear that you've had some trouble with filling. We've just released 1Password 7 which has some improvements there, and I hope it helps.

    That said, I've installed the Animal Jam app to test this out. Unfortunately, this particular app blocks filling, so 1Password can't fill. I tried enabling split screen mode and dragging and dropping, and unfortunately their filling interface makes that impossible as well. I recommend reaching out to their development team regarding this issue. Hopefully they can allow filling in the future.

    Please let me know if you have issues with any other apps! Thanks and have a great day!

  • fritzophrenicfritzophrenic
    Community Member

    I sent an email to the address listed on the Play store for Animal Jam, I will update here if they respond.

  • AGAlumBAGAlumB
    1Password Alumni

    Sounds good! :) :+1:

  • fritzophrenicfritzophrenic
    Community Member

    About 10 days ago, after it got bounced around a little and escalated: "Thank you for contacting your support team. I will pass this suggestion along to our developers for consideration."

    No further communication.

    Oh well, at least I tried. :|

  • periperi

    Team Member

    I'm sorry to hear that, @fritzophrenic, and I hope they improve their login form so that it can work with password managers. Let me know if you notice trouble with any other apps and I'll be happy to look into it!

  • mattzabmattzab
    Community Member

    I'm having trouble with autofill in every android app. It is as if autofill is not a feature. I have to manually copy/paste everything. 1Password support team doesn't reply to my emails. Does anyone know how I can get a refund? The website talks like refunds aren't possible on subscriptions.

  • periperi

    Team Member

    Hi @mattzab. I've replied to your other thread, and I see that Andi has replied to your email. Let's keep the conversation in one place so we can more easily help out.

This discussion has been closed.