How do I disable the unlocking noise?

Options
RayHightower
RayHightower
Community Member

1Password makes a highly annoying noise every time I unlock it. The noise coincides with the rotating of the keyhole image in the app. How do I disable this noise? I've recommended 1Password to my friends and colleagues, and all enjoy the hard work that you put into the product. But now... THE NOISE!!! The noise only began recently, which makes me think it was added during a software update. Your product is has been great for years without the noise. Please tell me how to remove the noise forever. Thank you!

1Password version: 6.8.9 (689001) running on macOS v10.13.6


1Password Version: 6.8.9
Extension Version: 4.7.3.90
OS Version: macOS 10.13.6
Sync Type: Dropbox

Comments

  • @RayHightower,

    Unfortunately I don't think we're sure where the sound is coming from. 1Password itself plays no sounds directly. 1Password 3 did have a lock sound but as you show, you're on 6.8.9.

    Someone else encountered this issue last year but didn't have any luck figuring out what was causing the sound: https://discussions.agilebits.com/discussion/75229/lock-and-unlock-sounds

  • verdi1987
    verdi1987
    Community Member
    Options

    @RayHightower, is it like a sucking/swoosh sound?

  • RayHightower
    RayHightower
    Community Member
    Options

    No, it's more like a ding. Like the ringing of a slightly muffled bell.

    One more thing: The noise also occurs when I edit & save information for one of the logins. For example, when I add a note or update a URL, and then click save, the noise occurs.

  • RayHightower
    RayHightower
    Community Member
    Options

    @rudy, thanks for the response. What additional information can I share with you as we investigate this issue? I understand that you removed noises from previous versions of 1Password. However, this noise feels like part of the app. The noise coincides with the rotating lock when I open 1Password. And it occurs when I save/update login information (see the above post) within the app.

  • That is even more strange as 1Password has never made any sound when saving an item. I can see how this would be incredibly annoying, which is why we removed the lock/unlock sound from 1Password, but seeing as 1Password doesn’t generate any sounds itself anymore I’m not really sure where this sound might be coming from. As far as I’m aware, unlike Windows, macOS doesn’t have any way to tell what application is causing a sound to be played.

    One thing I might suggest is creating a new macOS user account on your Mac, and see if these sounds occur in 1Password while logged into that account.

    Thanks.

    Ben

  • @RayHightower,

    Is the sound the sound you have selected in System Preferences -> Sound -> Sound Effects for your Alert sound?

  • RayHightower
    RayHightower
    Community Member
    Options

    @rudy: The sound selected in System Preferences -> Sound -> Sound Effects (screenshot below) is "Blow", but that's not the one playing in 1Password. Even stranger, the sound played in 1Password does not appear on the list of sounds in System Preferences -> Sound -> Sound Effects.

    @ben: Per your suggestion, I created a second macOS account. When I use 1Password in that second account, no sound... it works! And when I return to my original macOS account, I get the sound. Thanks for the troubleshooting step. What have we learned from the observations? Should I un-install & re-install 1Password? And if that works, how do I prevent the sound from returning in the future?

    Thank you both for applying your brains to this puzzle. Making progress, and I'm uncertain about the next step. Recommendations welcome.

  • @RayHightower,

    I don't think re-installing will help as you're presumably launching the same application from /Applications in the other test account.

    I would see what other applications you have running in your normal account that could be causing sounds. Anything like Alfred or
    Hazel around doing background tasks?

This discussion has been closed.