Running 1Password 6.8.9 on Mac OS Mojave?

Options
tkhan
tkhan
Community Member

I have been using 1Password 6.8.9 on High Sierra. It was working great, now I have upgraded my Mac OS to Mojave (OS X 10.14), and I tried to install 6.8.9, now its not working, it is saying: "You need to have administrative privileges to install this software." Sad and Disappointing. How can I get all the passwords now?!! 😡😢


1Password Version: 6.8.9
Extension Version: Not Provided
OS Version: OS X 10.14
Sync Type: Not Provided
Referrer: forum-search:1Password 6.8.9 on Mojave

Comments

  • dan pearson
    dan pearson
    Community Member
    Options

    Administration privileges are controlled by the admin account on your computer, not by 1Password.

  • danco
    danco
    Volunteer Moderator
    Options

    And 1PW needs to be in the Applications folder, which requires administrative access.

    But I don't know why you weren't told of this during installation and given the opportunity to enter admin credentials.

    Perhaps as a matter of security, the installer is set to fail as requests for admin access could be from malware.

    If it is your own computer, you should either have only one account which will be an admin account (so I don't think the installation should have failed in that case) or to accounts, one admin and one standard (which many people think is safer) in which case you should know the admin user name and password, and should just install 1PW while logged in to that account.

    Note that admin access is required for INSTALLING, but not for use.

  • Lars
    Lars
    1Password Alumni
    Options

    Welcome to the forum, @tkhan! I'm sorry for the trouble. Are you an administrator on your Mac, but perhaps in another account? I run that way myself - an Admin account I rarely use, and then my non-admin "working" account. If you're used to having 1Password in a folder other than the main /Applications folder on your Mac, that will likely be the issue: as of 1Password 7 for Mac, since we are fully sandboxed for increased security, 1Password must be installed into your /Applications folder...which requires Admin privileges to modify. If you don't have these, ask whoever owns/administers your Mac if they can install 1Password 7 for Mac into the Applications folder. Once they do, you'll be able to use it with no further trouble in your user account (with the exception of updates, which would again need to be approved by an Admin).

This discussion has been closed.