Vivaldi: "Couldn’t connect to 1Password"

Options
andresc
andresc
Community Member

After installing the extension in Vivaldi (from the Chrome store), I click on the icon next to the address. The extension tries to connect to the app. The active application switches from Vivaldi to the 1Password app, but I end up getting a "Couldn’t connect to 1Password" error in the Vivaldi tab that opens.

(I remember that at some point there were instructions on how to deal with Chrome-like browsers, like Vivaldi or Chrome Canary, which involved going to ~/Library/Application Support or something like that, and deleting/creating files. I couldn't find them this time.)


1Password Version: 7.2.1
Extension Version: 4.7.3.90
OS Version: macOS 10.14
Sync Type: 1Password.com account

Comments

  • dannilundgren
    dannilundgren
    Community Member
    Options

    I can confirm this issue, both in Vivaldi 2.0 Stable and 2.1.1322.4 Snapshot.
    Confirmed with both standalone and Mac App Store version of 1Password 7.2.1.

    I really hope we will get a solution for this soon.

  • Lars
    Lars
    1Password Alumni
    Options

    @andresc and @dannilundgren - I'm sorry for the trouble. However, I use Vivaldi as my main "work" browser as well...and I'm not seeing this issue here, on 2.0.1309.37. So, a few things: do either one of you have content blockers turned on? Privacy Badger, uBlock Origin, anything else like that? If so, please turn them off, then restart Vivaldi. Also, if you have any extensions (disabled or not) that are listed as in violation of the Chrome Store's policies (they'll be in red), please remove those completely. Let me know if that works for you.

  • dannilundgren
    dannilundgren
    Community Member
    Options

    I have already tried a reset of the browser, and I have no other extentions installed. By the way, I forgot to mention that I am using it on a MacBook Pro running macOS 10.14.

    System diagnostics is sent to the support team.

  • Lars
    Lars
    1Password Alumni
    Options

    @dannilundgren - thanks for sending. One of us will be with you shortly.

    ref: NRB-37838-497

  • Lars
    Lars
    1Password Alumni
    Options

    @andresc - the page you're remembering is this one: https://support.1password.com/cs/native-messaging-chown/ - it's often the case that the Native Messaging Hosts folder does not exist; when that's the case, it must be created. Give that a shot, and let me know how that works for you.

  • dannilundgren
    dannilundgren
    Community Member
    Options

    @Lars Thank you for your fast responce and support. The problem got fixed, but it seemed like the command only worked after installing Chrome.

  • andresc
    andresc
    Community Member
    Options
    • chowning NativeMessagingHosts does not do anything.
    • I do have an ad blocker installed, which is not blacklisted, and the problem persists even turning it off.
  • rudy
    Options

    @andresc,

    does ~/Library/Application Support/Google/Chrome/NativeMessagingHosts exist?

  • andresc
    andresc
    Community Member
    Options

    It does. And I own it.

  • rudy
    edited October 2018
    Options

    @andresc,

    is there a 2bua8c4s2c.com.agilebits.1password.json inside it? if not can you go to 1Password -> Help -> Troubleshooting -> Restart 1Password Extension Helper ?

  • albertw
    albertw
    Community Member
    Options

    I had this problem too. In my case, I had a corresponding JSON file in ~/Library/Application Support/Vivaldi/NativeMessagingHosts, likely from older instructions on getting things to work in Vivaldi. Turns out its contents were outdated and referred to an old version of 1Password.

    Removing that file completely seemed to do the trick (also removed/reinstalled the extension, but that may be unnecessary) — it wasn't recreated upon reinstallation, so I'm guessing the extension now just relies on the one in Chrome's directory, but it may get shadowed by Vivaldi's own copy if it exists — hope that helps.

  • Lars
    Lars
    1Password Alumni
    Options

    @albertw - yep, that's entirely possible. Thanks for reporting, and glad you figured that out. :)

  • andresc
    andresc
    Community Member
    Options

    @rudy Sorry for the delay in my response. The email sank deep in the pile.
    The JSON file is inside the folder. I deleted it but nothing happened.

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    I suspect that reinstalling the browser completely will do the trick, but if you're still having trouble after that it may be worth asking on their forum. Definitely an odd issue if the Terminal solution does not help, and unfortunately it isn't possible for 1Password to correct things outside of its own bundle and support folder.

  • youcune
    youcune
    Community Member
    Options

    @andresc Do you sync with 1Password.com? I have had same problem and solved it. My account's master password contains space -- it violates 1Password.com's validation, but I was able to change the password with space via iOS application. In my case, changing master password to valid one via other device solved this problem.

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    @youcune: Can you please clarify? I have several 1Password.com accounts, all with Master Passwords that include spaces, and I've never encountered anything like that. And since the Master Password won't be used by the browser under any circumstance, I can't imagine how that would be involved.

  • youcune
    youcune
    Community Member
    Options

    @brenty Thank you for your feedback! I used to set my master password, which ENDS WITH space. This password was valid when I changed master password with iOS Application. And my master password was length of 9 letters including space. I suppose this might cause this problem.
    Now I've changed master password to valid one, I got able to connect to 1Password.

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    Ohh. Thank you for clarifying! While I have spaces in my Master Password, it certainly doesn't end with one. Definitely something to consider.

  • mikher
    mikher
    Community Member
    Options

    Thanks a lot. For me it worked now. What I did was. Uninstall extension in Vivaldi. Install Chrome. Close Chrome. Install extension in Vivaldi. Tada. Thanks again for that advice.

  • AGAlumB
    AGAlumB
    1Password Alumni
    Options

    Glad to hear that did the trick for you. Cheers! :)

This discussion has been closed.