Disabling 1Password X for specific fields/forms (web developer question)

2

Comments

  • I look forward to future development in this area. I had been using 1Password 7 and then discovered X and I love it (other than no touch ID, which they are working on) but the auto fill in everywhere is blocking me from being able to see text below the field. The press command + . image covers things up. I certainly appreciate all the hard work of the developers on such a great product.

  • ag_anaag_ana 1Password Alumni

    Thank you for the kind words @charango622! And thank you also for the feedback :)

  • @ag_jarek I have a page that allows users to add many key => value pairs, the key input is always a text input but the type of the value input may be either text or password if the user has chosen to encrypt that key pairs value. I think this conflicts with your point above
    "The form in question has at least one field that appears to be a password and at least one field that appears to be a username". Do you have any suggestions for getting around 1Password extension showing for this sort of form?

  • ag_jarekag_jarek

    Team Member

    @hendore hmm, that's a tough one. Your best option for now is going to be to use the "Hide on this page" feature:

    This will hide 1Password on whatever page you happen to be on. (Click the "Suggestions" bar at the bottom of the menu that appears under the field to get here.)

  • This is actually very sad story for web developers.

  • ag_yaronag_yaron 1Password Alumni

    It is indeed a sad story, considering how the autocomplete="off" attribute was abused to the point where password managers had to adapt to ignore it... we're doing our best to find the middle ground though! Hopefully things will improve further down the road.

  • Not sure why this has been tied to autocomplete in this thread. 1password should just add a custom data attribute that developers can add to fields that never ever should be autocompleted with 1password. Lastpass let's us add data-lpignore="true" to an input to make Lastpass ignore it. Seems like an extremely simple feature to add to 1pass as well.

  • ag_yaronag_yaron 1Password Alumni

    Hey @aelvan ,

    Since this discussion we have implemented some improvements on this front, such as telling 1Password to ignore fields when they have autocomplete="off" when there is no password field present on the page/form.

    We're still debating the notion of adding a specific variable that would allow developers to tell 1Password to ignore a field and its implications. Thanks for chiming in on that!

  • @ag_rayon Yes, my point was that I want autocomplete on my (email) fields, but they have nothing to do with logins, so I don't want the 1pass widget to pop up.

  • ag_yaronag_yaron 1Password Alumni

    I don't quite follow @aelvan .

    If you want autocomplete, then 1Password is there for the job. It can autofill email fields using identity items (and not Login items).
    Or are you referring to the browser's built-in autocomplete?

  • No.

    1) 1Password is not a complete autocomplete solution. I understand that you can store more than just logins in 1password, but 1password is by no means a good fit for every single type of information that you could possibly put into a web-based form on the internet.

    2) If I, as a web developer, were to completely disable autocomplete from my forms/fields, that would be a disservice to users who don't have 1password or a similar solution installed - and actually want to use autocomplete.

    Telling 1password to not care about my email field, is in no way related to wanting to turn off autocomplete.

    But, I've now found a way to trick 1pass into not recognising the field, and still maintain accessibility and built-in autocomplete, so. Do as you wish.

  • ag_yaronag_yaron 1Password Alumni

    Thanks for the feedback @aelvan . We'll definitely consider it going forward.

  • landsmanlandsman
    edited June 2021

    Please, this is a really stupid thing that is annoying in our PWA apps. Fix it.

  • ag_anaag_ana 1Password Alumni

    Thank you for the feedback as well @landsman, I will certainly pass it to the team for future consideration :+1:

  • What's the status of 1Password trying to fill in non-password input fields? Since you won't/can't respect autocomplete="off", why not the "new-password" value tag?

  • ag_jarekag_jarek

    Team Member

    @dustin555,

    Hello! I'm happy to say that we do incorporate the autocomplete="new-password" attribute mentioned in the link you provided into our autofill suggestions. 1Password is capable of suggesting new, strong passwords in new-password fields, and so when we encounter that particular autocomplete value we nudge 1Password in that direction. We also nudge 1Password away from making other suggestions in such fields (such as usernames, existing passwords, or any other data).

    I hope that helps!

  • Cool. We will give it a try. Thanks for letting me know.

  • ag_anaag_ana 1Password Alumni

    On behalf of Jarek, you are welcome @dustin555 :)


  • Please please fix this :( I'm just a user (not a dev) but being able to disable 1password on specific inputs "as a user" (ie with a checkbox) would be VERY helpful... Specific example: when tracking time in Toggl the icon completely hides what I'm typing. And I already HATE timetracking with a passion * cry *

  • ag_anaag_ana 1Password Alumni

    @jessie_vp:

    I will be happy to let the developers take a look at this website :+1: Are you able to share the full URL where we can test this?

  • ag_yaronag_yaron 1Password Alumni

    @jessie_vp You can also immediately dismiss 1Password by clicking the little 1Password icon in the field or by pressing ESC.
    Additionally, you can temporarily hide 1Password by clicking the "Suggestions" menu in your screenshot, scroll to the bottom and select "Hide on this page".

    1Password won't show up on that website until the next time you launch your browser :)

  • @ag_yaron Think something buggy is going on as well? The icon suddenly disappeared on that specific input so I tried on a regular login form, and your solution (suggestions -> hide on page) was visible & worked. Yet when I tried on the Toggle one (once the icon miraculously appeared again) I cannot click the "suggestion" submenu. Screencap in attach.

  • I have an account on Toggle.com (https://track.toggl.com/timer), screenshot is as a logged in user

  • I have an account on Toggle.com (https://track.toggl.com/timer) but logged in in

  • ag_anaag_ana 1Password Alumni

    @jessie_vp:

    We can try looking at the page details. Please see these instructions from my colleague Yaron to see how to collect them, in case you want us to take a look :+1:

  • @ag_ana I can't replicate this behaviour :| Tried to collect page details but the icon was once again gone from that specific input so not sure how helpful that would be...

  • ag_anaag_ana 1Password Alumni

    @jessie_vp:

    Thank you for the update! Ok then, should this happen again, please feel free to email us the page details and we will be happy to take a closer look. In the meantime, I am glad that this is working as expected once again :)

  • ag_yaronag_yaron 1Password Alumni

    @jessie_vp 1Password might show up in a field if the page itself (behind that little popup window) contains certain keywords, such as "Password", " Login", "Username" etc, which explains why sometimes it shows up and sometimes it doesn't.

    If you're looking at a specific page/event that contains such keywords, 1Password will show, but in other pages/events it won't if there are no such keywords in sight.

    Regardless, do grab the page's structure for us when you encounter it again and we'll see how we can improve 1Password there.

  • Not really solved as it's happening frequently... I just can't replicate this behaviour manually. Also, in the steps provided in the instructions I should close Chrome completely... However, I think this temporarily "solves" the issue as the icon is then once again not showing in that specific field, so the page structure would ( I think?) show like nothing is amiss? And at some point the icon will show again, and I'm not able to click the suggestion menu to "hide on this page" (as shown in the screencap). I don't understand why it sometimes shows & sometimes doesn't on the same input on the same page :)

  • ag_yaronag_yaron 1Password Alumni

    @jessie_vp Some websites are just built in ways that cause unwanted behavior. Keep in mind we are injecting 1Password into a page that (from the looks of it) already injects stuff into your view as a popup inside a popup, so things don't always work out.

    If you encounter the issue again where 1Password shows up and suggest stuff, simply right click the 1Password icon on the top right corner of your browser, select "Help" -> "Collect Page Structure" and send it over to us. That's all :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file