iOS password autofill shows obsolete 1Password entry next to current 1Password entry

lilyballlilyball Junior Member
Community Member

I recently changed the email address on my corporate Google account, and updated the corresponding 1Password item. As a result, I have only one 1Password item for this account, which has my new email address (and it's the same item that used to have the old, so the UUID hasn't changed).

When iOS 12 prompts me to autofill a password for this account, it keeps showing my old email address for the 1Password entry. This is both in the autosuggestion bar, and in the action sheet that pops up when I hit the key glyph. In that action sheet it actually shows 2 password entries for 1Password, one for the old email address and one for the new. Selecting the entry for the old email address fills in my password correctly (I don't know about email; the Google sign-in form is only prompting for password here). If I select the "1Password" item to pull up the full 1Password extension interface, 1Password does not show the old item.

I don't know how iOS password autofill works from a technical level, but it certainly seems as though it's trying to cache previously-fetched items, that it believes that the item with my new email address is a separate item from the one with my old, and that it believes the item with my old email address is still valid. And I see no way to clear this out. Though I can't be positive this is a caching issue on iOS's side; is there any chance 1Password itself is trying to maintain a cache for the iOS password autofill and has screwed it up?


1Password Version: 7.2.1
Extension Version: Not Provided
OS Version: iOS 12.1
Sync Type: Teams

Comments

  • BenBen AWS Team

    Team Member

    Hi @kballard

    Please open 1Password > Settings > Password AutoFill and wait for it to update. Once complete please check these entries again.

    Ben

  • lilyballlilyball Junior Member
    Community Member

    @Ben Just tried that, still seeing the phantom entries. I also just tested, if I select the entry that autofill lists as my old email address, 1Password actually fills in the correct updated address.

  • BenBen AWS Team

    Team Member

    @kballard

    Well... that’s interesting. I can’t say I’ve seen that before. Could you please try disabling 1Password in Settings.app > Passwords & Accounts > AutoFill Passwords, and then re-enable it?

    Ben

  • lilyballlilyball Junior Member
    Community Member

    @Ben

    That worked. Thanks!

  • BenBen AWS Team

    Team Member

    Thanks for the update @kballard. :)

    Ben

  • jsinglesteinjsinglestein
    Community Member

    Thanks for the fix. This has been driving me crazy.

  • BenBen AWS Team

    Team Member

    :+1: :)

    Ben

  • RobbertvRobbertv
    Community Member

    Ben, when disabling autofill on my Iphone, the 'password for 1password.com xxxxx' disappear from main login screen - ok, that's what i want. But on my iPad it doesn't; it only disappear if i completely disable autofill (so incl key hanger).
    Also; when i enable 1password in iOS-settings iPad, 1password ask the main password (to confirm i guess). But when i disable, 1password doesnt ask for that.

    • but maybe more relevant question: from all my passwords only for one specific login keeps appearing on main screen. Now i trashed that loginentry from the 1password app, and its in sync with other devices, but it keep appearing. So no matter enable/disable...that trashed login remain there somewhere.
  • ag_anaag_ana
    1Password Alumni

    Hi @Robbertv! Welcome to the forum!

    If you go to Settings on this iPad > Passwords & Accounts > AutoFill Passwords, can you confirm that only 1Password is enabled there?

  • RobbertvRobbertv
    Community Member
    edited August 2019

    the autofill has only iCloud-keyhanger and 1password. 1password currently disabled but that login keep present below main password.

  • RobbertvRobbertv
    Community Member
    edited August 2019

    There's no way manually edit this for each login inside the app? For each single entry? Because what if i want lets say 10 logins there, or just 2? Looks now all or nothing due to the iOS-setting enable/disable.
    But its strange i removed the login from 1password (i checked devices to confirm sync but main login screen still show that login)

  • ag_anaag_ana
    1Password Alumni

    @Robbertv:

    If you have Keychain enabled in your AutoFill settings, then your passwords are coming from there, not from 1Password. As per my previous post, please disable Keychain from there and make sure that only 1Password is enabled.

    This way, your AutoFill menu will only show you entries that exist inside the 1Password app.

  • RobbertvRobbertv
    Community Member
    edited August 2019

    i looked in Mac Keyhanger and that password is also not there. (and key hanger also sync with iCloud is it not?)

    • but disable keychain? i have also web entries that doesnt use 1password.
  • ag_anaag_ana
    1Password Alumni

    @Robbertv:

    and key hanger also sync with iCloud is it not?)

    Not necessarily: only if you enable iCloud Keychain.

    Because of this, it's entirely possible that this password is stored on your iOS device but not on your Mac. What happens if you temporarily disable Keychain from your AutoFill settings? Does this password disappear?

  • RobbertvRobbertv
    Community Member
    edited August 2019

    The login entry is indeed in IOS keychain. And removed :)
    I thought all those are in sync with Mac keychain (trough iCloud sync); apparently not.
    Thanks for your support!

  • ag_anaag_ana
    1Password Alumni

    You are welcome @Robbertv!

    Your Keychains can indeed sync among your Apple devices, but only if you explicitly enable the feature under your iCloud settings, in your Apple ID section ;)

This discussion has been closed.