Cannot login to Citibank [make sure 1Password has the correct username and password to fill]

I am really getting frustrated using 1password. I followed all of the steps of generating a new password on the following citibank website: https://online.citi.com/US/login.do

As I try to use the password generator to regenerate a new password, the Citibank website always states that number is not being used in the generated password. I know that the regenerated password has a number in it, but the Citibank website for changing the password will not recognize it.

Secondly, I tried saving my current username and password with 1password on the URL for citibank: https://online.citi.com/US/login.do

It continually states that the password is incorrect. I fill it in manually and it works. Is there an issue between 1password and the citibank login page? Can you resolve this? I just purchased a membership and if I cannot get this to work, I want a refund.

Thanks.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • When I try and use 1password to log into account, I get a message that says unable to log in at this time and please try later. However if I do a manual login it works fine. I go back and try 1password again and get same error. It appears the bank system knows I am using an auto login program and it refuses to accept. Is there anyway around this?

  • brentybrenty

    Team Member

    @Therands: It sounds like you may have a URL saved in that Login item that Citi doesn't want you to use (or hasn't designed for it to be). In my experience, this one works best:

    https://accountonline.citi.com/cards/svc/LoginGet.do

    Try saving that in the Login instead and let me know if that helps. :)

  • Brenty, when I save and use logon you suggested, I get the error message that site cannot be found. Is it possible that Citi has dropped that site as a way into their system? Do you have any other options you know of?

  • brentybrenty

    Team Member

    @Therands: I'm not sure I follow. I went there and logged into my account before replying, to make sure they hadn't changed something (as they have in the past), and I did just now again. Are you saying you can't load their website at all?

  • I had 1password icon both pinned to my task bar and also the one listed in the upper right corner of chrome. I was using the one on the task bar. I now tried the one listed in corner of Chrome and it works OK. Not sure of why one works and the other does not. But I will remove from task bar and use one on chrome from now on. Thank you,

  • brentybrenty

    Team Member

    I'm not sure I understand either, since they both open exactly the same thing: 1Password mini. I'm glad to hear that you've found a workaround, but if you'll share the details I'd still like to look into it.

  • The 1Password version is: 1Password7
    OS version: MacOS Sierra Version 10.12.6

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hello @golazo08,

    Let's start with saving and filling on the sign-in form and then make our way to their change password form.

    Can you visit https://online.citi.com/US/login.do and manually fill the fields. Before you submit though can you manually save a new Login item using the steps detailed on our support page How to save a Login manually in your browser. If you view the new Login item in 1Password and reveal the password are the username and password stored in the new item correct?

    Returning to the browser, just as a sanity confirmation check complete the login attempt and then sign out. Return to the sign-in page and attempt to log into the account with the new Login item. Does Citi still state the password is incorrect?

  • johnnywozjohnnywoz Junior Member

    @littlebobbytables I too am having the same issue, I follow your steps, no luck
    1Password 7
    Version 7.2.2 (70202006)
    AgileBits Store
    MacOS Mojave

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @johnnywoz,

    When you say no luck, did the completely new item you created save everything correctly but then filling failed or something else? If it was the filling failure is it still the case that both fields fill but then it complains?

    The reason for the questions is I don't have a Citi account so I can only do some surface testing. Things look like they ought to work but I cannot test a successful sign-in attempt.

  • johnnywozjohnnywoz Junior Member

    @littlebobbytables I spent a good hour trying to setup my Citi account and each time I went through the password process it kept failing, meaning wrong information entered when logging in.

    Per your instructions, I manually changed the account password using Citi's process, then I went to their login page, manually entered the correct information, then used 1P to "Save New Login", I then entered into the account and then logged back out, when back at the login page I used 1P to enter the information and got a message about wrong info entered. I then entered the correct info manually and was able to log in.

    I cannot attest to to whether 1P had entered the info correctly when using the Save New Login as I had spent so much time and so much effort I forgot if 1P had done it correctly or if I had gone back and put it in. Sorry, too much frustration at the time and was unwilling to go through the process again.

    I recall that during one of the many attempts to get this working while updating the account password, I clicked on the 1P Update button in the popup dialog, when I went to the 1P main window I saw that 1P had entered in a single letter for the password field.

  • brentybrenty

    Team Member

    @johnnywoz: But lil bobby didn't instruct you to change the password, so that seems like a bit of an unnecessary detour you took. :blush:

    I use 1Password to login to Citi a number of times each month because they keep asking me for money. ;) I haven't encountered issues there for a long time, but my setup may be different from yours. Can you tell me the exact browser and extension versions you're using? I'll be happy to look into it.

  • Yes I have this problem as well in Firefox Nightly. When I press fill from 1Password, it says wrong username or password. When I just copy my password and paste it in, it works as intended. Just can't figure out why this is happening.

  • johnnywozjohnnywoz Junior Member

    @littlebobbytables @brenty FYI: the above issues were with trying to setup my mother's online access with her existing Citi credit card, using her MBP laptop and her 1P vault.

    BUT NOW I have my own new Citi credit card and I just setup my new online Citi account. So in my 1P vault there was no prior entry for CIti. I used the CIti online process for setting up my new online Citi account, I created a unique ID and PW and logged into the Citi website. I logged off the website and then logged back in manually to validate/verify my ID/PW. I then went back to their login page @ https://online.citi.com/US/login.do , entered my ID/PW manually, clicked the CIti login button and then saved the details to my 1P via the 1P pop-up dialog box. I assume this is the normal/accepted/recommended AgileBits process for saving a new login. I then logged out of the Citi website, went back to the Citi login page at the address noted above, but this time I used my 1P to enter the ID/PW into the Citi website login box section. When I clicked the Citi login button I got a message of incorrect credentials. I have gone into my main 1P app and validated the ID/PW and web login address.

    Note I have used the exact same process for several other websites both before doing the above and after. So I am confident my computer, browser, and 1P are all working correctly.

    Please Advise.

    Model Name: MacBook Pro
    Model Identifier: MacBookPro13,3
    Processor Name: Intel Core i7
    Processor Speed: 2.9 GHz
    Number of Processors: 1
    Total Number of Cores: 4
    L2 Cache (per Core): 256 KB
    L3 Cache: 8 MB
    Memory: 16 GB
    Boot ROM Version: 251.0.0.0.0
    SMC Version (system): 2.38f7

    1Password 7
    Version 7.2.2 (70202006)
    AgileBits Store

    Firefox:
    Version: 64.0
    Obtained from: Identified Developer
    Last Modified: 12/14/18, 8:32 AM
    Kind: Intel
    64-Bit (Intel): Yes
    Signed by: Developer ID Application: Mozilla Corporation (43AQ936H96), Developer ID Certification Authority, Apple Root CA
    Location: /Applications/Firefox.app
    Get Info String: Firefox 64.0

  • brentybrenty

    Team Member

    That is odd. How about the stable version of Firefox? It seems to work okay for me, but of course I don't know anything else about your setup.

  • @brenty Yes, same problem in the stable version of Firefox.

  • johnnywozjohnnywoz Junior Member

    @brenty @Tomatoshadow2 I am having the same issue with 1P not correctly filling in the login details on the Citi website, I am using the latest updated version of Firefox on my MBP running Mojave. See my notes here.

    It would be nice to see AgileBits Support offer more assistance than just telling us that they don't have any problems (same response in other post by same team member). It is obvious that more than one person is having troubles.

  • johnnywozjohnnywoz Junior Member

    @Tomatoshadow2 @Therands I think I discovered the issue, at least mine. Double check your userID in 1P, my ID was saved as 'jw****45' with the actual asterisks in the ID and not the actual letters 'jwoz45'. I can't believe I overlooked that, but in all honesty it did match what was displayed on the Citi web page with the asterisks in the ID. That was a painful lesson :'(

  • johnnywozjohnnywoz Junior Member

    @littlebobbytables @golazo08 I think I discovered the issue, at least mine. Double check your userID in 1P, my ID was saved as 'jw****45' with the actual asterisks in the ID and not the actual letters 'jwoz45'. I can't believe I overlooked that, but in all honesty it did match what was displayed on the Citi web page with the asterisks in the ID. That was a painful lesson :'(

  • @johnnywoz Thanks! That fixed the problem for me.

  • Hi littlebobbytables,

    I actually figured it out.

  • Thank you johhnywoz. Will check out your advice. I appreciate it!

  • brentybrenty

    Team Member

    I'm sorry for the trouble there, folks. I've been there! Indeed, if the website is replacing the information with **** and that's what you've saved in 1Password, that's what 1Password will fill. You can edit the login to make sure it has the right credentials though if they've been mangled. It sounds like you should be all set, but if anyone is still having trouble let me know the details and we'll figure it out. :)

  • brentybrenty

    Team Member
    edited December 2018

    I've merged the two separate, nearly-identical discussions here so we're not trying to have the same conversation in both places.

    It would be nice to see AgileBits Support offer more assistance than just telling us that they don't have any problems (same response in other post by same team member). It is obvious that more than one person is having troubles.

    @johnnywoz: I'm sorry you feel that way. But for the record, on December 1st, lil bobby asked,

    If you view the new Login item in 1Password and reveal the password are the username and password stored in the new item correct?

    You said you followed his advice, but it sounds like you didn't actually check that until two weeks later. You'd probably have had a resolution sooner, had you listened. But I'm glad that making sure 1Password had the correct login credentials to fill helped in the end. Cheers! :)

  • jelliott2kjelliott2k Junior Member

    Just to add my 2 cents... iPassword does not seem to work with the Citibank login site (https://www.citi.com/credit-cards/citi.action). The handoff appears to fill the username and password fields (the password field is all dots, of course, so I can't see what has been filled in), but Citibank always tells me I have a wrong username or password. If I type the information into the Citibank login page manually, it works just fine. I have given up using 1Password for the Citicard site entirely. I don't know which system is the problem, and don't have time to chase down the problem. If it gets resolved someday, that will be grand.

  • ag_anaag_ana

    Team Member

    Hi @jelliott2k! Welcome to the forum!

    Have you tried following littlebobbytables advice already?

    If you view the new Login item in 1Password and reveal the password are the username and password stored in the new item correct?

    So let's not focus on what is being filled for now, but are both items correct inside 1Password?

This discussion has been closed.