1Password browser extension does not populate 1password.com/signup correctly

Problem

The Email field does not populate and the email address is put in the Secret Key field. The Master Password field does populate correctly.

Note: In my 1Password vault entry for 1Password, username is Email, password is Master Password, and Secret Key is a custom Password field labeled “Secret Key”.

Steps

  1. Go to 1password.com (https://1password.com).
  2. Click Sign in (https://my.1password.com/signin?l=en)
  3. Click the 1Password browser extension and select 1Password.

Work Around 1

  1. Copy and paste the email address to the correct field.
  2. Manually copy the Secret Key from the 1Password app and paste into the correct field.

Annoying. This should be automatic. That’s the point of it all.

Work Around 2

  1. Delete 1Password entry from 1Password vault.
  2. Manually enter Email Address, Secret Key, and Master Password.
  3. Allow 1Password to automatically create a new vault entry for 1Password.

The “Secret” Key is used as the username and you still have to manually enter your email address. This worked once, now 1Password is no longer offering to create a new entry so I can’t troubleshoot any further. I can’t recall whether the website it adds is my.1password.com or blahblah.1password.com.

Has fuzzy URL matching been removed?

Finally, the website in my vault entry must be exactly the URL being visited. If my vault is just 1password.com, neither my.1password.com/signin nor blahblah.1password.com/signin pick it up. If my vault has my.1password.com then only my.1password.com/signin picks it up, and likewise for blahblah.1password.com. Of course, you can add both URLs to the vault entry, but I seem to remember fuzzy URL matching being a thing. Has that been removed?

Hacking

I inspected the sign in form on the website for the input element IDs. They are email, account-key, and master-password. I tried using those as custom field labels in my 1Password vault entry. Didn’t work.

The email and master password input elements on the website have custom attributes data-onepassword-designation which are email and password respectively. However, the secret key element has the attribute data-onepassword-section-field-title and the value Secret Key.

I tried a few variations in my 1Password vault entry but nothing matched correctly. So, for now, I am using my Word Around 2 (above).


1Password Version: 7.2.2
Extension Version: 7.2.2
OS Version: macOS Mojave 10.14.2
Sync Type: iCloud

Comments

  • Hi @lukejanicke,

    What you refer to as fuzzy URL matching still exists but we don't allow it for subdomains for 1Password accounts. With the exception of my.1password.com, credentials for aaaa.1password.com won't work for bbbb.1password.com and offering them is the wrong behaviour. That's why we treat direct subdomains of 1password.com as being separate rather than all being part of 1password.com.

    To create a working Login item where the email address displays as the username you have one of two routes. This one works equally well for both 1Password for Mac and Windows.

    1. Save this 1PIF (1Password Interchange Format) file to your Desktop. The file should end in .1pif, if you see .txt please alter the filename accordingly.
    2. For 1Password for Mac, drag the 1PIF file to the 1Password icon in the macOS dock to import into the active vault. If All Vaults is active it will use the default vault for saving (Vaults tab in 1Password's preferences). For 1Password for Windows select the menu option 1Password > Import and then select the 1Password Interchange Format (1PIF) option and follow the prompts.
    3. Locate the imported item, it will have a tag with the import date.
    4. Enter edit mode and click the View Saved Form Details button if 1Password for Mac, Web form details if Windows.
    5. Replace the placeholder values with your real account credentials.
    6. Add a second website field if you also want to use your dedicated subdomain for the 1Password account.
    7. Save.

    That's one route. The other is as follows but only works for 1Password for Mac:

    1. Visit the sign-in page.
    2. Fill in the fields and manually save an entirely new Login item using the steps detailed on How to save a Login manually in your browser.
    3. Switch to 1Password's main window, locate the item and enter edit mode.
    4. Click the View Saved Form Details button.
    5. Against the secret key you will see a silhouette of a person, this is what 1Password uses to designate this field as representing the username. Click in the equivalent area against the email field and select the silhouette of a person from the small menu. This will correct 1Password's mistake.
    6. Save.

    You should find all three fields fill consistently with this Login item.

  • Thanks @littlebobbytables! View Saved Form Details is the secret sauce I needed! Much appreciated. Everything is working again as expected. Also thanks for the details about subdomains on 1password.com that actually does make sense.

  • wigsterwigster
    edited December 2018

    [Found what I needed!]

  • brentybrenty

    Team Member

    Sounds good. We're here if you need us. Happy New Year! :):+1:

This discussion has been closed.