Help! 1P on Safari 5.0.3 on 10.6.6 not showing

I have uninstalled and re-installed multiple times, restarted 1P, Safari, Machine all to no avail. I'm currently running Version 3.5.4 (build 30852) but have tried any beta that has come out. Seems to be fine on Firefox and Chrome.
I only have 1 extension installed but switching extensions off makes no difference. I also have Evernote installed.

HELP!

Cheers,

Comments

  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, steamshift.

    I'm sorry that you're having this problem. Please quit your web browser(s) and then:

    1. Open 1Password
    2. Reset folder permissions (Help > Troubleshooting > Reset Folder Permissions)
    3. Open 1Password's Preferences to the Browsers pane
    4. Click the "Remove All Extensions" button
    5. Click the "Install All Extensions" button


    The extension handling code is different when clicking those buttons (as opposed to unchecking/checking the individual boxes for each browser). Additionally, it has been updated in 3.5.4, so even if you have tried it previously, you may experience much more positive results if you do it at this time.

    Please let me know how it turns out.

    Thanks!
  • steamshiftsteamshift Junior Member
    No luck :(
  • khadkhad Social Choreographer

    Team Member
    edited February 2011
    Are you able to access 1Password via the right- or ctrl-click menu in Safari?

    An old version of the Evernote Safari extension didn't play nice with any toolbar customizations the user has made, which of course includes 1Password. We've reached out to the Evernote team to supply code to get this working and they made some progress in a recent update.

    Please try upgrading to the latest version of Evernote if you are not already using it and see if that helps. If not, try removing the Evernote clipper extension and see if that helps. Assuming it does, you can achieve much of the Evernote clipper's functionality by simply dragging the URL from the address bar to the Evernote icon in the Dock. Select the URL and click and hold for a short delay before dragging to have the text drag. Then, drop the URL on the Evernote icon in the Dock to clip the page. With this in place, many users have found they do not need to use the Evernote clipper in Safari at all.

    After removing Evernote, restart Safari and you should be able to get the 1Password icon to stay on the toolbar. Alternatively, if you want to keep the Evernote icon, you can access all of 1Password's functionality from the context menu in the browser (ctrl-click on the webpage).

    If you are still having trouble, could you please email us your Diagnostics Report? This will help us track down the issue more quickly. You can generate the report from 1Password on your Mac by clicking the Help > Troubleshooting > Diagnostics Report... menu item and then attach the report to an email to [email protected]

    Please include a link to this thread, so we can "connect the dots," but do not post your Diagnostics Report in the forums.

    I look forward to resolving this for you!
  • steamshiftsteamshift Junior Member
    I have tracked down the error!

    I removed ws.agile.1PasswordAgent.plist from ~/Library/LaunchAgents and rebooted.

    So then now running this in terminal:-

    > launchctl load ~/Library/LaunchAgents/ws.agile.1PasswordAgent.plist
    nothing found to load

    Manually running

    ~/Application Support/1Password/Agent/1PasswordAgent.app

    by just double clicking that app, then restarting Safari, all works fine.
    (Reinstalled my plugins, extensions etc, still works fine).
  • khadkhad Social Choreographer

    Team Member
    edited February 2011
    I'm glad everything worked out. Please do let us know if anything starts acting up again. It could have been helpful to see your Diagnostics Report just in case there is a change we need to make in our code.

    Do you have 1Password.app installed in a location outside of your Applications folder?
    Is your Applications folder stored outside of your startup volume?
    Is your home folder stored outside of your startup volume?
  • smith4925smith4925 Junior Member
    I'm getting the same problem, 1P won't show up in Safari since the last update?
  • khadkhad Social Choreographer

    Team Member
    Have you followed the steps outlined in my post above? Please let me know how it turns out.
  • smith4925smith4925 Junior Member
    Tried it but did not work. When trying to open the 1PasswordAgent it tells me 'You can't open the application 1PasswordAgent because it may be damaged or incomplete.
  • khadkhad Social Choreographer

    Team Member
    Thanks for the update.

    Please delete the Agent and Extension folders in the Application Support > 1Password folder shown in your screenshot.

    It sounds like your 1Password installation is damaged, which is affecting browser integration. To resolve this:

    1. Download 1Password from our web site:
    http://agilewebsolutions.com/downloads
    Click on the "Download Now" button under "1Password 3"
    2. Quit your web browser and 1Password, if it's running
    3. Open your Applications folder and drag 1Password to the Trash
    4. Install the new copy of 1Password you just downloaded
    5. Run 1Password and then your web browser

    Your information is stored in a data file separate from the application, so it will not be harmed by this procedure.

    I hope that helps.
  • smith4925smith4925 Junior Member
    That did the trick. Thanks.

    khad wrote:

    Thanks for the update.

    Please delete the Agent and Extension folders in the Application Support > 1Password folder shown in your screenshot.

    It sounds like your 1Password installation is damaged, which is affecting browser integration. To resolve this:

    1. Download 1Password from our web site:
    http://agilewebsolutions.com/downloads
    Click on the "Download Now" button under "1Password 3"
    2. Quit your web browser and 1Password, if it's running
    3. Open your Applications folder and drag 1Password to the Trash
    4. Install the new copy of 1Password you just downloaded
    5. Run 1Password and then your web browser

    Your information is stored in a data file separate from the application, so it will not be harmed by this procedure.

    I hope that helps.
  • khadkhad Social Choreographer

    Team Member
    Huzzah! :-D
  • Valdemar1Valdemar1
    edited February 2011
    khad wrote:

    Huzzah! :-D


    I have the same problem here. I have also followed all the suggestions that you have laid out, to no avail. Exporting a diagnostic report does nothing for me (it does not save "1Password Troubleshooting.html" and thus upon clicking on the icon in 1password, the dialog in Safari is: "No file exists at the address “/Users/xxxxxxxxx/Library/Application Support/1Password/Diagnostics/1Password Troubleshooting.html”").

    1. Customizing toolbar shows no 1password option.
    2. Removing and installing all browser extensions in 1password, relaunching both Safari and 1password does nothing.
    3. Deleting 1password's plist does nothing.
    4. Resetting folder permissions in 1password does nothing.

    Everything seems fine in Firefox, but this is not my main browser. Any other suggestions?

    I should add that I'm running Version 3.5.5.BETA-3 (build 30859)
  • I have now removed my previous version of 1Password and installed the version from the downloads as mentioned above: Version 3.5.4 (build 30852). It is now possible to export a diagnostics report, but there is still no 1Password button in Safari.
  • Valdemar1 wrote:

    I have now removed my previous version of 1Password and installed the version from the downloads as mentioned above: Version 3.5.4 (build 30852). It is now possible to export a diagnostics report, but there is still no 1Password button in Safari.



    I perused the diagnostics report and grew suspicious of Hyperdock showing up so often so I tried to disable it and nothing happened. I then de-installed it and voila, 1password is working in Safari again! That sucks because I really like Hyperdock.
  • Valdemar1 wrote:

    I perused the diagnostics report and grew suspicious of Hyperdock showing up so often so I tried to disable it and nothing happened. I then de-installed it and voila, 1password is working in Safari again! That sucks because I really like Hyperdock.


    Sorry for talking to myself here, but maybe my troubleshooting will help others...

    I have now reinstalled Hyperdock and everything seems to be working fine, including 1Password in Safari.
  • khadkhad Social Choreographer

    Team Member
    Thanks for that information, Valdemar1, and welcome to the forums! I am glad everything is working well for you. We never get tired of hearing that. :-)
This discussion has been closed.