1Password not working with Carson Pirie Scott

My mom uses 1Password and it will not work with Carson Pirie Scott's website. She goes on to pay her bill, the user name and password it's filled by 1Password, and it says invalid password.

So I go there and re-saved it and it worked for me a few times, she texts me later that night and still having the same issues.

Trying to have her troubleshoot is like pulling teeth, so I'll try more when I go there. Could it be there website doesn't allow an auto fill of the password info?

She is using the lastest 1Password for Mac on Yosemite.



  • dtearedteare Agile Founder

    Team Member

    Hello @prime,

    It's a guess but it's an educated guess so I'm going to take a shot before asking for exact URLs and browser versions and such :)

    Is it possible your mom has Autosubmit enabled on this site and you have it disabled? The other possibility is she purchased from the Mac App Store and you purchased from our site. Where you purchase from shouldn't matter and normally it doesn't, but in the case of Autosubmit, we need to do things differently when running in the Mac App Store sandbox.

    If my hunch isn't correct, no worries, we can dig into this deeper. Please let us know how it turns out :)

  • This was done on her 1Password only (from the Mac store). I thought I fixed it the other day, but I guess not. when she showed me the issue, I manually typed the password in, and all was fine. I should have copied and paisted it to see, but I was short on time (a hungry kid will always win lol). The auto-submit wasn't on.

    I will try more later, but I was wondering if anyone else had this issue on other sites.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @prime,

    I'm taking guess here so please do correct me if I'm wrong. Is the site in question, Carson Pirie Scott's, this site, https://www.carsons.com/ and the login page https://www.carsons.com/user/login.html?

    Now to allow you to compare I'll describe my system

    • OS X 10.10.2
    • 1Password 5.1 (MAS)
    • Safari 8.0.4 & Firefox 36.0.4
    • 1Password Browser Extension 4.3.1

    I've detailed that so if your findings differ from ours we can investigate possible areas for why. What I did was I created a Login item following our Saving a Login Manually guide. As part of my routine I always set the Login item to Never submit because I use dummy data. When I reloaded the login page to start from a fresh point I could successfully fill in both the email address and password and using a particular snippet of JavaScript I confirmed the password was correct. So in theory, if I had a real account I would expect it to proceed correctly if I were to click on the Sign-In button on that page. I even created what I call a basic Login, one where I create the Login item from within the main 1Password window and used https://www.carsons.com as the website field. That too pasted the correct information into the two fields. I tried over the two browsers just to see if one of them was doing something differently.

    Now this is just my findings as part of an initial investigation. Some of the version stuff might be hard to get hold of unless you're in front of the machine in question but if you routinely ensure all updates are installed via Apple's App Store then our systems should be the same.

    I wonder, is it the initial login that is tripping up when your mum tries or could it be another page later in the process? As a comparison, you know how Amazon will often ask you for your password again when you are in the purchasing part of the process even if you logged in right at the start.

    Please do post back when you can. If you do gain the time to do some more testing on your mum's Mac we'd love to hear how it goes and I'd be interested to know how all of it compares to the testing I did above with the fake data. Just in case it's useful as a comparator, I'm including a screenshot of my test Login item below.

    It looks like it should work so hopefully we discover the gremlin and get this running smoothly for you :smile:

  • I will keep you posted. Soooooooo... The issue is with the bank the have to pay you bill. That banks is called Comenity. You go on to carsons, and when you pay the bill it takes you to Comenity.
    I will get more info next time I stop over there.

  • primeprime
    edited April 2015

    @littlebobbytables more info. Talking to my mom, she said she has card with Marathon gas as well that uses Comenity bank and she has the same issues.

    On Facebook, 1Passwors posted a blog about a Canadian band thay wouldn't allow copy and paiste in the password section of the app, would this be the same issues? I wish I could find that blog now. I thought I saved it.

    I found the blog


  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @prime,

    I do apologise, I've lost the thread a little (and sorry for that pun too!).

    So your mum wants to pay a Carson Pirie Scott bill.

    1. She logs into Carson Pirie Scott's site.
    2. I'm guessing she has to navigate their site a bit? say go to the accounts page, select a bill and click to pay.
    3. She's then redirected to the website for Comenity and is it actually that login that is failing?

    and something similar happens at another company's website and they're called Marathon gas. She starts off at Marathon gas and then things go wrong once she's redirected to Comenity?

    Banks are tricky, in fact they're the toughest for us for a couple of reasons. Unlike Amazon for example, creating an account at a bank so we can test for compatibility is really tough, even if we just look at the top three big banks for each country. Banks often use a multi-page login approach too meaning testing the second page for compatibility is really tricky. Now this isn't to say we don't work on it, it's just that sometimes our users can really help us.

    It could be that Comenity don't allow pasting into a field. What would be really helpful is if we can first identify if Carson Pirie Scott is a red herring, is that site okay and it's actually the Comenity bank page that is causing the problem. If this is the case we can rename this thread and we can work with you on Comenity's website. What will help us is the following:

    1. Comenity's main URL.
    2. Could you go through the steps with your mum when she tries to pay a bill on Carson Pirie Scott's website and let us know what the URL of the page she is being redirected to is. If the URL looks like it contains any sensitive information please don't post the full URL. Even knowing if the main domains match up will be useful (basically everything before the first /).

    Hopefully that can help us understand :smile:

  • When I get a chance to go there (probably next weekend) I will try some of this and report back :)

  • dtearedteare Agile Founder

    Team Member

    Thanks @prime. We're looking forward to your results :)

    By the way, my hunch is that this has nothing to do with Paste being disabled. It's not as easy for websites to disable the paste feature as it is for iOS apps.

    In any event, we look forward to getting this working for your mom. Please let us know how it goes.

  • @dteare it seems all is working now since the last update.

  • brentybrenty

    Team Member

    @prime: That's great to hear! Thanks for following up. On behalf of dteare, you are most welcome! It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance! :)

This discussion has been closed.