1P extension doesn't work in Firefox 4 (32-bit mode)

I recently installed Firefox 4 after its release and updated the 1Password extension to support it. The extension works just fine when Firefox 4 is running in 64-bit mode, however sometimes I have to restart in 32-bit mode (like when watching Netflix streaming videos because Silverlight does not have a 64-bit version). When in 32-bit mode, the extension no longer works. Pressing the keyboard shortcut does nothing, clicking the "1P" toolbar icon does not bring up a menu, and right-clicking on the page, when you select the "1Password" option nothing is displayed. I've tried reinstalling the extension but this does not resolve the issue. Is this a bug? Is there something broken with my installation?

Comments

  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, gimpster!

    Unfortunately, 1Password can only determine the correct bit-ness of Firefox when the extension installation is initiated. In other words, if you change the bit-ness of Firefox "on the fly," 1Password will not detect this until you reinstall the extension in 1Password’s preferences. "Open in 32-bit mode" was not intended to be toggled regularly but set once until compatibility is achieved.

    Please try uninstalling 1Password's [64-bit] Firefox extension, setting Firefox to 32-bit, and then reinstalling 1Password's [32-bit] Firefox extension. Different code needs to be loaded in each case.

    Please let me know how it turns out.
  • khad wrote:

    Welcome to the forums, gimpster!

    Unfortunately, 1Password can only determine the correct bit-ness of Firefox when the extension installation is initiated. In other words, if you change the bit-ness of Firefox "on the fly," 1Password will not detect this until you reinstall the extension in 1Password’s preferences. "Open in 32-bit mode" was not intended to be toggled regularly but set once until compatibility is achieved.

    Please try uninstalling 1Password's [64-bit] Firefox extension, setting Firefox to 32-bit, and then reinstalling 1Password's [32-bit] Firefox extension. Different code needs to be loaded in each case.

    Please let me know how it turns out.


    That fixed it, thanks!
  • khadkhad Social Choreographer

    Team Member
    Glad to hear it. Thanks for letting me know! :-)

    Cheers,
This discussion has been closed.