Bug - can not edit last part of password in 1Password browser extension

In the 1Password Safari extension (4.4.3) when I have a password in a password field (regardless if newly generated or an old one) I can not change the last part of the password. It is simply not possible to select the last part of the password, but I can select the first part but not from character #10 and later. It does work in the regular Mac 1Password application so only the extension have this problem.

1Password Version: 5.3.2
Extension Version: 4.4.3
OS Version: 10.10.5
Sync Type: Dropbox
Referrer: kb-search:can not edit ppassword


  • brentybrenty

    Team Member

    @SEMats: Can you tell me the exact steps you're taking, perhaps with screenshots (using a test item, rather than your actual login info)? I'm not able to reproduce what you're describing. But restart your Mac first, in case it's simply Yosemite shenanigans.

    The only way to edit an item 'from the extension' is to click Edit, which 'anchors' it, and at this point it's a separate window which is part of 1Password mini. In this window I was able to delete each character of a 20 character password starting from the last. Please let me know what you find. I look forward to hearing back from you! :)

  • Hi, @brenty
    Please se attached:
    1_Create a new entry in the app
    2_Start the extension
    3_Choose the entry and anchor it
    3_Choose the entry and anchor it
    4_Try to mark the last part (this is a film). As you can see, it is possible to select the first part om the password but impossible to select the last part. Only tripped-clicking the password makes the password (incl last part) selected.

    Your system does not allow a film (mp4) to be attached, so I put it here: https://www.dropbox.com/s/db7md01l8vdwmai/4_Try to mark the last part.mp4?dl=0


  • And rebooting my mac did not help (just tried that).

  • Hi @brenty

    I tried what you wrote and found something Interesting:

    If I click the anchor button and then select edit, then it is impossible to select the last part of the password.
    If I does what you wrote - click the edit button directly, then I can edit the password exactly as I want.

    So using the anchor button creates the problem. Hope that helps in correcting the error but I am pleased with the workaround ;-)


  • brentybrenty

    Team Member

    @SEMats: Thank you! Your video showed the problem clearly, but I wasn't seeing this issue here — regardless of whether I anchor the item first or go straight to Edit...until I reverted to the stable version from the beta I was using.

    This is actually a visual glitch, as you can select the whole password and delete it, or press (or ⌘ →) to skip to the end of the line and edit it that way. The cursor just isn't showing.

    We've got this fixed in the latest 5.4 beta, so it's on it's way! And in the mean time I'm glad you can use Edit to avoid this entirely. Thanks again for bringing it up! :)

This discussion has been closed.