Apple Watch app not recognizing 1Password is unlocked on iPhone

sjksjk oversoul 1Password Alumni
This discussion was created from comments split from: Installation on Apple Watch not possible [resolved with latest 1Password beta].


  • mirvmirv Junior Member

    Agreed this is resolved, and 1Password is now installed on my Apple Watch. But I've run into a problem with the watch app. (If there a thread for Apple Watch issues let me know.) Anyway when I open the 1P watch app, it prompts me for my PIN, and asks me to unlock 1P on my iPhone, which I do. But it does not seem to notice this and is stuck at the "Please unlock 1Password on your iPhone to continue".

  • Hi @mirv,

    This happened to me also, and I suggest this bug is with the Watch software.

  • sjksjk oversoul 1Password Alumni

    Hi @mirv and @HRD,

    Thank you both for reporting this problem. Sorry I don't have any suggestions at hand for resolving it, and no Apple Watch on wrist. Someone else from our support team will be along to assist you as soon as possible.

    (If there a thread for Apple Watch issues let me know.)

    There's an Apple Watch category so I've moved this discussion there. :)

  • Hi @sjk,

    I resolved it by restarting the Watch and now the App works fine.

  • sjksjk oversoul 1Password Alumni
    edited February 2016

    Good idea, @HRD. Thanks for reporting your success with that! Hopefully it works for @mirv as well. :+1:

  • mirvmirv Junior Member

    I restarted both the Apple Watch and the iPhone and I'm still getting the problem.

  • Hi @sjk and @mirv,

    I should have mentioned that I am using Watch beta 2.2

  • sjksjk oversoul 1Password Alumni
    edited February 2016

    Sorry to hear the device restarts didn't fix this for you, @mirv. What to try next would be a guess from me so I'm going to defer to my colleagues for their expertise on what you can do.

    Thanks for mentioning you're using watchOS 2.2 beta, @HRD. We won't suggest its installation as a possible way to resolve this issue, and it really shouldn't make a difference.

  • brentybrenty

    Team Member

    @HRD, @mirv: I just wanted to follow up here with some additional info.

    The good news is that not everyone is having this issue with the Watch app, and that some were able to get it working simply by restarting.

    The bad news is that these sorts of problems — while less common than they were last year — are still rather pervasive in watchOS.

    But there's hope! When running into similar troubles, I've been able to get things working with any Watch app by following these steps (when all else has failed, since this can be a bit labourious):

    1. Connect both the Apple Watch and iPhone to power
    2. Open the Watch app on your iPhone, scroll down to 1Password, and set Show on Apple Watch to the off position
    3. Open 1Password on your iPhone and go to Settings > Apple Watch and set Enable Apple Watch to the off position
    4. Wait for it to stop saying "Uninstalling..." (this may never happen, but give it 5 minutes and then move on)
    5. View the apps on your actual Watch and if it is gone (in some cases, even those that completed "Uninstalling..." still show up)
    6. If it's still shown there, hold your finger on it and then tap the (x) (this may not work either)
    7. Regardless, hold the pill-shaped Side Button on the Watch and Power Off (you'll need to disconnect the power temporarily to do this)
    8. Then hold the Lock Button on your iPhone and Slide to Power Off (you'll need to disconnect the Watch from power temporarily)
    9. Power on both the Apple Watch and iPhone
    10. Verify that 1Password is not shown on the Apple Watch and that this is reflected in the Watch app on the iPhone as well (if not, go back to the beginning)
    11. In 1Password on the iPhone, set Enable Apple Watch to on
    12. In Watch on the iPhone, go to 1Password and set Show on Apple Watch to on
    13. Wait for the app to finish Installing...

    I hope this helps. Be sure to let us know how it turns out! :)

  • mirvmirv Junior Member

    I did all that stuff and it worked. Yay!

  • sjksjk oversoul 1Password Alumni

    Awesome, @mirv. Thanks for letting us know that those detailed steps from brenty cleared up whatever the snag was with 1Password between your iPhone and Apple Watch! If you run into any other trouble we're here and happy to help. :)

  • mirvmirv Junior Member

    You guys might also be interested in Apple's response to the bug report that I had submitted, when TestFlight was reporting that the 1Password Apple Watch app (wk or watchkit app in their terminology) was unavailable. Here it is:

    From: Apple Developer Bug Reporting [email protected]
    Subject: Attention: Bug ID 24679122: iOS 9.3 (13E5200d) TestFlight says Apple Watch App "unavailable"
    Date: Mon, 22 Feb 2016 11:43:34 -0800

    Hi Mark,

    This is a courtesy email regarding Bug ID# 24679122.

    Engineering has provided the following feedback regarding this issue:

    The reason you are seeing the wk app marked as Unavailable is because the beta for 1Password 6.2.2 is over. (The reason for that is 6.2.2 has moved to the AppStore and its beta has been closed). You currently have access to see version 6.2.2 but since the beta is over, you can’t install the iOS or wk app, so the wk app shows up as Unavailable. If you were to delete 1Password or install the store version, you would no longer be able to install the iOS beta either.

    Even though the above is correct, it is definitely confusing, so we are looking into making changes here.

    The wk install error notifications are a bug (the system is trying to install the wk beta app but the beta is over so it can’t). We are looking into fixing this as well.

    Sorry for the confusion.

    Since 1Password added a new beta, you can now install the wk app.

                                                 *** IMPORTANT: PLEASE DO NOT REPLY TO THIS EMAIL! ***

    Bugs requiring your attention will appear in the Attention tray at the top of the left-most column on the Bug Reporter website. Please review this bug report and, if necessary, provide any additional requested information by adding the information using the Apple Bug Reporter at When you update your report via the Bug Reporter website, engineering will be alerted about the new information automatically.

    Bug Reporter Link:

    Thank you for your assistance in helping us discover and isolate bugs in Apple products.

    Best Regards,

    Developer Bug Reporting Team
    Apple Worldwide Developer Relations


    Bug ID #: 24679122

    Bug Title: iOS 9.3 (13E5200d) TestFlight says Apple Watch App "unavailable"

    I am testing beta versions of the 1Password iOS app, which contains an Apple Watch app. Recently, probably since the update on Feb 11 of TestFlight app version 1.3.2, I've been getting notifications "Couldn't install 1Password; Open the TestFlight app and try again". In the TestFlight app, it says that the Apple Watch App is unavailable.

    Steps to Reproduce:
    1. Previously enrolled in the beta program for 1Password, and keeping up to date with iOS betas on my iPhone and Apple Watch as well as the 1Password beta apps on both devices.
    2. Update to TestFlight app 1.3.2.

    Expected Results:
    Didn't expect error messages. Expected the 1Password app distributed by TestFlight to install on the Apple Watch.

    Actual Results:
    See above comments in description. The 1Password iOS app is installed correctly, but the TestFlight notifications and Unavailable status seem to indicate that the Apple Watch app is not getting installed.

    watchOS 2.2 (13V5117c)


    I believe this worked correctly before the latest TestFlight. I am using an iPhone 6s AT&T 128GB, Space Grey:)

    'IMG_2540.jpg' was successfully uploaded.

    Well the 1Password watch app got installed with the next 1Password iOS beta. So perhaps not an Apple bug? Weird behavior though.

  • brentybrenty

    Team Member
    edited February 2016

    @mirv: I'll admit that I'm confused by the message as well, but thank you for including it! Perhaps after careful study I'll be able to find some useful insights there! :lol:

    I don't think this is limited to beta builds, but since it seems relevant I think I'll mention it in this context. Most of the time when I've run into issues with Watch apps it seems to be after an iPhone app update. Suddenly the Watch app doesn't work! While I can't verify this, my hunch is that in some cases the Watch app isn't being updated from the new iPhone app bundle, and that's where doing that crazy dance (the steps of which I outlined above) seems to get a fresh copy of the current app installed on the Watch when all else failed.

    Anyway, I'm glad to hear that it's working for you now, and we're here for you if you need anything else. Cheers! :pirate:

  • Hi folks, I'm still having this same problem. I did as suggested above; simply deleted/reinstalled the app on my Watch (recent OSes on Watch and iPhone 6S); deleted/reinstalled the app on my iPhone 6S and very other permutation I could think of. I still get the "Please unlock.." error on my watch. I'm at a loss for anything to do. Any suggestions anyone?

  • ...and FWIW, I just deleted the app from my Watch (pressed app until "wiggle" then pressed X), then deleted the app from my iPhone. I did the cache-flush (just for the heck of it - hold power button until "Off" then press Home button until Home screen appears). Then I reinstalled the iPhone app and checked the Watch app and 1Password was there). Tried to open the app again on the Watch and got the same error message. I'm stumped!

  • brentybrenty

    Team Member

    @BMWTwisty: I'm sorry to hear that you're still having trouble! Honestly, this is the first case I've heard of where following the steps I outlined above didn't resolve this issue — with any app! Did you encounter any errors or strange behaviour during that process?

    I did the cache-flush (just for the heck of it - hold power button until "Off" then press Home button until Home screen appears). Then I reinstalled the iPhone app and checked the Watch app and 1Password was there).

    However, your description leads me to wonder if you follow those steps exactly, in that order ("just for the heck of it"). If not, be sure to follow them precisely, as that's resolved the issue for myself and many others. But if you're still having trouble, the best thing to do will be to generate a diagnostic report and send it to [email protected] so we can look at the logs to determine exactly what is happening:

    Sending Diagnostics Reports (iOS)*

    *In 1Password Settings > Advanced > Diagnostics > Log Settings, enable App, Database, Keychain, and Lock.

    Just be sure to include a link to this forum thread and your username in the email so we can 'connect the dots'. Once we see the report we should be able to better assist you. Thanks in advance!

This discussion has been closed.