Browser Extension does't work with Windows 10 + Chrome

Hi guys,

the browser Extension doesn't work in this constellation. Is there a solution for this issue available?

Thanks for support & feedback,

Kind regards,
Ben


1Password Version: 6.0.183
Extension Version: Beta 4.5.8.2
OS Version: Windows 10 Pro 64bit
Sync Type: Team

Comments

  • brentybrenty

    Team Member
    edited July 2016

    @team_mynd: Sorry for the confusion! I've moved you to the Windows beta category of the forums since that's what you're having trouble with.

    To be clear, in order to use the beta with Chrome, the 1Password app will need to be open and unlocked. If you then click the button or press Ctrl Alt \ it will fill (or offer a list of) logins matching that URL. If there are none that match, it will display "No matches found".

    Do you maybe have 1Password 4 installed and running in the background? That will take over communications with the browser extensions if present. Please let me know what you find. I look forward to hearing back from you! :)

  • Hi Brenty, thanks for your feedback. We have installed 1password 6 with new fresh extension beta only. They are no old installations from v4 because it's a new computer.

    If we click on the "extension button" nothing happens. On OSX everything is fine.

  • brentybrenty

    Team Member

    @team_mynd: Is 1Password 6 open and unlocked? If not, the browser extension won't have anything to connect to. Also, if you have "security" software or other extensions, it may be blocking the connection. Try disabling them temporarily and let me know if that helps.

  • Same here. If 1Password 6 beta is not started, clicking on the chrome extension will automatically open it. However nothing happens then, no password filling, no "No matches found" displayed. Disable other extensions dose not work.

    Thank you.

  • MikeTMikeT Agile Samurai

    Team Member
    edited July 2016

    Hi @sign42,

    What happens if you do this:

    1. Close your browser, open 1Password 6 Beta and unlock it
    2. Open your browser and in your browser, manually visit one of the site's login page that you have a Login for. Click on the 1Password icon, what do you see?
  • @MikeT Yes, there is some progress. After disable all other extensions and do what you say, the password successfully filled into the corresponding login page with following logs:

    2016-07-29T23:32:20 From com.google.Chrome/3714: action showPopup.
    2016-07-29T23:32:20 From com.google.Chrome/3714: action activeURL.
    2016-07-29T23:32:20 From com.google.Chrome/3714: action collectDocumentResults.
    2016-07-29T23:32:20 From com.google.Chrome/3714: action collectDocumentResults.
    2016-07-29T23:32:20 From com.google.Chrome/3714: action fillItemResults.
    2016-07-29T23:32:20 Unknown action [fillItemResults]!
    2016-07-29T23:32:21 From com.google.Chrome/3714: action fillItemResults.
    2016-07-29T23:32:21 Unknown action [fillItemResults]!

    However there is still no "No matches found" message for sites have no Login information. logs:

    2016-07-29T23:35:16 From com.google.Chrome/3714: action showPopup.
    2016-07-29T23:35:16 From com.google.Chrome/3714: action activeURL.

    Thank you.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @sign42,

    That's all normal at the moment for the current Beta build, it won't show no matches found message on all sites, especially if you have no Login items for them. One common pattern is that if you're on an insecure page, you won't see any response back because we have an internal security check that prevents filling on insecure pages without the user's permission first.

    Updates are coming soon to address these issues.

  • @brenty: yes 1password 6 beta is open and unlocked. there is no security software installed.

    it doesn't work :(

  • brentybrenty

    Team Member

    @team_mynd: At this point, the best thing to do will be to restart your PC, reproduce the same issue, and then generate diagnostic information and send it to [email protected] so we can look at the logs to determine exactly what is happening:

    1. Open the main 1Password app
    2. Click on Settings > Email us
    3. Use a mail app to send it
    4. Or manually attach the current.txt to a new email to [email protected]

    Just be sure to include a link to this forum thread and your username in the email so we can 'connect the dots'. You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can quickly track it down. Once we see it we should be able to better assist you. Thanks in advance!

  • Hi @team_mynd,

    We've received the email and will get back to you as soon as possible.

    ref: XRI-92437-338

This discussion has been closed.