No autosubmit at NAB


  • You say you want to know about sites where autofill isn't working. Happened to me again on one of my bank sites (NAB) when I went to login, and

  • brentybrenty

    Team Member

    @Narius: To be clear, 1Password doesn't "autofill". It should only be filling something if you invoked it using the keyboard or mouse. Let me know the specifics and I'll be happy to test it!

  • Hi @brenty - I was trying to say it was the same as before. I only have one p/w for a site - I invoke it using the key command - it fills but didn't autosubmit. (Sorry if I was loose in my terms before). But I went into preferences, autosubmit off, closed prefs, then went in again and turned it back on. A couple of sites are working better now, so maybe that's a thing? NAB (National Australia Bank) still fills without submitting in their login page. Happy to report them as I come across them, or not, whatever you wish.

  • brentybrenty

    Team Member

    @Narius: Gotcha! So it was filling, but not submitting the form? That makes some sense, as we had to make some changes to how this works in 1Password 7 to better conform to Apple's sandboxing requirements. It sounds like something got hung up there in the transition, but disabling it and enabling it again helped.

    Can you tell me the URL for the page you're still having trouble with though? I think there may be a known issue with that site, but I'd rather test it and be sure. Also, what OS, 1Password, browser, and extension versions are you using? Thanks in advance!

  • NariusNarius
    edited May 2018

    Can't tell address - it's hidden. Go to then hit their login button and go to internet banking. It's that page. OSX 10.12.6, 1P 7.0.1, Safari, 1P extension 4.7.1

  • Hello @Narius,

    I navigated to the sign-in page and saved a dummy Login item to test with. After resetting the sign-in page I filled using 1Password and the ⌘\ keyboard shortcut and it submitted for me, instantly telling me the details were wrong (which was very true).

    Can you check something for me please. Edit your Login item and locate the now visible option titled display. Is the option set to the default of Submit when enabled or does it possibly say Never submit? Each item has it's own setting to allow for countering the global option and I wonder if that could explain what is happening here.

  • Good thought @littlebobbytables - I went to my login and clicked edit, but it was set to submit when enabled. However I toggled to always submit and sure enough, it worked. Toggling back to submit when enabled then worked too. Perhaps it just needed a wakeup call.

  • I wish I could explain that but I'm glad you tried the toggling just to see what happened. Let us know if you run into any other weird behaviour.

This discussion has been closed.