"database disk image is malformed" with 1password teams on one Mac Desktop client

A mac client (macOS 10.13.5) with an install of 1Password 7 cant connect to "1Password for Teams" account due to "database disk image is malformed" error.

The account inside of 1Password 7 was previously associated and spontaneously (from my perspective) dissociated.

I can still access the 1Password for Teams account on my iPhone and from the webpage.

What I've tried:

  • exporting my rescue kit (from website) and scanning it to authenticate the 1Password 7 install. (failed with above error)
  • changing my password via the web interface. (failed to associate with 1Password 7 with new password)
  • signing out and in with iPhone. (worked)
  • (not yet attempted) un-installing and re-installing 1Password 7 for mac.

Any additional troubleshooting steps would be appreciated.

1Password Version: 7.0.4
Extension Version: 4.7.1
OS Version: 10.13.5
Sync Type: 1Password for Teams
Referrer: forum-search:database disk image is malformed with 1password teams


  • I have now attempted a uninstall/reinstall and reconnect. Failure mode continues.

  • BenBen AWS Team

    Team Member

    Hi @makay_murray

    I’m sorry to hear about the trouble. While 1Password for Mac is locked please try selecting Help > Troubleshooting > Reset all 1Password data.

    Please let us know how that turns out.


  • Hi Ben:

    That did the trick! Thank you for the suggestion :)

  • BenBen AWS Team

    Team Member

    Excellent. Thanks for the update. If we can be of further assistance, please don’t hesitate to contact us.


This discussion has been closed.