1Password 7 Systray behaviour

Hello,

This is two separate queries really. First, I use two monitors, my taskbar is on my secondary monitor. When I right click the 1P icon in the systray rather than popping up next to my mouse, the context window pops up in the far corner of the other monitor, not the active one. I'm sure this isn't the behaviour previous versions used to exhibit, is there any way to change this?

Secondly, I don't tend to find 1P Mini useful for how I use 1P in 99% of cases. Is there any chance of being given a choice to set the default double-click behaviour for the icon in the systray to open the full app instead of the mini version within settings? If the second could be done the first would be less of an issue, I know it's only small QoL changes but if you don't ask you don't get!

Many thanks


1Password Version: 7.3.684
Extension Version: Not Provided
OS Version: Win10
Sync Type: Not Provided

Comments

  • bundtkatebundtkate

    Team Member

    It looks like we've seen this reported before, @hawkii, but haven't been able to reproduce the issue. Chances are that means it's fairly specific to a given setup, so could you share as much detail as you can about your display settings? Literally anything might be part of the equation – from your GPU to the resolution/scaling of each monitor – so feel free to bore me with details. It can only help.

    As for opening the main app, there isn't a way to set that to double-click, but there is a configurable keyboard shortcut for opening it. It's Ctrl + Shift + \ by default and can be customized in Settings > General. You can also Ctrl + left click on that systray icon if you prefer using the mouse. :+1:

  • Two-monitor setup as extended display as in image:

    Taskbar is on bottom of monitor two, when you right click the popup appears in monitor 1 as in image (sorry for large size!):

    Monitor 1 is an AOC G-SYNC monitor, 1920x1080, 144hz
    Monitor 2 is an LG Ultrawide 2560x1080, 60hz
    Graphics card is a GeForce GTX 980 (driver 431.36, but it's been doing it on every set of drivers since I installed 1P7)
    I do run DisplayFusion for desktop wallpapers, (the wrong-monitor-popup seems to only happen with 1P but possibly some sort of conflict). Let me know if there's anything obvious I've missed.

    I know there isn't a way to set double click at the moment but I know in other apps (Steam for example) you can choose the default activity of taskbar icon clicking. Is it possible to put in a feature request?

    Thanks for your help :}

  • bundtkatebundtkate

    Team Member

    I will absolutely pass your feedback about the system tray icon along, @hawkii, just wanted to provide some alternatives in the meantime. :+1:

    As for the issue with the context menu, I'm afraid we're still not able to reproduce this. I do think it would be worth temporarily disabling DisplayFusion just in case. I don't view that as likely, but one never does know. I'm also curious if you use LG's window management app, OnScreen Control, with your Ultrawide? I have the 1440 version of that monitor (love it!) and a single-monitor setup. I used OnScreen Control for a bit, but ended up ditching it due to some issues of my own. None menu-related, but that's not the sort of thing I'd see with just one monitor anyway, so figured it's worth a mention.

    Also, a bit of a laundry list so we can drill down to some more specifics. Anything else pop up on the wrong screen? Main app when opened with Ctrl + Shift + \ for example, or mini when you left-click? I'm also used to seeing a particular display marked with an * to show it's primary, but don't see that in your screenshot. Not sure if that's because my memory is outdated or if you have somehow managed not to have a primary display? My expectation would be that the context menu would show on the display with the task bar regardless, but I could also see it showing on whatever is set as primary and I'd think display 1 would be the default if you've not got a primary set. Assuming it doesn't otherwise muck up your setup, you could try setting display 2 as primary and see if that helps. Finally, I wanted to reiterate scaling. I'd expect both would default to 100% at 1080, but let me know if scaling is any different for either display.

    And I think that about covers what I can think up right now. Let me know what you find and we'll do some more testing as needed. Thanks! :chuffed:

  • Setting display 2 as Primary "fixes" the issue, so I'm guessing 1P is displaying it on whatever the primary display is, regardless of what is active. Setting display 2 as primary causes issues for me with games and other full-screen apps so it isn't an ideal long-term solution.

    As far as I can tell both displays are set to 100% scaling but Windows new settings layout isn't the clearest, the GeForce software seems to agree.

  • bundtkatebundtkate

    Team Member

    Lovely, @hawkii, thanks so much! I definitely don't expect you to muck up your games for our sake (I most certainly wouldn't), but that should almost certainly allow me to help someone reproduce the problem. Thanks again for your help and I'll be sure to pass our findings along to the development team. :+1:

This discussion has been closed.