Entity of my vault is not synced on AppleWatch - 1password TestFlight version

edited October 2019 in Apple Watch

I've recently updated an entity (shown on Apple Watch) of my vault on macOS client of 1password app. The editing was the deletion of the OTP from an entity, (shown on Apple Watch).

Today I've updated, to 7.4.3 (70403000) version of 1password on iOS device, paired to my AppleWatch. Since this morning I noticed that the OTP is still shown on the Apple Watch device for the involved entity of my vault. On the paired iPhone, the entity, does NOT have the OTP, correctly.

1Password Version: 7.4.3 (70403000)
Extension Version: Not Provided
OS Version: iOS 13.1.3 - watchOS 6.0.1
Sync Type: 1password server


  • edited October 2019

    And...just tried to uninstall it (only from Apple Watch) and then re-install it...nothing changed. The Watch app still does generate OTP that have NO corresponding OTP on the iPhone. Not different OTPs, but OTP on Watch and NO OTP (correctly) on iOS device app.

  • Now, I've just fixed it: I had to remove the Apple Watch label to the entity, and add it back to the entity. Now, on the Watch, the entitiy is w/o OTP.

    I'm not sure this is intended. Maybe @brenty can help us in this :)

  • AGAlumBAGAlumB 1Password Alumni

    @wizard86pz: Very strange. I'm glad to hear you were able to get it somewhat sorted, and thankful that you shared your experience here in case it helps others. I haven't seen or heard of something like that happing, but you never know. My best guess is that something happened with the Keychain data, which is used to transfer to the watch fro the phone by the OS. So removing and then re-adding the tag similarly re-added the data to the Keychain to sort of "refresh" it.

    Now, the TOTP thing is the real headscratcher. But maybe not, if it's unrelated. Are you seeing the TOTP code generated in 1Password on your iPhone? I wonder if that's related to some changes we've been making to better adhere to the standard.

  • edited October 2019

    @brenty thanks for the reply.

    "Are you seeing the TOTP code generated in 1Password on your iPhone?" - No, the mobile device app has never had the issue.

    These the steps done:
    1. I edited the entity on macOS app, removing the TOTP.
    2. the change has been correctly shown on all my devices (two win machines, an Android phone and an iPhone with Apple watch paired)
    3. using the apple watch app, I was continuing to see the TOTP of the related entity of my vault.
    4. once I've removed the "Apple Watch" label to the entity, from my iPhone, and then re-assigned the label to the same entity, the TOTP has been removed, correctly, from the Apple Watch view of the entity.

  • AGAlumBAGAlumB 1Password Alumni

    @wizard86pz: Okay, I think I wasn't understanding what you were saying then, or perhaps am not now. To clarify,

    1. you do not have a TOTP secret saved in the item any longer,
    2. therefore you expect 1Password to not generate a TOTP code,
    3. you were not seeing a TOTP code on your iPhone,
    4. but you were seeing a TOTP code on the watch,
    5. but after removing and re-adding the item to the watch the TOTP code is gone there now and all is well...

    Is that all correct? If so, it sounds like the Keychain had some stale data, but removing and re-adding the item updated it. We'll see if there's anything we can discover about that, but I'm glad if you were able to work around it.

  • edited October 2019

    All correct. Is something possible to fix on your side of the issue story?

  • AGAlumBAGAlumB 1Password Alumni

    @wizard86pz: Thanks for confirming. Probably not something we can "fix", as it's the OS that's storing the data in Keychain to use on the watch since it isn't feasible for us to run out own crypto there. But we'll see if we can reproduce it and find some other workaround.

This discussion has been closed.