Trying to use command line signin and getting secret key has changed message

Hi, I've just started with the CLI, I try to do the signin as shown in the getting started guide, it asks me for my secret key, I copy it from 1Password and paste it, type in my master password and it then tells me that my Secret Key has change and to enter my new Secret Key. I've double checked everything and I cant find out what it is looking for. The only thing I can think of is that I have MFA enabled, but I tried putting in my TOTP code and it states that its too short.
Any help would be greatly appreciated
Jonathon Page

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Not Provided
Referrer: forum-search:command line secret key has changed


  • BenBen AWS Team

    Team Member

    Hi @jpage386

    If you sign in at and generate a fresh Emergency Kit does the Secret Key on that kit match the one you're trying to use with the CLI?

    Get to know your Emergency Kit

    Please let me know.


  • Hi, same here, generated new secret key twice, keeps same "...has changed" message.

  • Solved. My fault was: My signin address is not My name, but !
    This info I could find only in team signin instructions.

  • felix_1pfelix_1p

    Team Member

    @fcaesar I'm glad you were to figure it out! I can definitely see that getting this message is confusing when an incorrect URL or email address is provided. I'm not sure whether we can/want to do better there though. For obvious reasons we wouldn't want to disclose that a given email address doesn't exist.
    Maybe we can do better for the signing URLs though.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file