Internet Explorer and Firefox are different

jmvenablejmvenable
edited August 2013 in 1Password 4 for Windows

I am on a v7 Windows machine with the latest 1P main program and two extensions for IE (V9) and Firefox (FF V23). I am displaying the main login screen for Fidelity Investments (www.fidelity.com) with an erroneous Username typed in (never mind why). I select the password from 1P from the respective extensions. Here is what happens:

For IE, the password shows up under Fill Login; for FF, Fill and Submit Login.

IE thinks for several seconds then incorrectly enters the Username in a Quotes textbox. The actual username textbox remains as was (with the erroneous entry). The LogIn button appears not to be pushed since it doesn't progress to the failed username page.

FF correctly overwrites the Username, correctly enters the password. However, it doesn't push the Log In button.

My questions:

  1. How might I correct this behavior, particularly IE's? I don't consider having separate PW schemes for each browser to be a good solution. And, I realize I may need to provide more info; pls advise.
  2. Why does the log in button not work here versus many other sites where it does?
  3. Why do the two add-ins have such vastly different user interfaces from each other and from the main application? They even use different nomenclature.

Many thanks for any feedback or help, John

Comments

  • khadkhad Social Choreographer

    Team Member

    Hi @jmvenable,

    Thanks for taking the time to contact us. I'm sorry for any confusion. Different browsers provide different extension APIs, and Microsoft doesn't allow us to integrate 1Password into Internet Explorer in the same way that we can in every other browser (Chrome, Firefox, and Safari). They are different browsers, thus they behave differently.

    Additionally, Fidelity has long made their site very difficult for 1Password to work with. It's like they code it in a way to actively thwart automated filling. So this is unfortunately exacerbating the issue. The differences on the majority of sites are minimal to nonexistent, but here it is likely much more pronounced.

    First of all, it sounds like you have autosubmit disabled in Internet Explorer. If you want 1Password to submit the Login automatically, be sure you have it enabled.

    I'm sorry that you're having this problem. My Fidelity Login is working well in non-Internet Explorer browsers (including autosubmit). Please try saving the login manually like this:

    1. Enter your credentials at https://www.fidelity.com but DO NOT submit the form.
    2. Click the 1Password button in your browser's toolbar, and select the "+" button in the upper right hand corner.
    3. IMPORTANT: Edit the username so that it contains your actual username and is not masked with asterisks. The Fidelity site obscures the username client-side, so 1Password will save the asterisks if you don't edit it at this stage.
    4. Change the title and make any notes (if desired).
    5. Click the Save button in the upper right hand corner.

    Using the above technique I was able to save and fill a sample login at:

    https://www.fidelity.com

    Manually saving a login can be useful for logins that are either problematic to begin with or were once working but have since stopped. Doing this allows 1Password to refresh everything it "knows" about the page. Login pages often change as websites are updated and this can be a necessary but very useful tip.

    It looks like Internet Explorer's limitations will require you to use Auto-Type on the Fidelity site, though.

    I hope that helps. Please let me know. I'd be happy to assist you further.

  • Well Khad, I wasn't expected quite as comprehensive an answer as this. Thanks so much. I will try out everything. But your last comment about Auto-Type is curious. The inference is that it should normally be turned off, true?

  • Khad, my IE version of 1P does not have an obvious place to add a new PW. Should I use the "main" program to add? Oh, BTW, auto submit was turned on. John

  • khadkhad Social Choreographer

    Team Member

    Well Khad, I wasn't expected quite as comprehensive an answer as this. Thanks so much. I will try out everything.

    I am happy to help! Please do keep me posted.

    But your last comment about Auto-Type is curious. The inference is that it should normally be turned off, true?

    Yes. Normally you do not need to use Auto-Type.

    Khad, my IE version of 1P does not have an obvious place to add a new PW. Should I use the "main" program to add? Oh, BTW, auto submit was turned on. John

    My instructions above are for the non-Internet Explorer extensions, but you can save a Login the same way in Internet Explorer just click the "Save Login" button instead of the + button. I just don't know that the Login will be saved properly in Internet Explorer. I didn't test it there, and the non-Internet Explorer extensions generally have better form filling. I usually start there.

This discussion has been closed.