Autofill not working in 7.3.BETA-1 [will be fixed in 7.3.BETA-2]


Team Member
edited March 2019 in Mac Beta
This discussion was created from comments split from: Chrome Extension No Longer Works After Update.


  • landenlanden
    edited March 2019

    Peculiarly, on some webpages in Safari, 1Password Mini doesn't show up. Opening up the Developer Tools shows this error:

    TypeError: null is not an object (evaluating 'a[0]') - injected.js:1028.

    Not sure what the commonality is between pages that this error appears on. The Reddit and Wikipedia homepages are examples, but on it works fine. Note that all of these pages have no fields to autofill, though I'd still like to be able to bring up Mini.

  • edited March 2019

    I just have to say, great work guys! - I really like the simplified UI, it is much, much cleaner and easier to navigate. Once again, only the core elements are shown, making 1Password Mini much faster to use, and that's a relief.

    It seems like I can't autofill in both Vivaldi and Safari, but maybe I should try rebooting the system. I will, and then I will post an update.

    UPDATE: That didn't fix it.

  • landenlanden
    edited March 2019

    Well, that was fast.

    To follow up on my above comment, the issue mentioned appears to be fixed as of Version 7.3.BETA-1.

    Edit: Nope, never mind. The error is gone, but popup behaviour is still inconsistent. Ironically, the only website I can find right now where Mini refuses to show up are these forums. I should mention that I'm on the Mojave Beta 10.14.4 and using Safari 12.1.

  • My autofill isn't working either. Running 7.3.BETA-1, Mojave 10.14.3, Chrome 73.0.3683.75, and Firefox 65.0.1.

  • edited March 2019

    @landen, nice to know that I am not the only one experiencing these issues. 1P Mini pops up on some pages, but it seems like I can't autofill at all. I have tried both in Vivaldi 2.4.1476.4 and Safari 12.1 on Mojave 10.14.4.

  • gdhnzgdhnz Junior Member

    Seems to quit after a while as well.

  • mmbrookmmbrook Junior Member

    Me too: Autofill not working anywhere. Mojave 10.14.3, Safari 12.0.3 or Chrome 72.0.3626.121

  • MrRooniMrRooni

    Team Member
    edited March 2019

    Hi folks. Thanks for testing, and sorry about the trouble with your browsers. If you would, send in a diagnostic report from to [email protected] and we’ll see what’s going wrong. In the meantime you can try a system reboot to see if that jogs things into working.

  • I'm not able to manually get "Fill Login or Show 1Password" to activate when pressing Command + . Hope this feature makes it back soon!

  • Have to say I really dislike the buttons at the bottom for Pin and Edit. Much prefer the glyphs that were previously there, starting to look too Windowsey now. Also, doesn't actually fill things anymore :)

  • As other have said, autofill is not working:

    Mac OS 10.14.3 + Safari

    1. Command + \
    2. Select item
    3. Hit enter (does not autofill)
    4. Hit autofill button (does not autofill)

    I also submitted a frequent crash that is occurring via email. Seems to be crashing and relaunching on almost every use at the moment...

  • Autofill not working on FF 66.0, 1P What I see consistently despite restarting both is attached.

  • Great job with the new mini.

    Autofill is also not working for me. Rebooting did not resolve it.

  • Mini seems to be crashing and requires launching the main app for it to recover.

  • hi @rudy,

    Chrome extension is not auto-filling sites with version 7.3b1.

    Does the extension itself need an update?

  • Same here! Autofill no longer works.

  • Yep, same here. Autofill is not working :-(

  • gkosteragkostera
    edited March 2019

    Yeap no autofill here either
    1Password Version: 7.3.BETA-1 (build #70300001)
    Extension Version: same
    OS Version: 10.14.4

  • jessejesse Junior Member

    I'm also experiencing the issue where autofill is not working in Chrome, Safari, or Firefox. Rebooting did not solve it.
    Here's a screen recording:

  • edited March 2019

    This morning I received a notice on my laptop (which is running the latest Mojave beta) that this new (beta) version of 1Password was now available, and so I installed it, as is customary for me. Like others in this forum have already said, I think you're off to a good start--though I have some notes about some of the UI/UX that I think are worth considering, which I'll post in a day or two. And, again like others who have already posted in this thread, I also encountered launch and autofill problems as the day went along.

    This evening, after moving to my iMac (which is running the latest copy of High Sierra), I realized that, though I had already been typing away on the iMac for an hour or so, I had not yet received notice of the 1Password beta being available, so I invoked 1Password's "Check for Updates" menu item in order to get/install it. I was told that I was running the latest version of the program and the "About 1Password" is reporting "1Password 7, Version 7.1.2 (70102000), AgileBits Store." That didn't seem right, so I went looking for the reason. I turns out that, for some reason, "Include beta builds" was not enabled on the 1Password copy that's running on this iMac. So I enabled it and then tried "Check for Update" once again. And, as before, I was told that I was running the latest version. I then quit 1Password and relaunched it, then tried "Check for Update" again. Same thing: I'm told that I'm running the latest available version. After a reboot of the machine, which I had to do a little later on for other reasons, I checked again. Nothing different.

    Are you only deploying this particular beta on Mojave -- or am I doing something wrong? Not that I do it often, and not that I can recall why betas were turned off on this machine, I nevertheless remember toggling betas off and back on some years ago and not encountering any difficulty with the update process respecting the setting.

  • baggendbaggend Junior Member

    As a few other folks have mentioned here, the overall new design looks great, but the big text-heavy buttons don't really feel right. I'll admit that the two overlapping squares weren't 100% intuitive, but "Pin on screen" feels like a big step back for me. I'm hoping these are just placeholders while you figure out how to display the information in a better way.

    The dropdown above the results is also a little bit confusing. I get that it's an easy way to navigate to different types of info (like credit cards for example), but why does it also show the current site there? Maybe there's a use-case I'm missing there but it does seem a bit confusing.

    Apart from that though, I really do like the new design direction here. Looking forward to seeing what else we can expect over the coming weeks.

  • rbergerrberger Junior Member

    I had to roll back. The new 7.3 beta 1 was unusable for me. It would not fill in things on Safari, Chrome or Firefox. 1Password app and mini-app would seemingly restart (symptom was I had to constantly re-enter my master password).

    I rebooted the computer just to make sure it wasn't me. This is on a iMac (Retina 5K, 27-inch, Late 2015) 17,1 running macOS Mojave 10.14.3 (18D109)

  • Also rolled back. What you are trying accomplish with a redesigned Mini is great, but not at the expense of a crashing main app and unusable add-on for a browser that cannot auto-fill.

    When you believe these are tested and fixed, note that in the beta notes and I'll climb on board again. Thanks.

  • No filling of my credentials in Safari.

    I have to return to "copy & paste".

    Previous beta did not have this bug.

    1Password Version: Not Provided
    Extension Version: Not Provided
    OS Version: Not Provided
    Sync Type: Not Provided

  • Same here. 1Password 7 Version 7.3.BETA-1 (70300001) not filling in username/password in [email protected] either. Previous beta did not have this problem.

  • Same here. On 1Password 7 Version 7.3.BETA-1 (70300001) in Safari and Mozilla Firefox no autofill. Double clicking does not work.
    I have to drag or copy paste. It's much worse than before.

  • I also have this problem.

    No autofilling

    also missing options for save new/update

  • I have this too...
    Also the helper behaves unexpectedly: if I click on edit the left sidebar disappears and does not come back, even after save...

  • Beta 1 of 7.3 crashed a couple of times. The new mini got a purple border twice. But the biggest problem is that it does not fill in my credentials neither via CMD + # nor via the button (or by pressing enter) in the new mini.

    I’m using mac OS Mojave 10.14.3 (German). The behavior is the same on both of my Macs (MacBook Pro and iMac).

    Send a diagnostic report a couple of minutes ago.

This discussion has been closed.