Icon missing from Safari toolbar


Team Member
This discussion was created from comments split from: 1password Safari extension broken.


  • Not getting 1P icon in Safari toolbar. Extension shows in Safari Preferences and is checked. It doesn't appear in Customize Toolbar.

    Mac Os 10.13.6
    Safari 12.0.3
    1Password 7, Version 7.3.BETA-4 (70300004), AgileBits Beta

  • Similar problem to TonyCr46. No 1P icon in the toolbar, but extension fails to load from the App Store extensions (it was installed and working fine yesterday).

    macOS 10.14.3
    Safari 12.0.3 (14606.4.5)
    1Password 7, Version 7.3.BETA-4 (70300004), AgileBits Beta

  • brentybrenty

    Team Member

    Since you're both using the beta, I've moved your posts to that category of the forum so we can look into that particular issue. Can you tell me the steps leading up to encountering the issue?

  • Yeah, this is the better forum :) For me the steps were:

    1. Previous version before March 20 working just fine.
    2. BETA-4 autoinstalls itself (with my permission).
    3. Safari no longer works (the extension has disappeared) and the extension does not (re)download (the App Store download icon shows the download starting but the progress bar stays at zero).
  • rudyrudy

    Team Member


    There appears to be a few confusing things you list in #3.

    The extension isn't a downloadable thing, its part of 1Password itself. So I'm curious what you're attempting to download there. You also mention the App Store, which doesn't have Betas, so i'm not sure how that's factoring into your description of step 3 here.

  • Well, here's the full workflow.

    1. Go to a page with a saved password.
    2. Click Command + '
    3. Get a prompt from 1Password Mini saying Open extension preferences in Safari
    4. Click the prompt, nothing happens.
    5. Alternatively, go to Safari Preferences -> Extensions -> More extensions (ending up in App Store) and see the 1Password extension there, which does not download.
  • brentybrenty

    Team Member

    @Killeri: What Rudy is saying is that there is not extension to install. Safari should be grabbing it from 1Password's app bundle. Have you -- or some other software -- modified the 1Password app? It might be a good idea to drag it to the Trash, restart your Mac, and the install a fresh copy:


    You should then see it in Safari Preferences > Extensions when you open Safari. If it's still not there, it won't work, and something may be wrong with Safari itself.

  • Uninstalling and reinstalling the beta did solve my problem. And no, I haven't modified the 1Password app in any way, the problem did happen immediately after upgrading to the current beta.

  • LarsLars Junior Member

    Team Member

    @Killeri - I'm glad reinstalling 1Password 7 for Mac beta seems to have done the trick for you -- but definitely keep an eye on things and let us know if you have any additional difficulties. :)

  • This problem resurfaced with the current beta, and reboots and uninstalls did not help this time. I'm dropping out of beta for at least until the next beta release, maybe the next release solves the issue completely.

  • LarsLars Junior Member

    Team Member

    @Killeri - OK, keep us posted. :):+1:

  • I'm currently tracking what may be a related problem. Just moments ago 1Password popped up the warning to "turn on ..." (as posted above). I unchecked and rechecked the extension and proper operation resumed.

    This is the second instance (that I recall) of this happening. With the fast pace of beta 1Password and Safari Technology Preview versions, I can't recall the exact circumstances of the previous occurrence. (I run on the bleeding edge on this machine.)

    I will try to track any future related updates correlate what I can, reporting as data is available.

  • LarsLars Junior Member

    Team Member

    @xz4gb8 - sounds good. :):+1:

This discussion has been closed.