Importing passwords from the Firefox password manager

I was able to install the beta extension for firefox. When I used the "import saved firefox passwords" nothing was saved to 1password.I have tried exporting firefox passwords using Firefox passort exporter to a csv file when I import to 1password i garbage.. how can i import my firefox passwords? I am running firefox 12.0 and this is on a Mac running Lion 10.7.3

Thanks

Comments

  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, nx01. Thanks for taking the time to contact us. I'm sorry that you are having this problem.

    Can you tell me if you get a "1Password Import Results" page like this…

    20120504-j4nfrne4qed29k2spuyb7617jg.png
    …when you click the "Import Saved Firefox Passwords" button?

    20120504-e9i9gbk4ry399bee448cms7p5x.png



    Does it indicate that your passwords have been imported?

    Are the Login items just not showing up in the main 1Password application, or are they not even showing up in the 1Password Firefox extension?

    Try doing a search in the extension for one of the domain names listed in the import results. You don't need to do anything special, just open the 1Password extension and begin typing to search.
  • No I do not get the 1Password Imported Results... when I go to the extention and click settings and then Import Saved Firefox Passwords it does not indicate anything after clicking it. When I search in the extention nothing is found.
  • khadkhad Social Choreographer

    Team Member
    edited May 2012
    Please try disabling all your other extensions to see if there is a conflict somewhere.

    If that alone doesn't work, while the other extensions are still disabled, try completely removing and reinstalling the Firefox extension. Other browsers automatically remove the SQLite file, but you will need to do this manually when using Firefox:

    1. In Firefox, select **Tools > Add-ons** from the menu bar.
    2. Click the **Remove** button to remove the 1Password extension.
    3. Quit Firefox.
    4. In Finder, select **Go > Go to Folder** from the menu bar.
    5. Copy and paste the following path and press Return:

    ~/Library/Application Support/Firefox/Profiles
    


    6. Move the [font=courier new,courier,monospace]OnePassword.sqlite[/font] file you see there to the desktop.

    Once everything is working well, you can safely move the [font=courier new,courier,monospace]OnePassword.sqlite[/font] file on the desktop to the trash.

    If you're still having trouble, could you please send us a Diagnostics Report?

    In 1Password 3.8, just select Help > Troubleshooting > Diagnostics Report from the menu bar.

    If you are using 1Password 3.9 (from the Mac App Store), you'll need to follow the instructions here:

    http://support.agile...lebits-help-you

    Then attach the entire file to an email to support AT agilebits.com.

    Please include a link to this thread in order that we might more quickly "connect the dots" when we see your Diagnostics Report in our inbox.

    Please do not post your Diagnostics Report in the forums, though.
  • Do I need a license to be able to import my firefox passwords? I am in my 30 day trial period. In the diagnostic report ..No 1Password 3 for Mac license was found. You cannot add more then 20 items in trial mode.'' and I do have over 20 items.
  • khadkhad Social Choreographer

    Team Member
    Hm. That may have something to do with it if you are trying to import more than 20 passwords from Firefox. I cannot say with certainty. We can certainly investigate further once we receive your Diagnostics Report. I don't see it in our inbox, but it is possible that you sent it from an email address different from the one you used to sign up for these forums. That is all I had to go on when searching for it.
  • Report sent again.
  • khadkhad Social Choreographer

    Team Member
    Thanks! It looks like you hadn't yet sent it when I posted earlier. We'll continue to work with you via email so as not to add confusion to the communications.
This discussion has been closed.