Chrome extension touch ID unlock?

nemanjahhnemanjahh
edited February 22 in 1Password in the Browser

Hey guys,

is there a way to unlock 1Password Chrome extension with touch ID? I'm using my touch ID for desktop app and it works perfectly but in chrome extension I have to type my really long password every time, which is really annoying. ¯_(ツ)_/¯


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • btw, I'm using latest update for 1Password app, also for extension, Chrome is running on latest version as well. Mojave is fresh too.

  • is there anyone who can answer my question?

  • brentybrenty

    Team Member

    @nemanjahh: Yes. But this is a support forum, not a chat room. And we try to reply to threads from oldest to newest, so when you keep replying to yourself, you're pushing yourself back up the the newest at the top. :blush:

    We've supported Touch ID on macOS since day one in 1Password for Mac and its companion extension. This will take you through setting up and using that:

    Use Touch ID to unlock 1Password on your Mac

    I hope this helps. Be sure to let me know if you have any other questions! :)

  • What the OP asked was about touch ID with the Chrome extension. I have the same question. Touch ID does not work with the Chrome extension for Mac as far as I can tell. Is this true? if not, how to activate?

  • LarsLars Junior Member

    Team Member
    edited June 2019

    @luckyday - if you're using the "desktop app required" version of our 1Password extension for Chrome, then the extension and the main app will unlock simultaneously: unlocking one unlocks the other. My suspicion is that you may have installed 1Password X instead? If you visit chrome://extensions, what is the version number listed? It should be 4.7.x if you're using the "desktop app required" version. It will be 1.15.x if you're using 1Password X. Let me know what you discover. FYI, there is currently no way to unlock 1Password X with Touch ID, so if you want this feature, you'll need to use the standard extension.

  • Thanks @lars this solves the touch id issue

  • LarsLars Junior Member

    Team Member

    @nemanjahh - you're quite welcome! Glad I was able to assist. :)

  • I have the 1PasswordX installed in Chrome. Should I delete it and install the the desktop app required" version of our 1Password extension?

  • ag_anaag_ana

    Team Member

    @glittermom:

    If you want the browser extension to unlock automatically when you unlock the desktop app, then yes.

    Alternatively, if you are more adventurous, you can use 1Password X Beta and activate Desktop App Integration, so the browser extension can follow the lock status of 1Password for Mac, like the traditional extension.

  • HenryHenry

    Team Member

    On behalf of ag_ana, you're welcome, @glittermom. More on Desktop App Integration here, currently in beta for 1Password X on Mac. It'll bring Touch ID support and more to 1Password X, so we're (understandably) quite excited about it. :)

  • Just to Chip in.

    I had this issue as well, and this thread solved it.

    Thank you!

  • ag_tommyag_tommy

    Team Member

    I'm glad to hear that this thread helped you out. :)

  • I installed 1Password X Beta on Chrome and Touch-ID doesn't work. It still prompts for a password. Touch-ID works fine in FireFox with the beta extension. Do I need to enabled another setting within the browser to enabled this?

  • ag_tommyag_tommy

    Team Member

    @ryin_hobs

    Please quit 1Password completely, along with Chrome, and restart both.

    1. Hold down the option key and click the 1Password icon on the right side of your macOS menu bar and select Quit 1Password Completely.
    2. Right-click on the Chrome icon in your dock and select Quit.
    3. Launch and unlock 1Password.
    4. Open Chrome.
  • Thanks for the tip. Turns out I needed to install the 1Password Beta desktop app as well. It's working now.

    Just funny how the Firefox extension didn't need the beta app, but Chrome extension did.

  • ag_tommyag_tommy

    Team Member

    Glad to hear your up and going. We are here if you need us.

  • @Lars Thank you! I had been frustrated by this for so long and now it's sorted.

  • BenBen AWS Team

    Team Member

    Thanks for the update @zjoel. :)

    Ben

  • @ryin_hobs Was Touch ID feature removed from 1password X beta? I have 1PX beta 1.23.0, and 1P7 for Mac OS X 7.7.1.BETA-3 and I followed your instructions above to quit and restart everything, and still no Touch ID when using 1PX?

  • @zebsola Yes. It was removed back in August. You can read about it in this forum post: https://1password.community/discussion/115228/temporarily-removing-desktop-app-integration

  • @ryin_hobs Ah. Hopefully back by the end of the year still, then. Thank you!

  • ag_anaag_ana

    Team Member

    Indeed, our developers are working on it :)

  • @ag_ana Any update on this?? it was removed 6 months ago!! This is something I really miss.

  • ag_anaag_ana

    Team Member

    Not yet @pducharme, but our developers are working on this :+1: We are all excited to see this feature back.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file