App Asking To Save Already Saved Paswords

Getting frequent requests to save passwords on sites that are already saved in 1Password. This is when the app is closed. It used to do this a lot before but I thought one of the prior updates had actually corrected this. I know this won't happen if the app is open but I seem to remember that it was corrected even if it's not open. I'm using Version 3.9.5 (39500.018).

Comments

  • khadkhad Social Choreographer

    Team Member
    Sorry you're having some trouble, pappjo. Let's try to get this sorted out for you.

    Having the main 1Password application open or closed makes no difference. There is a background process that runs.

    Can you confirm for me that you are seeing the prompt when filling the password with 1Password? If you fill it manually or your browser's password manager is filling it, you may be prompted to save the password.

    We recommend disabling your browser's built-in password manager.

    Please let me know what you uncover.

    Cheers,
  • This only happens when Safari autofills or I manually fill in the info. I don't get this message if 1Password fills everything in. However I had thought that in some previous version of 1Password that this message no longer appeared even when Safari autofilled the field. I remember when I first started using 1Password this always happened unless I had 1Password open and maybe I'm confused but I think one of the versions actually stopped this from happening when the password had previously been saved.
  • khadkhad Social Choreographer

    Team Member
    edited May 2012
    This only happens when Safari autofills or I manually fill in the info. I don't get this message if 1Password fills everything in.

    This is expected behavior. 1Password can only perform its check to see if there is an existing Login item if it is also the one doing the filling of the password.

    We have always recommended disabling browsers' built-in password managers for this and other reasons:

    http://help.agilebit...n_autofill.html

    If you disable your browsers' insecure password managers, use strong passwords, and fill them in via 1Password everything should be A-OK. :)

    You can also disable autosave for specific domains if that suits your needs.
    20120515-kjq3m24jeaqarqaj25tu6ywxyt.png
This discussion has been closed.