Form filled incorrectly in a specific site

LockerLocker
edited May 2012 in 1Password 3 – 6 for Mac
1PW 3.8.19
OS X 10.6.7

Safari 5.0.5
Firefox 11.0


When trying to fill a form in <http://registration.paragon-software.com/VM_Compact_GOTD.html>,
the email address is being filled not only in the field following "Email", but also in the fields following "First Name", "Last Name".

Previously, it used to work ok. That was before the site added the field "Title" (and perhaps other invisible changes). I did save the form to 1PW again, but upon calling 1PW to fill it again, the same problem happen.

The problem appears both in Safari and in Firefox on Mac.

Any idea why?

PS: In case the URL is not be available after today, I've attached the html page.

Comments

  • khadkhad Social Choreographer

    Team Member
    edited May 2012
    Thanks for reporting this, Locker. I wasn't able to that particular URL to come up, but I was able to save and fill a sample Login at the site's login page here:

    https://www.paragon-software.com/login

    1. Enter your credentials, but DO NOT submit the form.
    2. Click the 1Password button in your browser's toolbar, and select the "+" button in the upper right hand corner.
    3. Change the title and make any notes (if desired).
    4. Click the Save button in the upper right hand corner.

    As I think you are already aware, manually saving a login can be useful for logins that are either problematic to begin with or were once working but have since stopped. Doing this allows 1Password to refresh everything it "knows" about the page. Login pages often change as websites are updated and this can be a necessary but very useful tip. :)

    If you are still having trouble, please try disabling autosubmit for that Login and let me know if that resolves the issue. Since I don't have an account there, I was not able to verify autosubmit for the form.

    20111213-br4s3yshka286wsaxr16ty49ex.png

    I hope that helps. Please let me know.
  • First,as always, thanks for the reply.

    The URL that you have mentioned does behave ok. The one that I've originally mentioned (and other similar to that) does have a problem. As a side note, those URLs are only for one day only, so unless you try it at the same day, you cannot see them anymore. THEREFOR, I did capture that page html. Please see it attached in my original post.

    I did perform all the steps that you have mentioned. also, I usually disable the autosubmit.

    As a test, i opened the html file that I saved to the disk. As the domain is file://..., my saved 1PW entry didn't fit of course, so I made a new 1PW entry, using the "Save as" manually. Refreshed the page, to get an empty form, and applied the 1PW entry 9without submitting of course).

    Result: Incorrect fill. e.g., in Safari, the field for "First Name" got the value of the field for "Email", etc, as I mentioned in the original post.
  • khadkhad Social Choreographer

    Team Member
    I was overly optimistic that I had arrived at a successful solution. :)

    You mention that the link is only valid for one day. How would I go about finding the new link every day? The URL itself looks fairly static.

    I'm not able to save a Login for the local file and am running out the door. If you don't have a link I can use, I'll throw it up on our server quickly to test it more easily.
  • khad wrote:

    I'm ... running out the door


    I hope you are not reading this post right now (well, not now which is later, but now immediately after I am going to post it) (giggle)
    I hope you had a good weekend!

    khad wrote:

    You mention that the link is only valid for one day. How would I go about finding the new link every day?


    It's not every day, but once in few months, when they decide to give a free license... If it was every day, I might have memorized the info that I want to type :)


    khad wrote:

    The URL itself looks fairly static.

    I'm not able to save a Login for the local file ...

    Hmm, I was able to do that... strange.

    khad wrote:

    If you don't have a link I can use, I'll throw it up on our server quickly to test it more easily.


    Looking forward to read about your findings. Thanks.
  • khadkhad Social Choreographer

    Team Member
    edited May 2012
    Had a great night last night! After running out "the door" I got to meet Robbie Krieger from "The Doors". He's got a new band starting called the Roadhouse Rebels. Very cool stuff. :D

    As for the login page, I've been testing it, and I don't know why I didn't catch it before, but there is no password field on the page. I'm not one of the developers, so I don't know all the details. However, I know that 1Password always looks for a password field when saving/filling Login items.

    So...I filled the page with my fake Identity item, and it worked great. ;)

    Give it a try and let me know how it goes when you fill an Identity item instead of a Login item.
  • khadkhad Social Choreographer

    Team Member
    Unrelated, I also just noticed your version numbers above. I'd encourage you to update your browsers to get the latest security fixes, but you probably already updated since that original post.
  • khad wrote:

    there is no password field on the page.


    Indeed. I was/am using 1PW just to fill the form with my info (similar to filling credit card info).


    khad wrote:

    So...I filled the page with my fake Identity item, and it worked great. ;)
    Give it a try and let me know how it goes when you fill an Identity item instead of a Login item.


    hmmm... so you've used Identity instead of a Login entry. Interesting. But I don't recall that the iPhone version has Identities. Does it?

    If you use the Login entry, does it fail the same way that I had? (It used to be working right in a previous version of their web page).

    khad wrote:

    Unrelated, I also just noticed your version numbers above.

    I am 'stuck' with OS X 10.6.7 (hardware issues. long story), so I cannot get Safari higher than 5.0.5 :(
  • khadkhad Social Choreographer

    Team Member
    hmmm... so you've used Identity instead of a Login entry. Interesting. But I don't recall that the iPhone version has Identities. Does it?

    Identities are not supported in 1Password for iPhone at this time, but it is definitely on our radar.

    If you use the Login entry, does it fail the same way that I had? (It used to be working right in a previous version of their web page).

    It may have worked previously, but right now the current form is exactly what an Identity item is designed to fill and not at all what a Login item was designed to fill. As I mentioned earlier, there would need to be a password field, but there is not one.




    [font=helvetica, arial, sans-serif]
    I am 'stuck' with OS X 10.6.7 (hardware issues. long story), so I cannot get Safari higher than 5.0.5 :([/font]




    Yikes! I hope you are able to get it resolved. Running an unpatched OS and browser can be hazardous to your Mac's health. :(

    Stay safe out there.
This discussion has been closed.