Error: Unknown is connected but its code signature could not be verified

I'm using Windows 10 with Chrome. This is a new error. Chrome is up to date and I restarted the PC.
I realise I am using an old version of 1Password. I paid $48.99 for a family license in October 2014. I'm therefore not on the subscription model. The Chrome extension also no longer works but I assumed that was related to not being a subscriber.

1Password Version:
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Dropbox



  • Yes, I'm also getting these error dialogs. I have the version of 1Password for Windows on Windows 10. The issue with the Chrome extension not working is related to a change in Chrome and because Agilebits sadly decided to not update V4 anymore I guess you have to live with it or buy the new version... I think there are a number of other threads discussing that.

    However, the "Unkown is connected..." error is relatively new issue, at least for me. Very annoying because I get it every time I log in to a site (copying credentials from 1Password). Hopefully someone from Agilebits can explain whats going on?

  • AGAlumBAGAlumB 1Password Alumni

    @Anthony3737: Thanks for reaching out. I’m sorry for the confusion! I'm actually a bit confused by the timing, as Google changed their certificate used for code signing back in February:

    1Password 4 doesn't support Chrome 72 or later (but 1Password 7 does!)

    However, "Unknown is connected" sounds like 1Password 7. Do you maybe have both installed?

  • AGAlumBAGAlumB 1Password Alumni

    @macke: While upgrading is recommended, for the same reasons you (presumably) update your OS and web browser, if you're going to stick with 1Password 4 there are a number of other browsers which have not changed their code signing and still work with that -- for example, Firefox and Vivaldi. Cheers! :)

  • I am having the same problem with Chrome Version 75.0.3770.100 (Official Build) (64-bit) and 1Password version However, when I select the "Check for new version", it tells me that I am using the latest version of 1Password. How do I upgrade to Version 7?

  • LarsLars Junior Member

    Team Member

    @dreamer94 - I'm sorry for the confusion. The updater says that because you are using the latest version...of 1Password 4 for Windows. Because 1Password 7 for Windows is a completely new version and also a paid upgrade, we don't put in-app upgrade prompts into older versions because we don't want people to feel "tricked" into upgrading and then learning the new version isn't a free update.

    However, you can visit our downloads page and grab a copy of the installer for the current version of 1Password 7 for Windows, then follow these instructions to upgrade. Let us know how you get on! :)

  • Hi, I don't have both 1Password4 and 1Password7 installed, just 1Password4. Am I right in thinking I can upgrade from 1Password4 to 1Password6 on my existing deal? Would that fix this?

  • @Lars, Thanks for clarifying that. I have found the 1Password help to be almost completely useless in figuring this out. Every time I tried to search for information, the web site directed me to buy something, which I (apparently mistakenly) thought I had already purchased. Similarly, the link from the error message I received took me to a screen that offered only the option of restarting the browser or restarting the computer, both of which I had already tried. I will purchase version 7 and see how it goes.

  • AGAlumBAGAlumB 1Password Alumni
    edited June 2019

    @Anthony3737: 1Password for Windows version 6 isn't available. It was a brand new app that worked only with 1Password memberships, and has been superseded by version 7, which added support for local vaults:

    1Password 7 for Windows: The Best Ever

    If you have a 1Password membership, 1Password 7 is included. Otherwise it is a separate purchase.

  • AGAlumBAGAlumB 1Password Alumni

    @dreamer94: I'm sorry that you've had some trouble identifying the issue you were having, but I'm glad you got in touch; that's what we're here for! If you have any other questions along the way, just let us know.

  • @brenty: I only have 1Password 4 installed on Windows but I am using 1Password 7 on my mac (both are standalone versions). But I guess that has nothing to do with this.

    Also, I remember the day when the 1Password filling feature stopped working due to the change in Chrome, but I do not recall that I ever got this error message back then. Seeing this error message seems is relatively new for me.

  • bundtkatebundtkate

    Team Member

    While I can't say for sure what triggered this error specifically, @macke, I've snagged some logs from enough folks running into this to know it's got the same root cause as when Chrome 72 broke compatibility. The reason filling in Chrome doesn't work is that Chrome's code signature changed and now 1Password 4 can't verify it. That's what this error means as well, though it is a different presentation than what we saw at first and it's likely something has more has changed to lead to this change in behavior. Regardless, if you remove the 1Password extension from Chrome, it should get rid of that message.

  • When I purchased the family license, I thought it would continue to work into the future. Will your team please release an update for version 4 to fix this signature issue?

  • AGAlumBAGAlumB 1Password Alumni

    @lukestokes: You can continue to use your 1Password 4 license indefinitely, and it will continue to work with all supported browser versions. Chrome 72 is not one of them, as it was released almost two years after 1Password 4 was discontinued. Newer versions of other browsers which have not changed their security certificates will continue to work though (e.g Firefox, Vivaldi). If you want to take advantage of the work we've done since then to support newer browser releases and OS features, you'd need to upgrade.

  • Hey. If I do upgrade from 4 to 7, will my vault still be readable by version 4 software or will it be reformatted?

  • AGAlumBAGAlumB 1Password Alumni

    @HannGu: 1Password 4 supports OPVault as well, which is what 1Password 7 uses as a standalone purchase. I can't guarantee that it will be backward-compatible indefinitely as we may evolve the format in the future. But certainly if you're talking about trying it for a bit to test drive, you could just as easily go right back to using your original vault with 1Password 4 as you have been if needed.

  • I'm getting this error as well, running v4.6.2.626. For some reason, my 1Password About screen also now indicates that I am running in "DEMO mode (expired on Thursday, April 23, 2015)" when in fact I have a paid license. Is this a side-effect of the change to Chrome, or something else?

  • OK, entered my license key and it's out of demo mode. "Registered to:" is blank though, on both my computers. Is that ok?

  • LarsLars Junior Member

    Team Member

    @Stivan - it's fine in terms of functionality. A valid license key is all that's required; the name on the license doesn't affect the ability to authorize the app and unlock all features.

  • Thank you

  • AGAlumBAGAlumB 1Password Alumni

    Glad Lars was able to help! :):+1:

  • brenty, Can you confirm exactly why users running 1Password4 on Windows are seeing this message?

  • AGAlumBAGAlumB 1Password Alumni

    @bruce_cs: I can't, because there are many possible causes:

    • You're using a browser that was never supported
    • You're using a browser which was supported previously, but has changed its code signature since then
    • You're using "security" software that's interfering with 1Password's ability to verify the browser
    • You're using a browser that was modified or damaged
    • You're using a "browser" that's really malware
    • You're not using the appropriate communication method (Native Messaging for modern browsers, which needs to be enabled in Help > Advanced)

    There are probably other edge cases I'm not thinking of right now, but those are the most common causes.

  • Sorry, my scenario was woefully lacking details. Specifically, the situation is this:

    Machine running Windows 10, using Chrome (fully updated to current version). This is an existing 1Password4 install which was working as expected up until Chrome 72 was released. Chrome on this endpoint was updated in January this year when 72 went live. The message in the screenshot was received this month. No security software has changed during this time and the issue is not common among users configured similarly in our organization. I don't know this endpoint's current Native Messaging setting, but will confirm.

  • Confirmed: The Use Native Messaging option is enabled.

  • AGAlumBAGAlumB 1Password Alumni

    @bruce_cs: Ah, thanks for clarifying. This is the problem then:

    • You're using a browser which was supported previously, but has changed its code signature since then

    With the release of Chrome 72 in February, Google changed its signing certificate. 1Password 4 was discontinued back in 2017, so it has no knowledge of that.

    You can find more details in the announcement in this forum category:

    1Password 4 legacy support information

    But suffice to say I'd recommend upgrading, since the latest version of 1Password supports current browser and OS releases. Alternatively, you could use a different browser which 1Password 4 supports. I hope this helps. Be sure to let me know if you have any other questions! :)

  • Yep, aware that 1Password4 no longer works in Google Chrome in version 72 and newer. You're saying that "Unknown is connected" is indicating that the Chrome is connected to 1Password? Google Chrome being the "Unknown"?

  • AGAlumBAGAlumB 1Password Alumni

    @bruce_cs: Correct. 1Password 4 sees it trying to connect, but is refusing to communicate with it because it does not recognize it.

  • Excellent. Thanks for clarifying!

  • AGAlumBAGAlumB 1Password Alumni

    You're very welcome! Sorry I took the long way round. I didn't get what you were trying to find out at first. :lol:

  • Hi, So to clarify: having purchased the Mac and Windows versions of 1password 4, I will never have a possibility to use these in chrome on either platform, even though it's just a code signing update?

This discussion has been closed.