Chrome asking to add 1P extension but it's already there

Been using just Safari and 1P on my MAC. Just added the !P extension on Chrome. But don't understand fully why something is happening. If I click on the 1P icon on the right of my Chrome browser it works fine. But if I click the 1P icon on my MAC toolbar it tells me to install the 1P Chrome extension -- but it is already installed. Confused! See attached screen shot.

Thanks!


1Password Version: 1Password X
Extension Version: 1.15.3
OS Version: OS 10.14.5
Sync Type: ???

Comments

  • Hey, @BenBob.

    I'm not a 1Pass team member, but it's probably because you installed 1Password X (learn more about it), which is an extension that does not require the native app and thus, doesn't interact with it. In this case, you want the Browser Extension for the Mac App, which you can download from this page.

    If you want to know what are the differences between the two, check out this useful thread.

    I hope that helps! :)

  • Thanks arturoaubry, I'll look into that.

  • LarsLars Junior Member

    Team Member

    @BenBob - arturoaubry is correct -- if you look in your screenshot at your Mac's menubar, the presence of the 1Password mini icon there means you have 1Password for Mac installed. But if you look in Chrome, the presence of a color 1Password icon (instead of black & white) means you definitely have 1Password X installed. We're moving toward Desktop App Integration in the future - and in fact, it is already here in the beta versions), so that's something to keep in mind/look forward to. But for now, if you want the full integration between browser extension and local 1Password for Mac app, install the regular ("desktop app required") extension. :)

  • Thanks Lars. Not sure I fully understand but I haven't had time to read up. Been busy but I'll eventually get around to it!

  • brentybrenty

    Team Member

    No worries. We're here any time if you need us. :)

  • I'm having this same issue, but I've uninstalled the 1Password X from Chrome and still receive this install message window.

  • LarsLars Junior Member

    Team Member

    @ikre8 - I'm sorry for the trouble! If you're seeing the message that was posted in the original post in this thread, it means you likely have your default browser in System Preferences > General set to Chrome, and you don't have the standard ("desktop app required") extension installed and you're trying to use Go & Fill from within the main 1Password application. What happens if you click chrome://extensions? Do you see any 1Password extensions installed and active there? If not, please visit our downloads page and grab a fresh copy of the 1Password extension (NOT 1Password X), and install it. Actually, let's try this: even if you DO see the standard 1Password extension in Chrome, uninstall it and download/install a fresh copy from the above link. Let me know how that works for you.

  • I'm experiencing the same issue. I've reinstalled the (desktop app required) extension several times, I've restarted chrome as well as the 1 Password desktop app and I'm still receiving this message. This started happening after a recent 1 Password update.

  • Follow up - it's working now after restarting my Mac.

  • kaitlynkaitlyn

    Team Member

    Hi @zylum! I'm glad to hear a restart ended up resolving things. If the issue creeps back up, don't hesitate to reach back out. :)

  • If I'm intentionally using 1Password for Mac paired with 1PasswordX on Brave, is there a way to tell 1Password Mini that I don't want it to interact with Brave or advise me to download the regular extension?

    The filling engine is so much better in 1PX, but to create a new login manually, or make a manual edit, I want to be able to jump in from the menubar with mini and the native app UI rather than being punted off to the website, and every time it advises me to add the "regular" extension. And there's no obvious way of saying, "I know, show me the same UI you would show me if I was in Finder right now."

  • ag_michaelcag_michaelc

    Team Member

    Hey @colloidaddedrarefy. If you install the beta of 1Password for Mac and of 1Password X, as referenced earlier in the thread, then you can turn on Desktop App Integration, so the two do communicate and not tell you you're missing the extension.

    https://support.1password.com/getting-started-1password-x/#to-integrate-with-1password-for-mac

    Also, with 1Password X, you can right-click the toolbar icon and select "Save Login", if you're for some reason unable to save a login directly from the inline menu. Let me know if you have questions about any of this!

  • So incredibly frustrating. Do I need to uninstall 1password x and then install some 1Password for Mac? I cannot express my frustration over this strongly enough.

  • Also, since I had to sign up with 1password to comment here, and since a password for that was required, did 1password automatically save that password? This should be way more intuitive.

  • ag_tommyag_tommy

    Team Member

    @jps99jps99

    You can use 1Password X or our companion app extension. Could you let us know more about the issues you are encountering?

  • I have the same problem as the people above. I have 1Password installed on my Macbook, but I also have the little 1Password icon at the top of my menu bar and when I click it, it asked if I want to install the Chrome browser extension, which I already have. I'm guessing I've done something wrong with an installation, but I really expected this all to be pretty seamless. And it is not.

  • And this is another good one. I have 1Password installed on my Mac. I'm pretty sure I just saw it tell me that if I have 1Password installed on my Mac, I don't need a 1Password extension for Safari. Guess what? Just went to Safari and was told I don't have 1Password installed.

  • OK. Disregard the above comment about Safari. I just went into preferences and I think figured it out.

  • ag_tommyag_tommy

    Team Member

    @jps99jps99

    It sounds like a bit of confusion. No worries. The 1Password helper at the top of your screen in the menubar works with the companion app extension. If you have 1Password X installed, you should use its shortcut to bring up the on screen dialogue. Shift + Command + X. 1Password X does not communicate directly with 1Password 7. So 1Password 7 does not know about an extension being installed.

    If you want you can switch to our companion app extension.

    1. Disable 1Password X in the Chrome extension settings. No need to remove it.
    2. Download and install the companion app extension.

    --

    Due to the extensions' differences, you may first need to completely quit your browser and 1Password for communication to work properly.

    1. Quit your browser.
    2. Look for our helper in the menu bar near the WiFi indicator and the clock. Right-click on the helper and select quit 1Password completely. Wait a few seconds and then open 1Password from the Dock or the Applications folder.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file