Slow 1Password mini performance on Catalina

13»

Comments

  • @ag_ana It's slow all the time - been this way for a couple of weeks now. It's so frustrating that I am actively testing other apps and will cancel my subscription when I'm done.

  • ag_anaag_ana

    Team Member

    Sorry to hear that @JamesHenderson, but I certainly understand. If you would like, we can take a look at some logs for you too and see if we can spot anything there :+1:

  • edited September 2020

    @ag_ana happy to help diagnose. Have sent the logs #SDL-32839-148.

    This morning, Mini would not even open (for many attempts) until I opened the main app first.

  • ag_anaag_ana

    Team Member

    @JamesHenderson:

    Thank you! I confirm that I have managed to locate your diagnostics report in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: SDL-32839-148

  • @ag_ana thanks. The "it does not work at all" problem happens about once / week. Hopefully it's at the end of the logs,

    There was n point sending a diagnostic I thought about that too late and it was working again (after running the main app).

  • ag_anaag_ana

    Team Member

    Thank you @JamesHenderson, I have added this information in our system, so whoever will end up looking at the diagnostics report can have some more information on where to look :+1:

  • @ag_ana Hi, I sent the sample while it was freezing, #LIS-22676-964. I can also send a screen recording if you'd like, I think that will makes things easier.

  • brentybrenty

    Team Member

    Thanks! We'll continue the conversation via email. :)

    ref: LIS-22676-964

  • I am also having a performance issue on MacOS. I notice the problem anytime I update any records. Everytime I change a password, I get the multi-colored spinner and have to wait 3-5 seconds before I can interact with 1Password.

    This also occasionally happens to me when entering passwords as well, but it's not every time like updating a password is.

  • This is still happening to me. It happens on both my personal computer (Catalina) and my work computer (Mojave). I have 6 vaults in my personal/family team and 6 vaults in my work team (with 1000+ items in each).

    When I reboot my computer, everything is fine. I've also figured out that if I run pkill 1Password in my terminal, it's the same as restarting the whole computer—it kills the background 1PW tasks, which seam to have some sort of memory leak or something like that.

  • ag_anaag_ana

    Team Member

    @Aaron Gibralter:

    If you haven't done it already, I would like to ask you to collect some logs while this is happening, and email them to us. Perhaps we will be able to see from there why this is still happening to you :+1:

  • Hi @ag_ana I'm still waiting to hear from my work security team if they approve of sending the logs. In the meantime, I think I realized that this is only happening on my work computer where I have two teams' vaults configured. On my personal computer, I just have my family-team and I'm not seeing the performance issues.

  • edited November 2020

    Hi @ag_ana I just emailed the diagnostic report ([#MEG-77975-473])

  • brentybrenty

    Team Member

    Thanks! I'll get back to you there shortly. :)

    ref: MEG-77975-473

  • Things seemed to be fine for a brief moment in time, but it looks like my optimism a few betas go was unfounded. Performance is atrocious. Constant beach balls. It takes a good 5 seconds for mini to pop up (this happens frequently not just on first load). Searching is EXTREMELY slow. UI updating (such as hover effects) are spotty at best. These are just the "happen all the time and I can't really make an issue for each" issues. There are other issues such as the fact that the OTP codes are wrong more than they're right which I'm going to make a separate post for.

    Long story short, I have absolutely no idea what's happened to the code over the last year, but when you all dropped the "new old" mini and went to the svelte version, it was fast and it was amazing. Over the course of the last year something has changed and has caused it to be extremely slow. I don't know how much of this is Catalina and how much of it is 1Password.

  • ag_anaag_ana

    Team Member

    @jfelchner:

    Thank you for letting us know. Have you sent us the logs and the performance information too?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file