My entries aren't (consistently) synchronising across devices

I have a Win10 machine with 1Password v7.3.684 and Google Chrome 72.0.3626.121. I also use 1Password and Chrome on a Mac (with sync'd browser extensions in Chrome), and an iPhone with 1Password. I'm using the 1Password cloud vault (whatever it's called) to share one vault across all these instances of 1Password. I'm not using Dropbox or other 3rd party cloud storage solutions (to the best of my knowledge).
Generally, it works great. However I've found a significant lag between 1Password entries created on my Win10 machine and their appearance in my other devices. Generally it's a day or so before they are available on other devices, but presently I've been waiting 3 days for one particular entry to sync across.
The Win10 machine which created the entry was connected to the Internet at the time, and the entry is still visible within that Win10 instance of 1Password. However it still does not appear in the 1Password app on either my iPhone or Mac. All devices have working and reliable internet access.
Can anyone suggest a reason why this is occurring, and how I might rectify?
Many thanks!


1Password Version: 7.3.684
Extension Version: 4.7.5.90
OS Version: Win10
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @friskydingo! Welcome to the forum!

    If you are using 1Password.com to sync your data, are you able to see this item in a browser on 1Password.com? This will help us understand if the issue is between your Windows computer and the server, or between the server and your other Apple devices.

  • Hi!
    Well now you've opened a can of worms....
    I tried to login via the browser and found that I have 2FA enabled, however I've recently upgraded my iPhone and lost all my entries in Google Authenticator (which is where I think I had my 2FA linked). So although I am successfully logged into the 1Password app on my work PC, personal Mac and iPhone, I don't seem to be able to login to 1Password.com through my browser - I have the Secret Key/Code, but can't pass the 2FA test! :(
    How do you suggest I proceed? I feel stuck!
    Thanks in advance.

  • ag_anaag_ana

    Team Member

    @friskydingo:

    This might actually be part of the problem: if you have 2FA enabled for your 1Password account, and your Windows app was not able to authenticate because you lost your authenticator, sync will not work unless you enter the 2FA verification code.

    So let's start by taking care of the 2FA issue: as a first quick attempt, can you please try the following and see if it helps? Go to a browser where you’ve signed into 1Password before (it’s important that you try this on a known browser, even on a different device) and sign in to your account on 1Password.com. Then, click your name in the top right and choose My Profile. Finally, click More Actions > Turn Off Two-Factor Authentication.

    Should this not be enough, please let me know and I will send you some questions to verify your identity and temporarily disable 2FA on your account.

  • hi @ag_ana
    Although I have signed into 1Password.com on previous occasions (both in the office and at home), on both computers/browsers, I'm being prompted for my 2FA code. I presume that I must have cleared my browser data/cookies which has meant that my browser has effectively 'forgotten' my known login?
    Anyway, this means that I can't access My Profile and thus can't disable 2FA myself.

    So I think we'll need to go through the identification verification questions/process :(

  • ag_anaag_ana

    Team Member
    edited July 2019

    Thank you for the confirmation @friskydingo.

    I presume that I must have cleared my browser data/cookies which has meant that my browser has effectively 'forgotten' my known login?

    That's correct, if you clear your cookies, the browser will become not known again. Ok then, I will send you an email shortly so we can start the verification process without sharing personal information in a public forum ;)

    ref: DSH-84872-487

  • Hi @ag_ana
    So I've now managed to get into my 1Password.com account via the browser, and I can see that the entries I've created on my Win10 1Password instance are not visible. And I can now see that on my Win10 1Password application I have an "Offline Changes" section in the left-hand pane, which has 8 entries (all created in the last week or so), including the entry which is not replicated to my other devices.

    So it would seem that my Win10 machine is not syncing my entries outbound through/to my 1Password account.
    Looking in the logs, I see the following entries:

    I1364242141msThreadId(4)1Password::api:1692 │ 1364242143ms │ watchtower update started
    W1364243933msThreadId(4)1Password::api:1698 │ 1364243935ms │ Network request #430,234 failed in 2,009ms, status ConnectFailure (Unable to connect to the remote server)
    I1364243933msThreadId(4)1Password::api:1692 │ 1364243935ms │ checking network and applying any changes
    I1364244107msThreadId(4)1Password::api:1692 │ 1364244110ms │ network configured in 174ms
    W1364244108msThreadId(4)1Password::api:1698 │ 1364244110ms │ Network request #430,235 timed out in 1,949ms
    W1364246641msThreadId(4)1Password::api:1698 │ 1364246644ms │ Network request #430,237 failed in 2,011ms, status ConnectFailure (Unable to connect to the remote server)
    I1364246642msThreadId(4)1Password::api:1692 │ 1364246644ms │ checking network and applying any changes
    I1364246706msThreadId(4)1Password::api:1692 │ 1364246709ms │ network configured in 64ms
    W1364246707msThreadId(4)1Password::api:1698 │ 1364246709ms │ Network request #430,236 timed out in 2,158ms
    I1364247402msThreadId(4)1Password::api:1692 │ 1364247404ms │ watchtower update completed

    These log entries are repeated hundreds or thousands of times, over the past 2 weeks or so. There are no logs before 19-July-2019.

    How should we troubleshoot further?

    Many thanks!

  • bundtkatebundtkate

    Team Member

    As Ana mentioned, @friskydingo, the issue may be that since you have 2FA enabled for your 1Password account, and your Windows app was not able to authenticate if you didn't do so before your lost your authenticator. Again, sync won't work unless you have completed 2FA in your Windows app at some point.

    With that said, that doesn't look like it's the problem based on the logs you shared. Those indicate 1Password isn't able to communicate with the sever at all. Depending how long this has been the case, your Windows app may still not have been able to authenticate with 2FA, but that's a bridge we can cross when we get there. For now, I'd suggest looking at any security tools you have installed, like an anti-virus or firewall, and make sure that 1Password is whitelisted. If you use a VPN, try unlocking 1Password with the VPN off and see if these changes then sync. Let us know what you find. :chuffed:

  • Hi @bundtkate
    30mins ago I checked the WIn10 client and could see that it still didn't appear to be syncing (I could see that the 'Check for Updates' hadn't worked in 16 July. I went off to discuss some network/firewall troubleshooting with my team, and then came back to re-open 1Password and found that it had successfully contacted the update server and sync'd my 'Offline Changes'.
    I don't know what changed - maybe the app just needed to be open for longer than I had previously allowed before...? Who knows?!
    But passwords have definitely sync'd now, and the app is up to date.

    I'll need to re-enable 2FA to ensure it continues to work properly. Given I have 3 devices which use 1Password, is there any advice/recommendation to ensure that I enable 2FA without breaking the sync in any of them?

  • bundtkatebundtkate

    Team Member

    I wouldn't worry too much about 2FA, @friskydingo. I am horribly mean to our 2FA systems and am turning it off and on all the time to test things. What's more, I get lazy and decide to leave some of my devices not syncing at times because I don't want to dig my phone out of my purse after I've signed off for the day. So I leave them alone, then complete 2FA days after the fact when I need something and they've only rarely given me trouble. If my devices manage to put up with my foolishness, yours will be fine. If you want to be extra careful though, try to enable it when you have all devices at hand and unlock each right after you enable 2FA so you can complete it right away. :+1:

This discussion has been closed.