Google Chrome Extension "Looking for the 1Password Helper"

fletchnifletchni Junior Member

When trying to use the extension in Google Chrome I get the error "Looking for the 1Password Helper." I am PC smart, and am running the latest versions of everything (see below). I have tried all the steps in your help page, but to no avail. Same problem the whole time.

I have:

  • Uninstalled the extension
  • Restarted my PC
  • Checked that I have the latest version of Chrome (77.0.3865.120)
  • Checked that I have the latest 1Password App and Extension
  • Installed 1Password 7 again

BTW, the extension works on Edge. But I don't want to use Edge! :blush:

Please help!

Thanks, Nic.


1Password Version: 7.3.712
Extension Version: 4.7.5.90
OS Version: Windows 10 1903 (18362.418)
Sync Type: 1Password Account
Referrer: forum-search:helper

Comments

  • bundtkatebundtkate

    Team Member

    Did you recently upgrade from 1Password 4 by chance, @fletchni? What about BitDefender – any chance you use that on this PC? When you're having browser connection troubles, we'll often need to take a look at logs to figure out what's going wrong, but if you use BitDefender or recently upgraded from 1Password 4, there are a few cases of this I've seen recently and that have known fixes so we can give those a go before diving in deeper. :+1:

  • fletchnifletchni Junior Member
    edited October 2019

    Yepp. I finally took the plunge and upgraded from my older Mac license and Windows 1Password 4 and moved to a 1Password subscription!

    So, yes! This looks like it is a migration issue from Windows Version 4. (I had no problems with my Mac of course! ;) ) And no, we don't use Bitdefender.

  • bundtkatebundtkate

    Team Member

    It's not actually a migration issue, it's a registry problem. More recently, uninstalling 1Password 4 has been mucking up 1Password 7's registry entries. This should fix things up:

    1. Press Windows Key + R to open a run dialogue.
    2. Type 1Password --setup and press enter to run it.

    When this works, you should see the main app pop up with a little banner saying 1Password has been updated. It hasn't been, of course, but what we just did was rerun setup that runs at the end of the install/update process so we've tricked 1Password into thinking it has been. This will repair the registry and should get filling in Chrome working again. Make sure to restart Chrome and give it a go. Let me know if that sorts things out. :+1:

  • Hi Kate,

    Tried to to that because i'm in the same boat. I just recently updated from Windows 1Password 4.
    Your solution did not work:

    '1Password' is not recognized as an internal or external command, operable program or batch file. Press any key to continue . . .

    Nevertheless, i tried to run the setup again, bacause that's the result of what you are saying. That worked. No uninstall, just run the installer again and this: "When this works, you should see the main app pop up with a little banner saying 1Password has been updated."

    Hope this helps other users.

  • GregGreg

    Team Member

    Hi @JVCS909,

    I believe there was a typo and the command is supposed to be 1Password.exe --setup. Sorry for the confusion!

    Please let us know if you have any further questions, we are here to help. Thank you!

    ++
    Greg

  • Hi Greg, your fix worked for me! Running Windows 10

  • GregGreg

    Team Member

    Hi @MikeHouston,

    That is great! I am glad to hear that it worked. :)

    Please let us know if you have other questions, we are always happy to help.

    Cheers,
    Greg

  • edited July 2020

    Hi all - apologies for bumping an older topic but I'm having this exact same issue.

    Here's what I've tried so far:
    1. Uninstalling the extension, restarting my PC, then reinstalling the extension.
    2. bundkate's solution of pressing windows + r to open a run window, typing in "1Password --setup" (with no quotes). I receive an error that says "Error parsing arguments: opw-command-line\src\lib.rs:192 failed to parse command line".
    3. Greg's revised solution of pressing windows + r to open a run window, typing in "1Password.exe --setup" (with no quotes). I receive the exact same error as above in #2.
    4. Opening command prompt and typing in "1Password.exe --setup" (with no quotes). I receive an error that says "'1Password.exe' is not recognized as an internal or external command,
    operable program or batch file."

    I recently (just now) upgraded from 1Password 4 and imported my previous vault into my new account/app. The 1Password app opens on my PC with no issues and I can see everything here. I just can't get the extension to work. I'm on Windows 10 and I'm using Google Chrome.

    Any help would be very appreciated. Thanks!

  • ag_anaag_ana

    Team Member

    @Tripperson:

    Can you confirm what version of the 1Password app and the 1Password browser extension you are currently using?

  • Certainly!

    My 1Password extension version is:
    4.7.5.90

    My 1Password app version is:
    7.4.767 (I believe - I got this number by going into the app and selecting "Help" then "About 1Password...")

  • ag_anaag_ana

    Team Member

    Thank you for the confirmation @Tripperson! Can you please try the command "1Password setup" (without quotes and without the two dashes), and see if that works? I believe the command was updated recently, so since you are on the latest 1Password version, it's possible that this is why you are seeing that error message.

  • That new command worked - thanks so much!

    In case it helps anyone else who might have this problem, here's what I did to resolve it:
    1. Press Windows Key + R to open the "Run" window
    2. Type in what ag_ana said: 1Password setup
    3. Press Enter
    4. The 1Password app window will pop up on your desktop and ask you enter your master password. Do that.
    5. Once the 1Password app has opened on your PC. Try going back to your browser and clicking on the browser extension icon. If it works, then great!
    Note: My extension continued to error at this point saying it was "Looking for the 1Password Helper". If you're in the same boat, keep going to step 6.
    6. Uninstall the extension from your browser.
    7. Restart your computer.
    8. Do steps 1 - 3 again (running 1Password setup via the Run window). I don't know if this step is actually required, but it's what I did and I'm now fixed, so might as well.
    9. Reinstall the browser extension.
    10. Try again. It worked perfectly for me at this point.

    That's what worked for me so hopefully if anyone else has this issue it'll work for you too.

    Thanks so much to @ag_ana for your help! Couldn't have done it without you. =)

  • That new command did the trick - thank you so much!

    I had to fiddle with it just a bit more to get it to work, so if anyone else is in the same boat, here's the steps that worked for me:
    1. Press Windows Key + R to open the Run window.
    2. Type in what ag_ana suggested: 1Password setup
    3. Press Enter
    4. The 1Password app window will open on your desktop and ask you to enter your master password. Do that.
    5. Go back to your browser and try using the 1Password extension again. If it works for you, great!
    Note: Mine continued to error at this point, still saying it was "Looking for the 1Password Helper". If yours is still giving errors as well, move on to the next step.
    6. Uninstall the browser extension.
    7. Restart your computer.
    8. Perform steps 1 - 3 again (hitting Windows Key + R, typing in 1Password setup, then hitting enter). I'm not positive this step is necessary, but it's what I did and I'm now fixed, so might as well.
    9. The 1Password app window will pop up again asking for your master password. Enter it.
    10. Reinstall the browser extension.
    11. Try the browser extension again. At this point, I was fixed.

    Hopefully that helps someone else. Thanks again to ag_ana! I couldn't have done this without you. =)

  • ag_anaag_ana

    Team Member

    You are welcome @Tripperson! I am glad I could help :)

    And thank you for taking the time to write these instructions for other users, you are awesome!

  • I went through @Tripperson's 11 steps (thanks for spelling it all out!) and am still getting "Couldn't connect to 1Password" but I'm running 1Password 4 (yeah, yeah, it's a work machine admin'd by others).
    Windows 10 Pro-1809-17763.1577
    1P app v.4.6.2.626
    1P extension 4.7.5.90 on Chrome

    Hoping for a viable solution other than "you should really upgrade" because A. I know and B. I don't want to get IT involved.

  • BlakeBlake

    Team Member
    edited January 7

    Hi @ampersandwich (&🥪)

    Can you try opening up 1Password 4 for Windows, and then make sure that "Use Native Messaging Protocol" is checked as shown below?

    If it's already checked, go ahead and uncheck/recheck and then you'll want to click the "Restart 1Password Helper" option highlighted within the red bubble and see if that kicks things back into gear.

  • edited January 7

    Thanks, @Blake ! Use Native Messaging protocol was not checked, so I made the change, restarted the 1Password Helper, and no dice. Quit and did the Windows-R floopdy-doo, but still no love.

  • BlakeBlake

    Team Member

    @ampersandwich

    The 1password.exe --setup Run Dialogue bit won't help with 1Password 4 -- that functionality wasn't built in until 1Password 7. Sorry for the confusion there!

    Just so we're starting with a clean-slate after restarting the 1Password Helper, can you go ahead and give your machine a quick reboot and try once more? 🤗

  • A bit ashamed I didn't try that already, @Blake
    Anyway, this time I got a new and different error, so that's something! "Unknown is connected but its code signature could not be verified. Filling and other features are disabled until this issue is resolved." I'm using Chrome v. 87.0.4280.141 (Official Build) (64-bit)

  • BlakeBlake

    Team Member
    edited January 8

    How strange @ampersandwich 👀

    This error message suggests that you are using an unsupported browser. For security reasons, 1Password gets disabled when it sees an unsupported browser, so what you are seeing here can be normal, depending on the browser this is happening with. Since you mentioned that you're using the latest version of Google Chrome, we know that you're browser is completely fine, so the plot thickens...

    One last thing. Can you do a quick uninstall/reinstall of the 1Password Desktop Companion Extension within Chrome for me?

  • Oops, missed your reply until just now, @Blake ! Un- and re-installed, still getting the "Unknown is connected..." message. I want to note that I'm using the 1Password extension and not 1Password X because yeah, older version. :p

  • GregGreg

    Team Member

    Hi @ampersandwich, sorry for the ongoing troubles here! I know what is going on here.

    The thing is that 1Password companion extension for 1Password 4 for Windows will not work in the latest Chrome (Chrome 72+), due to updated code signature. See this article on our website for more information:

    1Password 4 for Windows won’t fill or save in Chrome 72 or later

    If you don't want to upgrade (although I would really recommend you to do so), you can try using Firefox instead. 1Password companion extension should work there.

    Otherwise, please check the following article on how you can upgrade:

    Upgrade to 1Password 7 for Windows

    Let us know if you have other questions. Thanks! :+1:

    ++
    Greg

  • @Greg Thanks for the clarification. Sounds like it's time for me to just upgrade already and bite the bullet with regards to the IT request that will require. Maybe they'll consider rolling out 1Password company-wide! //Mr. Burns plotting//

  • Dayton_agDayton_ag

    Team Member

    Hi @ampersandwich, that sounds good! If helpful, we have a handy guide for upgrading on our Support site, at the link below:

    Upgrade to 1Password 7

    If we can offer any support during the upgrade progress (or if your company has any questions about 1Password Business), feel free to reach out to us at [email protected]. :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file