1Password autofill inconsistent / not working from either the app or 1P mini

Hello,

I am the "organizer" for a 1Password 7 family account and am seeing the following issue on all of our family members' computers (all Macs) ever since upgrading from 1P 6 to 1P 7. None of us had these issues with 1P 6 – this is completely new. The current problem is a little bit difficult to describe, especially because it reproduces inconsistently, but I will do my best. Here is what happens:

  1. I log into 1P, either through the 1P Mac app or through 1P mini — it doesn't seem to make a difference which one.
  2. I find the account I want to log into and do any one of the following: a) double click on the item name in the list (this used to work), b) click the button for "Go" or "Autofill" (it is weird that what the button says here is inconsistent but whatever), or c) I click on "open and fill" next to the URL for the login.
  3. If I have done this within the 1P app, then a 1P mini window will open, but it does not automatically open the URL. In addition, within 1P mini, it does not automatically display the item I have just selected within the app. Instead it just shows my overall list – logins, notes, passwords, etc. all mixed together – without taking me where I want to go.
  4. If I go through 1P mini instead of through the 1P app, a similar thing happens. Once I have located the account I want to log into, I can go through the same steps outlined under #2 above, but nothing happens. Basically, the 1P mini window just "blinks" but it doesn't open the URL or do an autofill.
  5. The only way I can get 1Password to work properly is if I manually go to the website and choose "Autofill" from 1P mini and/or if I manually copy and paste my username and password from 1Password into the website. This is very annoying.

What's really weird though is that the behavior is not consistent. Some autofills will work at some times and not at other times. I have not been able to isolate any specific triggers. Again, all of this was working fine before the upgrade to 1P 7.

Troubleshooting: I have tried completely quitting 1P and also restarting my computer. I have turned off other browser extensions. Firefox (v.70) is my default browser but I also use Safari (v.13.02) – the problem is present with both. I sort of wondered whether the problem had to do with the combination of the 1Password browser extension and the 1Password X extension (PS: this dual approach is very confusing; I wish Agilebits would streamline). I wanted to test this, but turning off the 1P X extension doesn't seem to make a difference, and my system isn't letting me use just 1P X instead of the normal browser extension — I get an alert saying I have to install or activate the normal browser extension. Frustrating.

Although I personally can handle using a workaround (as shown in step #5 above) if it is 100% necessary, a bigger issue is that 2 people in our family membership group are elderly and the fact that the autofill feature isn't working anymore is really confusing and frustrating to them.

Can you provide any assistance on how to resolve the autofill issues I'm describing? Are there known software conflicts that might be causing such problems? Thanks in advance!


1Password Version: 7.3.2
Extension Version: 4.7.5.90 (1P extension) and 1.16.2 (for 1P X)
OS Version: 10.14.6
Sync Type: 1Password.com

«13

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @Ashiado ,
    Thank you for the very detailed report and all the extra information.

    What you are describing sounds like a currently known issue that we are tracking and working on fixing. It only happens in Chrome, and it is indeed intermittent and does not always occur, but when it does it is quite confusing. It can happen from within the desktop app, from 1Password Mini or even in your browser if you are already in the website.
    Until we release a fix, here's a workaround:
    1. Open your browser and get to the website you want to log into.
    2. Click the 1Password icon on the top right to open the 1Password window.
    3. Drag and drop the username/password from the window into the website's username/password field.

    By using the drag & drop method you will bypass this issue altogether and will be able to fill in your credentials quickly until we fix this.
    Another solution I can suggest is that you give 1Password X a try: https://support.1password.com/getting-started-1password-x/

    I have added your report to the dev's log, thanks again for reporting it in such a detailed manner. Let me know if you have any further questions.

  • Hi Yaron,

    Thanks for your response. Actually, I (along with my family) do not use Chrome at all — Chrome is not even installed on our computers. We're all using Firefox as our main browsers, with Safari as a backup.

    Regarding giving 1Password X a try, as I mentioned in my original post, unfortunately this is not working either.

    Since this same issue is affecting 4 different Mac computers, all of which I administrate, I assume that there is something in common about their configurations that is causing a conflict — I just don't know what it is. In case it helps in any way, the browser extensions I/we have installed and enabled in Firefox are the current versions of: 1Password extension, 1Password X, Disconnect, DuckDuckGo Privacy Essentials, HTTPS Everywhere, Privacy Badger, and uBlock Origin. We also are all using Intego VirusBarrier v.10.9.21 for virus protection. None of us has updated to Mac OS Catalina — we're all still on OS 10.14 — so it can't be a Catalina issue.

    Do you have an ETA on the fix for the problem described? I don't mind the workaround all that much, but it is super stressful for less tech-comfortable people (such as elderly parents) — and therefore also quite stressful for me. 1Password 7 has been out for quite a while already, so it doesn't seem like it can be a new bug. Thanks for any updates.

  • ag_yaronag_yaron

    Team Member

    Hey Ashiado,
    Thanks for the clarification. I was certain you are using Chrome, since your description is very similar to the issue at hand. Can you please confirm or correct the following:
    1. You open Firefox.
    2. You try to autofill in any way (open and fill / CMD+Backslash / Click on the extension and select "Autofill" etc...).
    3. Instead of autofilling, 1Password refreshes and shows up from the top menu bar of your Mac with a list of all the password you have, organized alphabetically.

    Is that what you are experiencing?

  • AshiadoAshiado
    edited October 2019

    Basically, yes, except that sometimes the autofill works and sometimes it doesn't... even for the same site login! It is really weird. So for example, yesterday I was able to log into a site from 1Password by just clicking the blue "Go" button, but today that same login did the refresh thing you described and didn't take me to the site or autofill! ..... The only other thing I can think of, but I haven't sufficiently tested it, is that maybe(??) it makes a difference whether I first enter my master password through the 1P app or through 1P mini. Not sure. I'd have to try this out in a more controlled way when I don't have other stuff going on. Thanks for the follow-up!

    PS: Question: is it a mistake for me to have both the 1P extension and the 1P X extension installed and activated? I am really confused about what the difference is between these and how they either do or don't work together... Thanks!

  • ag_yaronag_yaron

    Team Member
    edited November 2019

    Thanks for confirming, @Ashiado .
    I'd like to take a look at a diagnostics report from your computer so I can add that to the dev's log as well.
    Can you please create a diagnostics report on your computer and send it to [email protected], alongside a link to this discussion?
    Here's how to create a diagnostics report: https://support.1password.com/diagnostics/

    Regarding your other question, here are the differences:

    • 1Password companion extension (desktop app required) is our good old extension that has been with us for years now. It connects to the desktop app and allows you to autofill in your browser via the desktop app.
    • 1Password X is the newest extension we released, it does not connect to the desktop app but rather directly to your 1Password.com account, so it does not even need the desktop app to be installed on your computer. It has an enhanced autofill logic and workflow and shows up directly in the username/password fields in the websites you visit. You can learn more about how to work with it here: https://support.1password.com/getting-started-1password-x/

    You should not have both installed since it might get a bit confusing. I suggest you give 1Password X a try for a few days and disable the companion extension. If you like it - great. If not, you can disable it and go back to the companion extension :)

  • About the diagnostics report, I will email this first thing tomorrow morning.

    About 1Password X - unfortunately, on my end this extension does not seem to be working at all. As you suggested, I disabled the 1Password companion extension and left the 1Password X extension activated, but there is no icon showing up in the login fields of websites I go to — as an example, see the attached screen grab with the Trello login page. In addition, If the 1Password companion extension is deactivated and I go to 1Password mini, then things are not working that way either, so I'm stuck and can't fill in my passwords at all. The only way I can access my passwords again is to reactivate the 1Password companion extension. :(

  • ag_yaronag_yaron

    Team Member

    Thanks for the screenshot @Ashiado.
    Are you sure you activated 1Password X? It doesn't show up in the top right of Firefox where all extensions icons are, so I think it is either disabled (still), or something went wrong with it.

    If you are certain that you enabled it and it still doesn't show up on the top right or in login pages, please try removing it and then reinstall it again, see if that helps.
    Since 1Password X is its own app and does not talk to the desktop app, you will not be able to autofill in the browser via 1Password Mini and will see this message when you open it while Firefox is the active app - that's normal. With 1Password X, your workflow should start and end in the browser, but for that you need the 1Password X icon to show up on the top right ;)

  • AshiadoAshiado
    edited October 2019

    No, 1Password X really is/was activated - in the screen grab the icon for it was just covered up by the other popup window. Attached is another screen grab showing that this icon really is there. Unfortunately it just doesn't work... I should add though that when I click on that icon what happens is that a new browser tab opens up with a blank white screen. In other words this icon does not behave the way other Firefox icons in this row do, i.e., with dropdown options...

  • Of note - what I get when I click on the 1Password X icon is a blank screen in a new tab, but the URL shows this:
    moz-extension://45cce09b-6205-4542-a7f7-6afd70778030/app/app.html#/page/welcome

  • AshiadoAshiado
    edited November 2019

    Hi - I've just sent the diagnostics report to [email protected]
    Beforehand, I also tried uninstalling and reinstalling the 1P companion and 1P X extensions -- didn't make a bit of difference. Same problems as described previously. And just to reconfirm, sometimes the autofill problems happen repeatedly for some logins while not for others, but then — as happened just now(!!) — one login autofill will not work and then a few moments later it will again. So far I have not been able to isolate what is causing the change, but I can assure you it is very frustrating. I've been using 1P for many years and work in web design, so I have a little bit of background for helping to troubleshoot. Just let me know what you need from my end.

  • ag_yaronag_yaron

    Team Member

    Thank you kindly for the additional info @Ashiado .
    We will continue troubleshooting 1Password X in your support ticket. And yes, we know this bug is troublesome and intermittent, which is why it is taking a bit longer to fix.

  • Thanks for the follow-up.
    One thought/question: I wonder whether it somehow has to do with the upgrade from 1P 6 standalone to 1P 7 family? Maybe there is an old preferences file somewhere that is causing havoc? I'm just looking for what the common factor might be between my computer's configuration and that of others in my family group since we're all having the same issue.

  • ag_yaronag_yaron

    Team Member

    @Ashiado This is a bug that all Chrome users are experiencing with 1Password 7. I don't think you will find anything specific to your device. I experience it too :)
    This issue is a top priority for us at the moment and our devs are working on it every day, hopefully they will be able to pinpoint the problem soon and release a fix.

  • Yes exactly same issue happens in my chrome since update from 6>7 and this is BIG anonying!! I even thought to uninstall everything and change browser. This is that much anonying. If this is a known issue when do you guys to plan to fix this?

    On chrome it sometimes works if you refresh the site.. You open amazon, you try to fill it, it opens the mini instead filling, but sometimes if you refresh the amazon site and try again it works. This might help you

  • ag_yaronag_yaron

    Team Member

    @taskin Thank you for the additional info and for letting us know you are experiencing this as well.
    As I've mentioned, we're working on it at the moment, and hoping to release a fix shortly.

    Yes, sometimes refreshing works, and sometimes just waiting 5-10 seconds and then trying to autofill again works as well. Here are current possible workarounds or semi-solutions you can use:

  • AshiadoAshiado
    edited October 2019

    Note: I am having the exact same issue in both Firefox and Safari, so unfortunately switching browsers doesn't automatically provide a fix... and 1Password X isn't working on my computer at all, also regardless of browser

  • ag_yaronag_yaron

    Team Member

    @Ashiado You need to set your system's default browser to Firefox or Safari in order for it to not try and launch Chrome when you double click a login. If Chrome is still the default browser, when you double click a login or click on "Go" it will try to launch Chrome and you will experience the issue.

    Please go to System Preferences on your Mac, then to the General settings and change the default browser to Safari and see if you are still experiencing this.

  • AshiadoAshiado
    edited October 2019

    @Yaren, as mentioned at a couple of points earlier, I don't even have Chrome installed on my computer. The issue I am having has nothing to do with Chrome.... And: I am having the exact same issue regardless of whether I use Firefox or Safari.

  • ag_yaronag_yaron

    Team Member

    Hey @Ashiado ,
    Yes, thank you for reminding me. In any way, the instructions are still the same - change your default browser to Safari and see if it happens then :)

  • Just checked this again. It is the exact same issue if I make Safari the default browser instead of Firefox. No difference.

  • ag_yaronag_yaron

    Team Member

    @Ashiado then you are the first :)
    I sent you an additional email requesting more details on Safari.

  • Many thanks to Ashiado for raising these issues. I have had the same problems with autofill, have had them for months. I have a Mac mini (late 2014 edition). I have just upgraded to the Catalina operating system, but I experienced all the autofill problems Ashiado did with Mojave and things have not changed with Catalina. Autofill remains inconsistent, only working on a minority of websites, often requiring me to go to a site's log in page and autofill user name and password one at a time or copy and paste manually. Like Ashiado, there is no rhyme or reason to the sites where autofill works seamlessly and the ones where it fails. I am using Firefox and Safari only. CHROME IS NOT LOADED ON MY COMPUTER. On my computer, 1 Password has become nothing more than a place to keep my passwords, a list. It stores them securely but it does not help me interact with websites on the internet or save me time or make my digital life easier or more convenient.

  • AshiadoAshiado
    edited November 2019

    @Nick - Following the above conversation, I have had continued contact with @Yaron via email regarding this issue. It sounds like the 1P team is working on fixing the bug. In the meantime I am still trying to narrow down how and when it happens so the 1P team has more information to work with. Particularly because I have elderly parents calling me almost daily who are stressed out with this same 1P issue, I'm quite motivated to do what I can to help 1P find a solution.

    A couple of questions for you from my side: I have been trying to reproduce the bug in Safari — which was taking place for me at one time but has since (for some reason I can't identify) stopped. Although that is a good thing, it's also frustrating because I wanted to show the 1P support team that it was there. So question #1: Are you seeing this issue in Safari or only in Firefox? Does it make a difference whether Firefox or Safari is set to be your default browser?

    Question #2: I went through some troubleshooting with Firefox and a couple of things helped a tiny bit — not resolved, but slightly more consistent behavior. Specifically, what I did was a) remove the 1Password X extension (Tools > Add-ons), b) delete Firefox from my computer and then manually re-download and reinstall it (backup your bookmarks first), then c) open the 1Password app and go to the 1Password 7 menu and choose Install Browser Extensions... Reinstall the 1Password Extension (desktop app required). Do not reinstall the 1Password X extension. Once I had done all of this, what I noticed was that if I had a blank window open in Firefox and I went to the 1P app, then it worked if I double clicked on a login item in the list(!!!). However(!) if I did NOT have a blank window open in Firefox before I did this, then the annoying bug behavior showed up again. This was reproducible and I could toggle back and forth to watch it happen. Is this true for you too?

  • Give me a couple of days to try your suggestions. I will let you know if they have any effect.

  • ag_yaronag_yaron

    Team Member

    Thanks for the help @Ashiado :)
    It's worth noting that the Safari issue is not the same bug we're discussing here, it is rather a different issue that is probably solvable.

    Let us know what you find @NickJupiter .

  • I am computer developer myself with services like this. But please it should never never take that long for a paid product like this. We cannot work and all our team loses time because of such problems. I am not relaxed about this incident.

    Even our free products are expected to work as advertised. This problem exists prior my update to 1p 7 obviously and it has been already weeks.

    Sorry Yaron but do not give any food to your team unless this bug is fixed. We need to make business instead of writing with you guys here in this forum.

  • ag_yaronag_yaron

    Team Member

    Hey @taskin ,
    We are aware of the amount of users who are affected by this issue and it is a top priority for our devs at the moment. We're hoping to see a fix very soon.
    I do apologize for the inconvenience.

    Until such a fix is released, please do try one of the workarounds/alternatives:

    • Use the Drag & Drop method to fill in credentials in websites.
    • Try using Safari (you will have to set it up as the default browser of your system).
    • Try using 1Password X if you have an active account with us.

    Thank you for adding your input and feedback here. I have forwarded it as needed.

  • ag_yaronag_yaron

    Team Member

    Hey @ibrennan,
    I understand how frustrating this issue may become and we do hope to release the fix soon. We certainly do not recommend downgrading to outdated versions of 1Password such as 1Password 6, but if your mind is made up you can get it here: https://1password.com/downloads/mac/#legacy-downloads

    Perhaps it would be a better idea to download an earlier version of 1Password 7 before that issue appeared instead: https://app-updates.agilebits.com/product_history/OPM7

    In any way, like I said, we strongly recommend against downgrading, but the choice is yours.

  • AshiadoAshiado
    edited November 2019

    @ibrennan, I continue to have the same problem as described above, but here's what has worked for me:
    1) uninstall the 1Password X extension and then reinstall the regular 1Password (desktop app required) extension. (This is just one time - you won't have to do it every time.)
    2) open a browser window - empty or with another website loaded, doesn't matter
    3) now log into the 1P desktop app or 1P mini -- either one -- and choose a site login from your list.
    For me, if I do this, 1Password works normally. The only time it doesn't work is when I don't have any browser window open before using 1Password. In other words, on my end at least, it looks like the bug is linked to getting 1Password to kick launch a Chrome or Firefox browser window when no other window is already open. Ever since I figured out this "workaround", the issue has been much less annoying to me, but OF COURSE I am really hoping that 1P will issue a real fix as soon as possible.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file